Forum Clubic

[Serveur] Apache 2 (win32) : pb avec mod_ssl - lors d'un upgrade à la version 2.0.59

Saloute à tous :jap:

Je poste ça ici, mais si un modo trouve que sa place est mieux dans un autre forum, libre à lui de le déplacer :jap:

J’ai un serveur perso qui tourne sous WinXP avec Apache 2.0.58 avec plein de modules, dont mod_ssl 2.0.55 …
Avec la sortie de la version 2.0.59 d’Apache, j’ai décidé de tout mettre à jour …

L’installation d’Apache se passe se problème, et le serveur (de base) fonctionne correctement (je peux surfer sur mes sites hébergé en http quoi :paf:) …
je récupère donc le binaires de mod_ssl sur http://hunter.campbus.com/, et je le met dans le dossier modules/ d’Apache (bref, tout ce qu’il y’a de plus normal) …
sauf qu’impossible de démarrer Apache (à moins de désactiver mod_ssl) … dans les logs, j’obtiens le message suivant :

vu que le certificat et la clé avait été créer avec une “vieille” version d’OpenSSL, je les ai recréer à l’identique, mais toujours même problème …

j’ai donc remis l’ancienne version de mod_ssl (2.0.55), et là paf, ça marche :??: …
j’y perds mon latin :paf:

donc bon, actuellement je fonctionne an Apache 2.0.59+mod_ssl 2.0.55, mais j’aimerais être à jour dans mes versions, donc si quelqu’un à une idée d’où peut venir ce problème, car Google n’est pas très prolixe de ce côté là :sarcastic: …
le message me fait penser à une erreur avec la libraire OpenSSL, mais elle est correctement installé vu qu’elle fonctionne parfaitement avec la version 2.0.55 de mod_ssl :neutre: …

Salut

T as bien remis les Dll a jour ?
sinon j ai installé apache 2.0.59 et mod_ssl-2.0.58 et openSSL-0.98a et y a pas de souci . :super:
Tu peux recuperer tous les fichiers necessaire pour Win32 sur :
http:\\www.apachefrance.com/Forums/index.php?showtopic=1478&st=0

ouahou c’teu UP :smiley:

merci pour cette réponse, normalement tout est à jour … mais j’irais tester ça ce soir :jap: