Forum Clubic

Se connecter au routeur wifi avec feisty fawn

hello ! j’avais fait un sujet il y a peu car impossible de me connecter au net. le problème est aujourdh’ui a moitié résolu. je peux me connecter en câblé sur ma box mais pas en wifi.
il me demande mon mot de passe, je le tape…et il me le redemande.
quand j’avais enlevé le mot de passe il se connectait sans souci au wifi.

je me demande si ce n’est pas une question d’adresse IP ou quoi, je n’en sais rien :neutre:
s’il y a un conflit d’adresse IP , je ne sais pas si ça me sera notifié (il y a 4 postes connectés,mais des OS différents)

:~$ ifconfig -a
eth0      Lien encap:Ethernet  HWaddr 00:0D:56:DE:6E:4A  
          inet adr:192.168.1.4  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::20d:56ff:fede:6e4a/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:10675 erreurs:0 :0 overruns:0 frame:0
          TX packets:10535 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:8476907 (8.0 MiB) Octets transmis:1623886 (1.5 MiB)

eth1      Lien encap:Ethernet  HWaddr 00:0C:F1:14:94:A4  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Packets reçus:0 erreurs:17 :17 overruns:0 frame:0
          TX packets:35 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:0 (0.0 b) Octets transmis:6030 (5.8 KiB)
          Interruption:5 Adresse de base:0x4000 Mémoire:fcffe000-fcffefff 

je ne vois pas trop ce qu’il faut faire, c’est peut-être le mot de passe mais c’est bizarre, ou le canal wifi?
bref. si vous avez une idée je suis a l’écoute :stuck_out_tongue:

Pour lister un périphérique wifi, c’est plutôt iwconfig (et chez moi, il ne veut exécuter cette commande qu’en root… allez savoir pourquoi ^^)

Ce n’est pas un problème de canal Wifi, en fonction du SSID que tu choisis, il se connecte au canal correspondant.

Si tu lui attribue une adresse IP déja utilisée, il est sensé le détecter et se pleindre dans le /var/log/messages.

Par contre, il se peux que comme chez moi les outils graphiques ne s’en sortent pas bien. J’ai viré le Network Manager de Gnome et modifié mes config réseaux à la main:


ebola% cat /etc/network/interfaces
auto lo
iface lo inet loopback

iface eth0 inet static
address 192.168.1.100
netmask 255.255.255.0
gateway 192.168.1.1

iface eth1 inet static
address 192.168.1.101
netmask 255.255.255.0
gateway 192.168.1.1
wpa-ssid LinksysToFree
wpa-key-mgmt WPA-PSK
wpa-psk MACLEWIFI

auto eth1

eth0 est mon interface ethernet cable et eth1 mon interface wifi.

J’ai aussi un autre problème, le driver wifi se charge trop tard, ce qui fait qu’a chaque fois que je boot, je suis obligé de faire /etc/init.d/networking restart.

Vérifie aussi que ton resolv.conf est OK:

ebola% cat /etc/resolv.conf   
# generated by NetworkManager, do not edit!

nameserver 192.168.1.1
nameserver 212.27.52.176

La première entrée est le DNS de mon routeur wifi, la seconde un DNS de chez Free.

ok mais synaptic ne trouve pas le gnome network manager :neutre: il y a une commande magique? :smiley:

justement il ne faut pas l’utiliser.
son petit nom est “network-manager”, il doit y etre, je le vois dispo en install sur ma Ubuntu 7.04 avec Synaptic …

forcément, si je le cherche à "gnome-network manager"… :paf:
ok donc je teste ça demain.
par contre je ne comprends pas la ligne en gras dans ton code.

wpa-ssid LinksysToFree
[B]wpa-key-mgmt WPA-PSK[/B]
wpa-psk MACLEWIFI

c’est le type de clé? non paske comme j’y connais rien, je connais pas le type de clé que c’est :ane:
ma page de config box me dit que c’est une clé ASCII 128 bits. si elle le dit… :neutre:
tu pourrais me dire ce que moi je dois mettre à la place? merci :jap:

C’est une clé de type WPA, il faut savoir ce que ta box wifi utilise: WPA, WPA2, WEP ou rien du tout :slight_smile:

Pour configurer le reseau sur Ubuntu, c’est ici:

http://doc.ubuntu-fr.org/tutoriels_imprimes/reseau