Forum Clubic

Scripts de connexion lecteur réseau

Bonjour à tous! Alors voilà, j’explique mon petit problème, je voudrais faire un script de conexion à des dossiers présents sur un serveur et fonctionnant sur des ordis clients en XP et 2000 cependant il faut une reconnexion automatique. Donc j’ai utilisé Net use et l’aide DOS et j’ai cherché sur le net mais malheureusement il n’y a aucun exemple de syntaxe avec reconnexion auto, j’ai donc tapé net use Z: \Develop\APLTMP\lexou * /USER Invité /PERSISTENT:{YES} avec \Develop\APLTMP\lexou=chemin du dossier partagé, *=demande de mot de passe et /USER Invité=connexion avec utilisateur local invité
Malheureusement ça me met qu’il y a une mauvaise syntaxe :S quelqu’un connaitrait-il la bonne syntaxe? Merci de votre aide!
Edité le 11/01/2008 à 11:10

Bon alors j’ai réussi a faire le script c’est net use Z: \Develop\APLTMP\lexou * /USER:Invité /PERSISTENT:YES par contre j’ai un soucis, quand je fais un copier coller de çà dans l’invite de commande pas de problème çà marche et connecte le lecteur réseau. Par contre quand j’éxécute le script qui a cette commande (copier coller donc exactement la même) çà ne marche pas? :s

net use Z: \Develop\APLTMP\lexou * /USER:Invité /PERSISTENT:yes

Attention l’option PERSISTENT:YES signifie que la connexion restera active même après redémarrage du PC

Ah d’accord donc pas besoin de mettre ce script dans démarrage alors? on le met une bonne fois pour toute? ne vaudrait il pas mieux mettre ce script au démarrage en lui rajoutant un net use * /delete avant?

Tout dépend de ce que vous voulez.

êtes-vous sur un domaine ? je n’en n’ai pas l’impression.

Si vous l’étiez il suffirait de mettre ce script dans le profil des utilisateurs, mais dans ce cas ce ne serait pas “invité” mais le code utilisateur

Pour la commande tapez simplement:
net use Z: \Develop\APLTMP\lexou * /USER:Invité /persistent:no

si vous voulez que les personnes qui démarreront les ordinateurs et qui ne connaitront pas le mot de passe invité ne puissent pas se connecter sur votre serveur.

Merci de tes réponses rapides caiman! Alors non il n’y a pas de domaine, c’est pour ça que je fais des scripts par utilisateur, le script a été créé, j’ai mis : if exist “Z:” net use Z: /DELETE /YES
net use Z: \Develop\Partage\Compta zetajones /USER:Invité /PERSISTENT:NO

et ça marche par contre, autre question, j’ai juste un réseau local pour l’instant et je voulais savoir si on pouvait donner des droits NTFS et de partage par utilisateur et non par ordinateur. Je m’explique :
- J’ai 3 ordis pour l’instant, un appelé Develop (où il y a mes données à accéder), un autre Titanium et le troisième test, est il possible de donner des droits d’accès à \Develop\Partage\Compta à l’utilisateur \test\compta et \Titanium\Compta seulement? J’ai pas réussi à faire ça dans sécurité ni options de partage il ne me trouve pas \test\Compta qui pourtant est créé…(Develop est sous XP Pro)
Edité le 11/01/2008 à 13:09

Si tu n’est pas dans un domaine, il te faut créer sur chaque machine les mêmes utilisateurs avec les mêmes mots de passe (ceux qui serviront à accéder aux données partagées en tout cas).

Ensuite, dans les onglets NTFS et Partage, il faut régler les droits qui vont bien, sur les dossiers qui vont bien pour les utilisateurs qui vont bien. Ca j’ai l’impression que tu pourras trouver sans problème.

Et puis c’est tout :slight_smile:

Par contre, si tu as un domaine, inutile de créer les utilisateurs locaux, un utilisateur itinérant devrait faire l’affaire en lui donnant les droits qui vont bien…

Par contre, je te déconseille fortement de prendre l’habitude d’utiliser le compte invité si tu ne sais pas le paramêtrer correctement.

AtY
Edité le 11/01/2008 à 15:07

Ben le compte invité c’est juste pour les tests donc je m’en servirai plus après, qu’est ce qu’il a de particulier? Mais pourtant quand je donne des droits, je tape directeur puis vérifier les noms il me met \Test\Directeur et pas \Titanium\Directeur qui est marqué comme n’étant pas un objet…

C’est normal que tu n’obtiennes pas le “bon” nom d’utilisateur puisque la recherche de l’objet se fait sur le “domaine” Test (qui est en fait une machine). La machine test ne peut pas rechercher d’objet sur la machine Titanium.

Ca suit la forme suivante : “DOMAINE\USER” où “chez toi” le domaine est en fait le nom de machine (puisque tu n’as pas de domaine). Ne te formalises pas sur cet aspect. Cependant, veille bien à leur attribuer le même mot de passe sur les deux machines pour que ces comptes soient interopérables.

L’idée est la suivante :

  • Poste 1 : \SERVEUR\partage
  • Poste 2 répond : ok partage existant, mais qui es tu ?
  • Poste 1 : je suis DOMAINE\USER
  • Poste 2 : ok, je connais cet utilisateur (même si techniquement l’utilisateur, existant sur les deux postes en local, ne sont pas les mêmes).
  • Poste 2 : Tu peux passer.

Pour le compte invité, son plus gros problème, c’est que c’est un compte qui, sur tous les systèmes windows, porte le même nom. Donc un script pourrait l’utiliser à de mauvaises fins. Si il est désactivé, pas de soucis. Donc, si tu comptes l’utiliser, renomme le, tu seras plus tranquille. Ensuite renseigne toi bien sur les droits à lui donner dans les sécurity policy et vérifie qu’il n’ait pas de droits trop importants.

En espérant t’avoir éclairé.

AtY

Ah d’accord, merci pour ton explication claire et precise, si je comprends bien, en donnant les droits à Directeur tu trompes l’ordi et il donne les droits à Test\Directeur mais aussi à Titanium\Directeur et aux autres. Le réseau risque de grandir donc au final un domaine sera p.e plus approprié…A voir et encore merci à tous!

C’est tout à fait ça. Bon courage pour ta configuration :slight_smile:

AtY