Forum Clubic

Samba - pb d'acces

Salut, je poste aujourd’hui pour un pb samba qui ronge le neurone qui me reste.
Voila, j’ai un serveur fonctionnant avec fedora4 et dessus installé samba en version 3.0.14a. Je pense avoir bien configuré le fichier smb.conf et mes differents partages qui devront tous etre accessibles en lecture et ecriture mais le seul qui soit accessible en écriture est celui que j’ai decommenté et qui existe par défaut dans smb.conf : /tmp
Les autres sont configurés de la meme façon que /tmp mais ne sont accessibles qu’en lecture. J’ai donc modifié les droits d’acces des repertoires partagés en donnant les droits d’ecriture et de lecture a tout le monde : chmod a+rwx /monpartage, mais ca ne fonctionne pas…quelqu’un aurait une idée…
merci

chown pour changer le propriétaire des dossiers dans lesquels tu va écrire, ca peut etre utile

il faudrais que tu poste ici les résultats des commandes ‘testparm’ pour samba et ‘ls -al’ pour tes dossiers

voila ce que la comande testparm me retourne :

Load smb config files from /etc/samba/smb.conf
Processing section "[tmp]"
params.c:Parameter() - Ignoring badly formed line in configuration file: This one is useful for people to share files
Processing section "[partage]"
params.c:Parameter() - Ignoring badly formed line in configuration file: This one is useful for people to share files
Processing section "[public]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

Global parameters

[global]
workgroup = SSII
netbios name = FEDORA4
server string = partage
security = SHARE
null passwords = Yes

[tmp]
comment = Temporary file space
path = /tmp
read only = No
guest ok = Yes

[partage]
comment = partage
path = /partage
read only = No
guest ok = Yes

[public]
comment = public
path = /public
read only = No
guest ok = Yes

a qui devrait appartenir mes repertoires si j’utilise chown ?
merci

slt

le probleme vient qu en modifiant ton fichier smb.conf , tu as du par megarde enlever le ‘#’ qui met en comentaire la première ligne du fichier
donc samba ne comprend pas ce que c 'est …