Forum Clubic

"Retirer le périphérique en toute sécurité" n'apparait plus dans la barre des tâches pour les clefs usb - Windows 7

Bonjour, je précise par rapport au titre

Sous Windows 7 fraichement réinstallé et complètement mis à jour pour l’occasion, le symbole de retrait de périphérique n’apparait plus dans la barre des tâches à l’insertion des clés usb. Par conséquent plus de possibilité d’éjecter les clefs proprement.

Il apparait bien par contre à l’insertion des disques durs externes.

J’ai essayé d’utiliser la commande %SystemRoot%\System32\RUNDLL32.EXE shell32.dll,Control_RunDLL hotplug.dll pour afficher les disques éjectables et point de périphériques usb.

Dans les options “Icônes de la zone de notification” " je trouve :

“Explorateur Windows- Retirer le périphérique en toute sécurité et éjecter le média”
“Processus hôte Windows (Rundll32)”

Avec l’icône qui me manque tant :-(:

Toujours afficher toutes les icônes et les notifications sur la barre des tâche est coché.

J’ai parcouru une moults forums sans résultat et désespère de trouver une solution à ce problème à première vue anodin mais fort gênant.

Je compte sur votre savoir infini pour m’aider et je vous en remercie d’avance.

Cela n’est pas utile =)

Bonjour

Pourquoi c’est inutile , Si Microsoft l’a mis , on ne pense pas que c’est uniquement pour épater la galerie , et
on pourrait dire aussi que tout ce qui est présent dans le Systray ne sert à rien .

Il faut réinitialiser le tampon du Systray:

Démarrer \ Exécuter , taper regedit.exe ( pour ouvrir le registre) .

Cliquer sur le petit triangle qui se trouve juste à gauche de Ordinateur de manière à masquer toutes les clés de base.

Ouvrir l’onglet Edition -> Rechercher ,

cocher les cases Valeurs et Mot entier seulement , décocher les autres , dans le champ Rechercher , taper

iconstreams (en minuscule)

Cliquer sur Suivant pour commencer la recherche , ensuite à chaque fois sur F3 afin de réitérer celle-ci

Quand la recherche a aboutie , sur le volet de droite , faire un clic droit sur les valeurs

IconStreams et PastIconsStream , puis Supprimer . Répéter cette opération

jusqu’à la fin fin de la recherche.

Redémarrer.
Edité le 04/06/2011 à 17:41

Bonsoir,
l’icône apparait bien chez moi mais lorsque je clic dessus il n’y a aucun de mes périphériques connectés qui s’affiche, il n’y a que trois petits points… (voir photo)
[Photo supprimée]
et si je clic sur “ouvrir périphériques et imprimantes” la fenêtre du panneau de configuration “périphériques et imprimantes” est vide.
Pour retirer une clé USB je dois aller dans “Ordinateur” , c’est assez pénible je trouve

Vous avez une idée c’est la première foi que je vois ça.

Pas de panique !

Pour commencer, as-tu essayé de fermer et relancer ton compte d’utilisateur pour voir si ça sufit à résoudre le problème ?

[spoiler]Ça peut paraître trop simple, mais nombre de “bugs” de ce genre sont corrigés par cette méthode, notamment ceux de Windows Update qui prévient de la disponibilité de mises à jour mais sans qu’elles ne s’affichent quand on va voir les détails.[/spoiler]

Si ça ne suffit pas, redémarre l’ordinateur : ça se produit toujours, après ?

Si ça ne fonctionne toujours pas, c’est soit ton installation de Windows 7, soit une mise à jour qui a déréglé, soit éventuellement un des logiciels que tu as installés par la suite.

Au pire, ce n’est pas grave : du moment qu’aucun fichier présent sur la clef n’est ouvert ou en cours de modification (ni même le logiciel servant à l’ouvrir/modifier), tu ne risques rien à la débrancher “à la sauvage” sur Windows. :wink: Mais c’est vrai que c’est toujours mieux de faire les choses “proprement”.
Edité le 04/06/2011 à 23:42

Salut, je relance au moins une foi par jour mon compte utilisateur parce que j’arrête l’ordinateur toutes les nuits, c’est alors peut être un thème un peu exotique que j’ai essayer qui ma fais cette connerie (ça m’avait changé tous les miniatures de dossiers et la barre des taches…)
mais merci quand même, c’est pas trop grave alors je vais me passer d’une réinstallation de Windaub

Bonjour,

Tout d’abord :

J’ai bien peur que ce soit ton post qui soit inutile :ane: ne serait-ce que pour éviter de fusiller ses clefs usb…

Ensuite merci zaboukou, car j’ai avancé.

Je ne pouvais pas auparavant éjecter les clefs et maintenant cela m’est possible via clic droit sur la clef dans le Poste de Travail et…“Ejecter”.

C’est seulement après avoir cliqué sur “Ejecter” qu’apparait l’icone dans le systray et la notification comme quoi je peux éjecter le périphérique en toute sécurité.

Étrange mais moins gênant que l’absence totale d’éjecter correctement.

Autre détail cela n’est pas le cas des disques durs usb, où tout est ok (Icone dans le systray et éjection à partir de celui-ci).

Quoiqu’il en soit encore merci pour ces minutes dépensées pour m’aider. :super:

bonsoir,
réinstalle Windows et c’est reparti pour un tour jusqu’à la prochaine… Pour mon problème aussi je pense que c’est la seule solution mais je me suis tellement cassé la tête à réinstaller Windows maintes et maintes fois pour des conneries que je ne me foule plus. Perso je pense que ça sera mon dernier PC sous Windows, ça devient tellement un labeur d’être devant un ordi c’est pas normal

Mooouuuiii, une réinstalle windows, ben pas plus que tous les deux ans. (3 pc et pour les trois c’est pareil).

En l’occurrence l’installe qui présente ce problème est toute fraiche.

Par contre à partir du moment où l’on commence à installer “d’exotiques thèmes” je conçois aisément que cela fait foirer le système.

Windows n’est pas fait pour cela je crois.

Utilisateur depuis Windows 3.1 il me semble que Seven justement est d’une stabilité exemplaire, du moins si on le compare à n’importe quelle version passée.

À partir du moment où on ne bidouille pas trop le bouzin :wink:

Heureusement que j’avais déjà expliqué pourquoi ça a peu de chances d’arriver… :riva:

Je sais que c’est différent sur les Linux ou Mac OS X, mais Windows a au moins l’avantage de ne pas activer par défaut le cache en écriture sur les volumes USB, ce qui réduit les risques de bousiller leur contenu si on fait pas les choses dans les règles.
Edité le 19/06/2011 à 18:31

Cela veut dire tout simplement que les broches 2 et 3 (Data - et Data +) sont mises en haute impédance .