Forum Clubic

Restauration GRUB

Bonjour à tous,
j’avais Windows Xp et Ubuntu 8.04 installes sur un ordi, je choisissais entre les deux grace a GRUB.
J’ai voulu reinstallé windows , ce qui a échoué mais grub n’apparait plus !
je veut donc le restaurer, voici un tuto d’un autre site :

<< 6. Restauration de Grub en mode rescue :
Vous avez par mégarde effacé votre grub ? aucun problème, il vous suffit de démarrer en mode console pour le restaurer. Voici comment le faire grâce au CDROM de votre distribution :

* Pour Mandriva :
      o Au premier choix pressez [F1]
      o puis au prompt tapez : rescue root=/dev/hda4
* Pour Slackware :
      o Au prompt pressez la touche [enter]
      o Après le choix du clavier vous êtes logué en root.
* Pour Debian :
      o Au prompt tapez : rescue root=/dev/hda4
* Pour Redhat :
      o Au prompt tapez : linux rescue
      o Choisissez votre clavier
      o Choisissez [acceptez] à la demande d'auto-configuration d'anaconda

A ce stade vous êtes en mode rescue, cependant pour Mandriva et slackware vous devez acter encore un petit peu :
mkdir /tmp/linux mount -t ext2 -o rw /dev/hda4 /tmp/linux
Pour restaurer grub dans le mbr, tapez simplement :
/tmp/linux/usr/sbin/grub --config-file=/tmp/linux/boot/menu.lst grub> root (hd0,3) grub> setup (hd0) >>

Mais je ne comprend pas ce que veut dire " au prompt "… ?
merci de m’éclairer.

Bon sur la doc d’ubuntu.org il est dit que l’on peut restaurer GRUB a partir du Live Cd dans un terminal -> sudo grub-install /dev/sdax
ou x est le # du disque “racine” : je cite

<< La partie /dev/sda(numéro du disque) est à compléter (Vous devez indiquer le numéro de la partition racine. Celle ou est marqué / dans les résultats de la commande ci dessous. Pour avoir les informations sur vos disques durs rentrer dans un terminal :

sudo fdisk -l >>

mais aucune n’est marquée par ’ / ’

tapes plutôt mount que fdisk

Résolu ! Ouf .!! :smiley:

Voici la démarche a suivre pour réinstaller GRUB et ainsi pouvoir booter sur les systemes installés :

ubuntuforums.org…

Voila! merci tout de meme atekor :super:

Bonjour je suis dans le meme cas. mais je ne sais pas si je suis en slackware, Debian ou redhat. Comment savoir? ou regarder?
De plus je suis largué car je ne sais pas ou taper ces invites de commande… Et oui pas evident les debuts sur linux mais ca me plait deja!!!

J ai essayé en cliquant droit sur le bureau puis invite de commande mais l execution ne donne pas le resultat espere…
Edité le 11/11/2008 à 00:01

Apres avoir pas mal galererj ai trouvé le terminal et reussi a rentrer les lignes de commande indiquer par le lien. En redemarrant il me propose 3 boot different de Ubuntu mais pas xp. Faut il rajouter un grub ou je ne sais quoi?
J ai un besoin assez urgent de retourner sur le xp pour le travail!!! J hesite meme a formater ma partition de ubuntu pour remettre un xp dessus…:frowning:

Voici ce que j ai tapé et la reponse:

[ Minimal BASH-like line editing is supported. For
the first word, TAB lists possible command
completions. Anywhere else TAB lists the possible
completions of a device/filename. ]

grub> find /boot/grub/stage1
(hd1,0)

grub> root (hd1,0)

grub> setup (hd0)
Checking if “/boot/grub/stage1” exists… yes
Checking if “/boot/grub/stage2” exists… yes
Checking if “/boot/grub/e2fs_stage1_5” exists… yes
Running “embed /boot/grub/e2fs_stage1_5 (hd0)”… 16 sectors are embedded.
succeeded
Running “install /boot/grub/stage1 d (hd0) (hd0)1+16 p (hd1,0)/boot/grub/stage2 /boot/grub/menu.lst”… succeeded
Done.

grub> quit

benjamin@Benordi:~$ sudo mount
[sudo] password for benjamin:
/dev/sdb1 on / type ext3 (rw,relatime,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
/proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,nosuid,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
lrm on /lib/modules/2.6.27-7-generic/volatile type tmpfs (rw,mode=755)
securityfs on /sys/kernel/security type securityfs (rw)
/dev/sda1 on /media/system type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
/dev/sda2 on /media/Tout type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
benjamin@Benordi:~$ rescue root=/dev/hda4
bash: rescue : commande introuvable
benjamin@Benordi:~$ sudo grub
Probing devices to guess BIOS drives. This may take a long time.
benjamin@Benordi:~$

Merci pour votre aide précieuse
Edité le 11/11/2008 à 10:13

ok, tu es presque au bout de tes peines. Tu dois éditer le fichier /boot/grub/menu.lst
en faisant (copier coller)
sudo gedit /boot/grub/menu.lst

Ensuite il te faut ajouter l’entrée correspondant à XP que tu dois pouvoir trouver sur le net.
Ceci dit, est ce que tu vois quelque part tes données windows dans un répertoire? Est ce que tu as plusieurs disques? Car je ne vois pas de partition ntfs dans les partitions qui sont utilisés par ton système (ça peut être normal, mais c’est tout de même étrange puisque j’imagine que tu n’es pas allé tripatouiller les montages des partitions )

grub4dos.sourceforge.net…

Mon xp est sur le 2 eme disque dur D: et toutes mes partitions sont en ntfs sauf la nouvelle pour linux qui est en ext3.

Quand je rentre
sudo gedit /boot/grub/menu.lst
Il me dit “commande not found”

Ah d’accord, tu as deux disques, détail très important.
JE te donne l’aide à midi. (Enfin 13:30, vu que je suis en Espagne)

Tu es bien sur ubuntu ?

Une fois que tu as démarré la machine complètement, depuis le terminal (dans tes menus) tu copies la ligne (copier coller):
sudo gedit /boot/grub/menu.lst

et tu entre ton mot de passe. Regarde si il y a une section Windows ou non.

Je suis sur Kubuntu et il me reponds : sudo: gedit: command not found

Ah ok, c’est kubuntu donc remplace par
sudo kwrite /boot/grub/menu.lst

Il me reponds pareil command not found!

bon, essaie une de celles ci dans l’ordre (c’est un editeur de texte simple dont on a besoin), mais les deux derniers sont un peu … non standards. :

sudo kedit /boot/grub/menu.lst
sudo kate /boot/grub/menu.lst
sudo nano /boot/grub/menu.lst
sudo vi /boot/grub/menu.lst

Avec la commande : sudo kate /boot/grub/menu.lst
Il me reponds
Error: “/var/tmp/kdecache-benjamin” is owned by uid 1000 instead of uid 0.
kate(7889): createDoc
kate(7889) KateSessionManager::KateSessionManager: LOCAL SESSION DIR: “/home/benjamin/.kde/share/apps/kate/sessions”
kate(7889) KateApp::initKate: Setting KATE_PID: ’ 7889 ’
Error: “/tmp/kde-benjamin” is owned by uid 1000 instead of uid 0.
kate(7889) KateViewDocumentProxyModel::updateBackgrounds: false
kate(7889) KateMainWindow::KateMainWindow: **************************************************************************** 0x9465990
kate(7889) KateViewDocumentProxyModel::updateBackgrounds: false
kate(7889) KateViewDocumentProxyModel::updateBackgrounds: false
kate(7889) KateDocManager::slotDocumentNameChanged: docname changed: “Sans titre” -----> “Sans titre”
kate(7889) KMimeTypeFactory::parseMagic: Now parsing “/usr/share/mime/magic”
kate(7889) KateDocManager::slotDocumentNameChanged: docname changed: “Sans titre” -----> “menu.lst”
kate(7889) KateViewDocumentProxyModel::updateBackgrounds: false
kate(7889) KateApp::startupKate: KateApplication::init finished successful
Error: “/tmp/ksocket-benjamin” is owned by uid 1000 instead of uid 0.
kate(7889) KateViewDocumentProxyModel::updateBackgrounds: true


Et pour la ligne : sudo nano /boot/grub/menu.lst Il reponds: default 0 timeout 4

BEGIN AUTOMAGIC KERNELS LIST

lines between the AUTOMAGIC KERNELS LIST markers will be modified

by the debian update-grub script except for the default options below

DO NOT UNCOMMENT THEM, Just edit them to your needs

## Start Default Options

default kernel options

default kernel options for automagic boot options

If you want special options for specific kernels use kopt_x_y_z

where x.y.z is kernel version. Minor versions can be omitted.

e.g. kopt=root=/dev/hda1 ro

kopt_2_6_8=root=/dev/hdc1 ro

kopt_2_6_8_2_686=root=/dev/hdc2 ro

kopt=root=UUID=a43a95a6-7882-405e-8906-2d26066e40df ro

default grub root device

e.g. groot=(hd0,0)

groot=a43a95a6-7882-405e-8906-2d26066e40df

should update-grub create alternative automagic boot options

e.g. alternative=true

alternative=false

alternative=true

should update-grub lock alternative automagic boot options

e.g. lockalternative=true

lockalternative=false

         [ ligne 1/91 (1%), col. 1/10 (10%), car. 0/2748 (0%) ]

^G Aide ^O Écrire ^R Lire fich.^Y Page préc.^K Couper ^C Pos. cur.
^X Quitter ^J Justifier ^W Chercher ^V Page suiv.^U Coller ^T Orthograp.

pour la 1/ ça c’est le blabla de kate quand il s’ouvre la premièer fois, mais tu as quoi dans l’éditeur lui même, dans la fenêtre?
2/ Ok on va travailler avec nano, mais kate est plus pratique

Descend dans le texte, et copie l’intégralité du fichier ici pour voir si il y a une section windows
Edité le 11/11/2008 à 14:14

Avec nano il me reponds pareil a savoir: GNU nano 2.0.7 Fichier : /boot/grub/menu.lst

default 0
timeout 4

BEGIN AUTOMAGIC KERNELS LIST

lines between the AUTOMAGIC KERNELS LIST markers will be modified

by the debian update-grub script except for the default options below

DO NOT UNCOMMENT THEM, Just edit them to your needs

## Start Default Options

default kernel options

default kernel options for automagic boot options

If you want special options for specific kernels use kopt_x_y_z

where x.y.z is kernel version. Minor versions can be omitted.

e.g. kopt=root=/dev/hda1 ro

kopt_2_6_8=root=/dev/hdc1 ro

kopt_2_6_8_2_686=root=/dev/hdc2 ro

kopt=root=UUID=a43a95a6-7882-405e-8906-2d26066e40df ro

default grub root device

e.g. groot=(hd0,0)

groot=a43a95a6-7882-405e-8906-2d26066e40df

should update-grub create alternative automagic boot options

e.g. alternative=true

alternative=false

alternative=true

should update-grub lock alternative automagic boot options

e.g. lockalternative=true

lockalternative=false

^G Aide ^O Écrire ^R Lire fich.^Y Page préc.^K Couper ^C Pos. cur.
^X Quitter ^J Justifier ^W Chercher ^V Page suiv.^U Coller ^T Orthograp.

Alors que je vois mon systeme xp dans le gestionnaire de fichier
Je precise que mon Xp pro est epuré (XP trust)
Edité le 11/11/2008 à 14:23

oui non ca c’est normal :slight_smile:
C’est kate qui te parle de son moi porfond. Il le fait toujours mais quand tu le lances en cliquant sur son icone, tout ce baratin n’apparait pas. Est ce que kate se lance quand même?

  1. installes un bon éditeur sur ta distribution. Celui que tu veux. kwrite est basique mais bien pour commencer.
    Installes le. Tu sais installer un logiciel sur ta kubuntu? Si tu ne sais pas demande :wink:

  2. v_atekor: le problème avec sudo vi /boot/grub/menu.lst quand on connait pas étant que l’on peut mettre longtemps avant d’en sortir… :wq ca fait trois touches soit qlqls 10^9 années avant de tomber dessus par chance :slight_smile:

fakbill : ben je sais … c’est pour ça que je le mets en dernière option. J’en ai bavé mes premières fois avec vi, surtout que de mon temps c’était ça ou rien. (heu … pardon : ça ou emacs )

Ca y est j ai installer kwrite je suppose qu il faut que je lance
sudo kwrite /boot/grub/menu.lst ??