Forum Clubic

[Résolu] XFS et GRUB - marche, marche pas ?

J’ai une question à propos de GRUB et du système de fichiers XFS. Quand j’avais essayé de créer ma partition / en XFS il y a qq temps, et d’installer grub ensuite, l’installeur debian m’affichait un gros message comme quoi GRUB pouvait planter à cause du XFS, et me proposait d’installer lilo (qui bien sûr ne fonctionnait pas :paf:). Vu que je connais mieux grub que lilo, j’ai abandonné le xfs…

Mais là je vais faire une réinstallation ce week-end, et je retenterais bien le XFS (ça me changera du reiserfs :D). D’après la doc XFS, il se pourrait que grub plante par intermittence sur un / en XFS ( http://oss.sgi.com/projects/xfs/faq.html#grubwork )

donc marche ou marche pas ? :neutre:

:jap:

Ne me répondez pas “T’as qu’à essayer !”, ça m’ennuierait fortement :o

Solution : faire une partoche séparée pour /boot (en ext3 par exemple)

Pour ma part,avec la kanotix (basée sur debian) , ça ne marchait effectivemment pas : à l’installation aucun message d’erreur ,mais au redémarrage , absence totale de grub et donc départ direct sur windows -)

marche pas mais y’a une astuce :smiley:

il suffit de faire une partoche de qq Mo (30 ou 40) speciale pour /boot en ext3.
Tu mets ton / et ce que tu veux en XFS et ca roule !

:jap:
c’est ce que j’avais prévu de faire :miam: , mais je n’étais pas sûr, car je pensais que grub bloquait lorsque on essayait d’exécuter grub-install depuis une partoche XFS.

bon bah résolu a priori :jap:

Cà a toujours fonctionné à la perfection avec ma Gentoo !
XFS POWAAA !!!!!

je confirme grub - xfs marche très très bien

mais pas en boot il faut faire appel à une partoche non xfs /boot

perso mon /boot et en ext2

le reste en xfs

La totale çà marche aussi y compris le /boot.