Forum Clubic

[RESOLU] Virtual Host et sous-domaines ! - Apache2, Debian 3.1, IP Fixe

Salut !

Bien ,depuis 2 jours j’essaye desesperement de faire quelquechose sur mon serveur apache ! J’ai un DNS (www.domaine.org) et plusieurs sous domaines (pop.domaine.org, jabber.domaine.org, etc).

Je souhaiterais par exemple que le sous-domaine pop.binouzeworld.org n’arrive pas directement sur l’index.php présent dans mon repertoire /var/www mais plutos dans un repertoire /www/Forbiden ou mieux que cela génère une erreur 404 !

Dans le même ordre d’idée, j’aimerais que le sous domaine jabber.domaine.org arrive diretement dans le repertoire /var/www/jabber.

En fouillant la mémoire de Google e les differents posts du forum, j’ai entendu parlé des virtual hosts ! Après un test sans succès, je me tourne vers vous ! :love:

Pourriez vous m’aider a ce niveau la ?

Merci les z’amis !

:hello:

Salut !
Teste la syntaxe suivante :

<VirtualHost tonip:tonport>
        ServerName sousdomaine.tondomaine.org
        DocumentRoot /var/www/tonrepertoire/
</VirtualHost>

Etant sous apache 2 je doit bien mettre cela dans le /etc/apache2/sites-availables/defalut ?

Tu dois avoir un dossier conf.d dans /etc/apache2 dont tous les fichiers sont inclus dans la conf d’Apache… crée un fichier dedans et mets-y tes redirections, à mon avis ce sera plus propre.

Ca fonctionne superbement bien ! Mais pour aller plus loin est t’il possible de manière classe (c’st a dire sans rediriger vers un repertoire qui n’existe pas) de générer une erreur Forbiden lorsque l’utilisateur tape pop.domaine.org ?

Merci bcp !

EDIT : en fait dela ne fonctionne ap a 100%… lorsque je rajoute un vhost a la suite, avec la même syntaxe mais avec bien sur un ServerName different, il me dit que le vhost annule lme vhost précédent… :miam:

J’ai pas l’habitude de faire les choses de manière classe, c’est un peu le problème :smiley:
Moi je mettrais simplement un “Deny from all” à la place de la ligne DocumentRoot.

Sinon, je viens de regarder ma config et c’est peut-être mieux de mettre ces lignes là où tu voulais les mettre, ils le disent dans /etc/apache2/apache.conf : sites-enabled. Enfin bon, tant que ça marche…

Okay c’est déplace mais tjr le même pb… Cf EDIT :slight_smile:

Je te met le message d’erreur :
[warn] VirtualHost 88.191.xx.xxx:0 overlaps with VirtualHost 88.191.xx.xx:0, the first has precedence, perhaps you need a NameVirtualHost directive

Oups… j’ai oublié de te faire rajouter un

NameVirtualHost ip:port

tout en haut…

oh d’accord :slight_smile:

Mias même si c’est le port 80 pour tout, ca change rien ?

EDIT : je repond à ma question… c’est idem ! Le nom du virtula host ne doi pas être unique ?

Non, tu peux même mettre une étoile à la place de ip:port…

Rapide :slight_smile:

Cf EDIT :bounce:

Euh ben si, je comprends pas trop la question… t’associes un sous domaine unique à un dossier non ?

Ouais, j’essaie de t’aider avant de reprendre le boulot ^^

Ouic 'est ca :slight_smile:

Je reprend de zero ! J’ai le message d’erreur suivant avc ta modif :
Apache2[Mon Jul 24 14:00:57 2006] [warn] NameVirtualHost 88.191.xx.xxx:80 has no VirtualHosts

Mon fichier vhost :

<VirtualHost 88.191.xx.xxx:80>
NameVirtualHost 88.191.xx.xxx:80
ServerName jabber.xxxxxxxxx.org
DocumentRoot /var/www/Forbiden/
</VirtualHost>

<VirtualHost 88.191.xx.xxx:80>
NameVirtualHost 88.191.xx.xxx:80
ServerName pop.xxxxxxxxx.org
DocumentRoot /var/www/Forbiden/
</VirtualHost>

Ah oui non, excuse-moi, c’est plutôt du genre :

NameVirtualHost 88.191.xx.xxx:80

<VirtualHost 88.191.xx.xxx:80>
ServerName jabber.xxxxxxxxx.org
DocumentRoot /var/www/Forbiden/
</VirtualHost>

<VirtualHost 88.191.xx.xxx:80>
ServerName pop.xxxxxxxxx.org
DocumentRoot /var/www/Forbiden/
</VirtualHost>

And God is…Mandarounet !!! :clap:

Merci beaucou pr ton aide précieuse je vais pouvoir faire de même pour tout les sous domaines !

Bon coruage pour ta journée de boulot alors !!

:super:

De rien ! :hello: