Forum Clubic

[résolu][Perl] Problème requires explicit package

Bonjour,

Connaissant pas grand chose au perl et ayant un problème, je viens poster ici.

Le problème est le suivant :

Mon code (réponse possible fournie par l’utilisateur : o ou rien)

print 'Ajouter le dépôt de beryl ? : ';
chomp(my $active_beryl = <STDIN>);

if ($active_beryl =~ /o/i) {
        print 'As-tu une carte nvidia ? : ';
        chomp(my $active_nvidia = <STDIN>);

        if ($active_nvidia =~ /o/i) {
                print 'Est-ce une geforce 3 ou 4 ? : ';
                chomp(my $active_nvidia_geforce = <STDIN>);
                print "\n";
        }
}


if ($active_beryl =~ /o/i) { $data .= $beryl; }
if ($active_nvidia =~ /o/i) { $data .= $nvidia1; }
if ($active_nvidia_geforce =~ /o/i) { $data .= $nvidia2; }

Je connais rien au perl mais je pense qu’il n’y aurait pas d’erreur si tu regroupais toutes tes déclarations en début de fichier.

Excellent, c’est ça. Merci.