Forum Clubic

[RESOLU] Pb [mandriva 2007] + [ATI]: pas de 3D - pas moyen d'afficher le bureau 3D

Bonjour a tous,

J’ai réinstaller ma Mandriva 2007 que j’avais péter a force d’installer n’importe quoi en gérant moi même les dépendances. Et comme d’habitude, la partie délicate ce sont les drivers graphique ATI…

j’ai installer les derniers pilotes proprios pour avoir XGL, mais XGL marche pas. J’ai bien une accélération 3D (Tux racer fonctionne), le panneau de config mandriva m’autorise a choisir XGL mais rien a faire.

J’écume les tutos en vain.

Apparemment, j’ai pas le DRI d’activer:

[pascal@localhost ~]$ glxinfo | grep rendering
Xlib: extension "XFree86-DRI" missing on display ":93.0".
direct rendering: No

[pascal@localhost ~]$ glxinfo | grep OpenGL
Xlib: extension "XFree86-DRI" missing on display ":93.0".
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X800 XL
OpenGL version string: 1.2 (2.0.6334 (8.34.8))
OpenGL extensions:

Pourtant fglrxinfo sort que des trucs corrects (fglrx est le nom du module du driver ati)

[pascal@localhost ~]$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X800 XL
OpenGL version string: 2.0.6334 (8.34.8)

et enfin mon xorg.conf:

File generated by XFdrake (rev 57713)

**********************************************************************

Refer to the xorg.conf man page for details about the format of

this file.

**********************************************************************

Section "ServerLayout"
Identifier "layout1"
Screen 0 "aticonfig-Screen[0]" 0 0
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
EndSection

Section "Files"

# font server independent of the X server to render fonts.
# minimal fonts to allow X to run without xfs
FontPath     "unix/:-1"
FontPath     "/usr/share/fonts/misc:unscaled"

EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
Load "dri"
EndSection

Section "DRI"

# Access to OpenGL ICD is allowed for all users:
# Access to OpenGL ICD is restricted to a specific user group:
#    Group 100    # users
#    Mode 0660
        Mode         0666

EndSection

Section "ServerFlags"

#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)

allows the server to start up even if the mouse does not work

Option        "allowmouseopenfail"
Option      "AIGLX" "false"

EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
EndSection

Section "Monitor"

# Monitor preferred modeline (60.0 Hz vsync, 64.0 kHz hsync, ratio 5/4)
Identifier   "monitor1"
VendorName   "Generic"
ModelName    "Flat Panel 1280x1024"
HorizSync    31.5 - 90.0
VertRefresh  60.0 - 60.0
ModeLine     "1280x1024" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
ModeLine     "768x576" 50.0 768 832 846 1000 576 590 595 630
ModeLine     "768x576" 63.1 768 800 960 1024 576 578 590 616

EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

#Section "Device"

Identifier "device1"

  #  Driver      "vesa"

Driver "fglrx"

BoardName "ATI Radeon (vesa)"

Option "DPMS"

#EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
Option "UseFastTLS" "0"
Option "BlockSignalsOnLock" "on"
Option "ForceGenericCPU" "off"
Option "KernelModuleParm" "locked-userpages=0"
EndSection

Section "Extensions"
Option "Composite" "Disable"
EndSection

#Section "Screen"

Identifier "screen1"

Device "device1"

Monitor "monitor1"

DefaultDepth 24

SubSection "Display"

Depth 8

Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"

EndSubSection

SubSection "Display"

Depth 15

Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"

EndSubSection

SubSection "Display"

Depth 16

Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"

EndSubSection

SubSection "Display"

Depth 24

Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"

EndSubSection

#EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

j’ai installer les dernier driver ATI, 8.35.5, ca fait pareil, il doit me manquer une option a la con…

aidez moi svp !!! j’en peux plus, google trouve rien pour moi !

Petit oublie, désolé:

[root@localhost firefox]# grep EE /var/log/Xorg.0.log
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER

[root@localhost firefox]# grep WW /var/log/Xorg.0.log
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(WW) fglrx: No matching Device section for instance (BusID PCI:5:0:1) found
(WW) fglrx(0): board is an unknown third party board, chipset is supported
(WW) fglrx(0): Option "VendorName" is not used
(WW) fglrx(0): Option "ModelName" is not used

je précise qu’avant ca marchait avec mon processeur simple coeur 3200+ 64 bits et maintenant j’ai un CPU 4200+ X2 64 bits et une carte ATI X800 pcie

up

personne pour me donner un coup de main ?

snif, aucun barbu sur clubic ???

Ben disons que moi j’ai laissé tombé les drivers proprios pour les pilotes libres, mais je ne joue pas et je ne lance beryl qu’assez rarement (d’autant que ça rame légèrement).

Moi je te conseillerais de choisir entre les jeux et beryl/compiz.

le but c’etait d’avoir le bureau 3d, mais avec les drivers libre (les radeons je crois) c’est encore pire, quand je lance le test avec la mcc ca plante direct, donc c’est pour ca que je met les proprio (mais c vrai que je prefererais beryl)

j’ai trouver !!!!

il fallait dans /etc/sysconfig/compositing-wm mettre COMPOSITING_WM_START=yes car je l’avais a no

maintenant mon cube est revenu avec tous les effets 3D idiots mais indispensable ;o))