Forum Clubic

[RÉSOLU] FTP avec FileZilla server - mode passif ne fonctionne pas

Bonjour à tous, voila mon problème j’ai insatallé FileZilla server sur un pc (XP SP2), et je n’arrive pas a m’y connecter en mode passif (par contre ca passe en actif).
Pour moi perso ca ne me pose pas de problème, mais comme la majorité des clients FTP sont par defaut configurer en passif et que mes clients ne sont pas des informaticiens, j’aimerais que mon serveur réponde en mode passif.

Voici toutes les infos (que j’ai jugé indispensables de vous fournir pour m’aider a résoudre mon problème)

Configuration de ma freebox :

IP freebox : 192.168.0.254
Debut DHCP : 192.168.0.20
Fin DHCP : 192.168.0.50
Ip DMZ : 192.168.0.0
Ip du Freeplayer : 19.168.0.0
Réponse au ping : non
Proxy WOL activé : non

Redirections des ports :
Port 21 protocole tcp destination 192.168.0.1 port 21
Port 21 protocole udp destination 192.168.0.1 port 21

Configuration de pc (XP SP2)

IP : 192.168.0.1
Passerelle : 192.168.0.254
DNS : 212.27.32.176 et 212.27.32.177

Firewall windows :

actif avec des exception :
nom : FTP port 21 protocole UDP
nom : FTP port 21 protocole TCP

Configuration de FileZilla server :

General settings :
Listen on these port : 21

Passive mode setting :
Use the following IP : 192.168.0.1
Use custom port range : non

c’est tout sinon j’ai aussi essayer avec le régalge par defaut, mais ca ne change rien.

Merci de votre aide

Voila, en fait c’etait un problème firewall, j’ai bien ouvert les port 21, et j’avais Filezilla server interface aussi en exception, il m’a suffit de rajouter FileZilla Server (j’avais pas vu ou “merder” quand j’ai créer la première exception).

Salut, quelle est la difference entre le passi et actif? merci

en fait j’ai sais trop rien, j’ai fait des testes avec un pote ce matin, et pour pouvoir passer en mode actif, il faut dans un premier temps configurer ton client FTP pour ce mode (et c’est pas toujours facile a trouver comme option), puis après faut aussi configurer ton firewall, alors d’en passif normalement ca passe mieux les firewall (pas de config au niveau du client).
tout ce je que je viens d’écrire relève de ma propre expérience et n’est pas à prendre pour argent comptant, je peut me gourer.
Si quelqu’un connait la vérité, merci de poster.

:slight_smile: ok merci d’y avoir répondu quand même :wink: