Forum Clubic

[RESOLU]EXCEL : besoin de spécialistes - utilisation de le fonction SI

Bonjour
J’ai un listing sous excel de plus de 5000 personnes avec comme entetes de colonnes :NOM, PRENOM, SEXE (F,M), NOM MARITAL,etc…
J’aimerai rajouter une colonne “CIVILITE” (Mr, Mme, Mlle)
Sous excel, j’ai utilisé la fonction SI, mais le seul résultat auquel je parviens c’est de determiner 2 résultats (Mr ou Mme - Mr ou Melle)

Mon tableau se présente comme suit :

  • colonne A "SEXE"(M ou F)
  • colonne B "NOM"
  • colonne C "PRENOM"
  • colonne D "NOM MARITAL"
  • colonne E "CIVILITE" ----> celle que je veux rajouter en faite.

voici la formule que j’ai en E1 :
=SI(A1=“M”;“Mr”;SI(A1=“F”+D1="";“Mlle”;“Mme”))
Celle-ci parvient sans probleme a me determiner qui sont les “Messieurs”, mais elle me met #VALEUR pour toutes les femmes de mon listing

Pouvez-vous m’aider a trouver mon erreur SVP
Merci par avance.

La formule est fausse remplace la par:
=SI(A1="M";"Mr";SI(ET(A1="F";D1="");"Mlle";"Mme"))

Et si il n’y a que des M et des F en colonne A, tu peux même simplifier en :
=SI(A1=“M”;“Mr”;SI(D1="");“Mlle”;“Mme”))

Merci bcp pour ta précieuse aide : ca fonctionne nickel