Forum Clubic

(Résolu) Demande Aide Fonction "recherchev" excel

Bonjour à tous,
Je pense avoir bien effectuer ma formule mais pourtant j’ai le droit à un #N/A

voila m’a formule : =SI(B1<>"";RECHERCHEV(B1;‘top 250’!$A$2:$C$250;3;0);"")

Mes feuilles :

-top 250 où il y a en B le nom des produits et en C les quantités vendues (il y a des listes si jamais cela peut jouer…)
-top 50 où il y a en B le nom des produits et je veux en C les quantités vendues

Ma boss à voulu faire un top50 mais a oublié de mettre les quantités vendues…

Et ma formule ne fonctionne pas et je comprend pas pourquoi car je pense bien l’avoir faite.

Merci de m’aider je m’arrache les cheveux =)
Edité le 19/06/2009 à 10:38

essaye avec
=SI(B1<>"";RECHERCHEV(B1;‘top 250’!$B$2:$C$250;2;0);"")
Excel recherche la correspondance avec la premiere colonne de la matrice. S’il ne trouve pas (toi c’est la colonne a) --> #n/a
Edité le 18/06/2009 à 18:02

J’aurais mis : =SI(B1<>"";RECHERCHEV(B1;* "top 250* "!$A$2:$C$250;3;0);"")
et pas

  • 'top 250*

Essaye ça : =SI(B2<>"";RECHERCHEV(“top 250”;B2:C5;2;0);"")

Sans $, B2:C5 s’incrémente quand tu recopies vers le bas !

Exact… autant pour moi… donc avec les $

Youpi ! ça a marché! Merci Beaucoup!!