Forum Clubic

[résolu] Comment charger un module plus tôt?

Je viens de recompiler un kernel 2.6.13, pour avoir la gestion de mon chip ide it8212, avec une ubuntu. Seulement, celui-ci ne doit pas se charger assez rapidement car si je rajoute une ligne dans mon fstab pour le disque relié à ce chip, ça pose problème: le système de fichiers n’est pas reconnu, etc…(erreur au niveau de Fsck au boot)
Le truc c’est que le module se charge bien puisque ensuite je peux le monter sans problème. Pas besoin de modprobe ni quoi que ce soit.
Je me dis que peut-être en le chargeant plus rapidement, je n’aurais plus ce problème.
avez vous une idée?

en le forçant à le charger, dans /etc/modules, ça ne marcherait pas ?

Non, ça ne fonctionne pas avec /etc/modules.
J’ai bien éssayer modconf aussi mais seulement je n’arrive pas à le lancer, lorsque je tape modconf (ou sudo modconf) :command not found

Recompiler un kernel avec it8212 compilé en dur au lieu d’être en module.

J’ai tenté (et pas qu’une fois) la compilation en dur, mais ça aboutit à un kernel panic!

J’ai tenté le reformatage du disque (on sait jamais…), changer le initrd par mkinitrd, de passer tout un tas d’options à e2fsck au boot, mais rien toujours la même *%*ù### :grrr: :grrr: :grrr: !
“No such file or directory on /dev/hde1”

Personne, n’as une idée?

ça y’est!!!!!!!!!!!!!!!!!!! :bounce: :bounce: :bounce: :clap: :clap: :clap:
bon en fait j’ai compilé en dur le driver, mais les fois d’avant je n’avais pas pensé à faire certaines modif dans le menu.list de grub. Le fait de compiler en dur fais que le nom de mes disques changent: hde=>hda et hda=>hde d’où la bonne blague du kernel panic.

Il y avait aussi la solution de créer un initrd pour le noyau.
Mais je préfère compiler les modules en dur.

ça je l’avais déja fais. en fait, j’ai compiler le noyau avec make-kpkg et les options: buildpackage et --initrd.
J’ai même éssayé de modifier le initrd avec mkinitrd, mais cela n’avais rien changé.

Et tu avais bien chargé l’initrd ? (bien configurer grub ?)

Oui oui, j’avais bien changé grub. Je me suis même dis, ça vient peut-être du formatage, donc j’ai reformaté entièrement mon disque, mais rien que dalle! E2fsck me disait toujours:
/dev/hde1 no such file or directory …
alors que lorsque je le maontais à la fin du boot pas de problèmes.
De plus, pendant le reformatage, j’ai déplacé tous les fichiers et j’ai eu un max de gelle pendant les transferts, une galère infame.
Maintenant qu’il est en dur, j’ai transféré tout en un seul coup pas de prob!