Forum Clubic

[RESOLU] Barre de recherche qui disparait

Bonjour,

je suis sous windows XP pro et du jour au lendemain je n’ai plus eu accès à ma barre de recherche!
Voila ce que j’obtiens.
http://img378.imageshack.us/img378/161/bug9fi.jpg

Il y a un autre topic sur le forum qui parle d’un problème du genre sous une version anterieure de windows, mais je ne peux pas réinstaller windows parce que ces pignouf de chez dell ne fournissent pas le cd de windows avec le pc que j’ai.

Merci pour vos conseils

Tu as un MasterCD ou un truc dans le genre…

Là, tu as choppé une saloperie comme un virus ou un spyware.

Salut,

essaye de réenregistrer la dll de recherche
> démarrer - executer - taper:
regsvr32 %systemroot%\srchasst\srchui.dll

(mettre un espace derrière regsvr32)

ca marque " Dll registerserver dans c:\WINDOWS\srchasst\srchui.dll reussi."

Le système de recherche ne marche toutjours pas, je vais redemarrer windows

J’ai passé un scan avast avec les dernieres mises a jour et rien trouvé

Essaye en “désenregistrant” la DLL et l’enregistrant de nouveau


regsvr32 -u %systemroot%\srchasst\srchui.dll
regsvr32 %systemroot%\srchasst\srchui.dll

Une autre solution est de réinstaller l’assistant proprement-dit:

  • aller dans le dossier c:\windows\inf
    ( dossier caché - activer au besoin l’affichage des dossiers cachés)
  • clic droit sur le fichier: srchasst.inf -> installer

Ps: ton PC n’ayant pas de CD d’installation de XP, je ne sais pas si XP va demander quelque chose ou se débrouiller seul dans ses dossiers. Tiens nous au courant

1ere solution ne fonctionne pas :smiley:

pour la 2eme il me demande le cd d’installe je sais pas trop comment faire je vais essayer a l’occasion avec un cd pas SP2 mais je pense que ca va pas marcher

oui, essaye . Si ça ne fonctionne pas, on continuera à chercher d’autres solutions.

ca a réinstallé avec le CD du windows SP1 mais la barre de recherche ne s’affiche toujours pas.

Essayons autre chose
Voir dans le registre si une interdiction ne serait pas positionnée

> démarrer - executer - taper: regedit
dans ces 2 clés:
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
->voir si une valeur nommée Nofind de type DWORD aurait 1 comme donnée
Si oui, rentrer 0 comme donnée

Dans USER\…\Explorer j’ai pas NoFind ch’ai pas koi
J’ai “NoDriveTypeAutorun” valeur: 91

Dans MACHINE\…\Policies j’ai pas Explorer
J’ai:

NonEnum
Rating
System

Dis moi tu t’appelles pas Bill Gates par hazard pour connaitre aussi bien windows?

Bill Gate est un commercial, un négociateur et un financier, pas un "informaticien" ! :wink:

non non :lol:

Essaye alors ceci:
>démarrer - executer - taper :

regsvr32 /i browseui
  • [entree]
    si ça ne fonctionne toujours pas:
regsvr32 /i shell32
  • [entree]

Toutes ces pistes viennent de recherches diverses effectuées à la suite de problemes sur la fonction “Rechercher” postés dans le forum . Chacune avait résolu un probleme spécifique . Mais j’ai l’ impression que le tien va donner du fil à retordre car la fonction marche chez toi, mais avec une fenetre ‘vide’

re,

Une autre piste que je viens de trouver:
Page Microsoft: "Several dialog boxes are blank"
http://support.microsoft.com/?scid=kb%3Ben…831430&x=7&y=12

Elle est relative à un probleme de boites de dialogue vides qu’on peut rencontrer sur:

  • Search companion ( <-- notre cas)
  • user accounts
  • Windows update
    etc

Il y a 2 méthodes à essayer:
la methode 1:
entrer ces commandes dans >Démarrer | executer:

regsvr32 vbscript.dll

et

regsvr32 jscript.dll

Si XP dit qu’il ne trouve pas les Dll en cause, il est expliqué comment les recharger depuis le CD de XP.

la méthode 2:
Intervention en éditant le registre

La page est en anglais . Si tu la veux en FR, aller en haut à droite, sélectionner French, dans le champ Traductions disponibles

voilà

no no pa la peine je suis bilingue :smiley:

oh y’a kaspersky qui s’en mêle,
Dans une messageBox
http://img527.imageshack.us/img527/9526/bug0lb.jpg

j’ai desinstallé kaspersky ça ne fait plus le message d’erreur mais y’a toujours le problème de recherche

wouu c’est bon ça fonctionne, ca devait venir des dll jscript ou vbscript …

merci beaucoup les vampes :bounce: