Forum Clubic

[résolu] Bah alors K3B tu veux pas graver ?

bonjour tout le monde,
voila j’ai installé ubuntu feisty pour la tester et parce que j’aime bien avoir la derniere version des logiciels elle fonctionne bien (quelques bug mais c’est normal, elle est pas encore mure) a part K3B qui ne veut pas graver voici le log d’erreur qu’il me donne


System
-----------------------
K3b Version: 0.12.17

KDE Version: 3.5.6
QT Version:  3.3.7
Kernel:      2.6.20-13-generic
Devices
-----------------------
PLEXTOR DVDR   PX-716A 1.10 (/dev/scd1, ) at  [CD-R; CD-RW; CD-ROM; DVD-ROM; DVD-R; DVD-RW; DVD-R DL; DVD+R; DVD+RW; DVD+R DL] [DVD-ROM; DVD-R séquentiel; DVD-R double couche séquentiel; DVD RW à réinscription limitée; DVD-RW séquentiel; DVD+RW; DVD+R; DVD+R double couche; CD-ROM; CD-R; CD-RW] [SAO; TAO; RAW; SAO/R96P; SAO/R96R; RAW/R16; RAW/R96P; RAW/R96R; Réinscription restreinte]

HL-DT-ST DVD-ROM GDR8162B 0015 (/dev/scd0, ) at  [CD-ROM; DVD-ROM] [DVD-ROM; CD-ROM] [Aucun(e)]
K3b
-----------------------
Size of filesystem calculated: 340042

Used versions
-----------------------
cdrecord: 2.1.1a03

cdrecord
-----------------------
TOC Type: 1 = CD-ROM
scsidev: '1,1,0'
scsibus: 1 target: 1 lun: 0
scsidev: 'ATA:1,1,0'
devname: 'ATA'
scsibus: 1 target: 1 lun: 0
wodim: No such file or directory. 
Cannot open SCSI driver!
For possible targets try 'wodim --devices' or 'wodim -scanbus'.
For possible transport specifiers try 'wodim dev=help'.
For IDE/ATAPI devices configuration, see the file README.ATAPI.setup from
the wodim documentation.

cdrecord command:
-----------------------
/usr/bin/cdrecord -v gracetime=2 dev=1,1,0 speed=48 -dao driveropts=burnfree -overburn -data -tsize=340042s - 

mkisofs
-----------------------
340042
I: -input-charset not specified, using utf-8 (detected in locale settings)
genisoimage: Connection reset by peer. cannot fwrite 2048*1

mkisofs command:
-----------------------
/usr/bin/mkisofs -gui -graft-points -volid K3b data project -volset  -appid K3B THE CD KREATOR (C) 1998-2005 SEBASTIAN TRUEG AND THE K3B TEAM -publisher  -preparer  -sysid LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/kde-xerxesis/k3bCGtzNb.tmp -rational-rock -hide-list /tmp/kde-xerxesis/k3bfkgmHb.tmp -joliet -hide-joliet-list /tmp/kde-xerxesis/k3bmm9Jna.tmp -full-iso9660-filenames -iso-level 2 -path-list /tmp/kde-xerxesis/k3bvjRSkb.tmp 

ce n’est pas super important mais c’est quand meme génant,
en cherchant sur le net je me suis aperçu que d’autres avaient eu le meme probleme mais sans jamais donné la moindre solution (les autres sont sous sid)
merci beaucoup
cordialement

Pour te sortir de l’embarras le temps qu’une solution soit trouvée pour ce problème, tu peux utiliser Brasero, qui n’est pas mal du tout soit dit au passage.

je suis désolé mais je n’aime pas installer un logiciel gnome sous kde

si tu lances la commande cdrecord à la main pour graver quelque chose, est ce que ça marche ?

par exemple :

cdrecord -v uneimagedecd.iso
ou peut-être
cdrecord -v -dev /dev/hdd uneimagedecd.iso

(avec le device de ton graveur à la place de /dev/hdd)

eh bien oui ça fonctionne tres bien (j’ai graver l’image de gentoo)
mais sais tu comment je dois m’y prendre pour graver un compilation de données
cordialement
et merci

tu commence par creer une iso avec mkisofs (désolé, je ne m’en suis jamais servi directement, essais le man pour avoir les arguments qui vont bien)
et ensuite tu la graves avec cdrecord.

dans le log que tu post, je ne vois pas de message d’erreur, j’ai mal lu ou il n’y en a pas ?

Au passage, je suis sous sid et je ne me souviens pas d’avoir eu ce problème… en même temps, la dernière fois que j’ai gravé un truc qui n’est pas une image…

http://www.hiboox.com/vignettes/1307/c97a823d.jpg
autant pour moi je l’ai pas bien lu voici les messages d’erreur que j’ai reçu

As-tu essayer de graver en mode Tao?

Sinon voila un lien qui devrait d’intéresser: http://cyriaque.dupoirieux.free.fr/linux/l…ls.html#Graveur

décoche dans k3b l’option “supprimer l’image après une gravure” et essais de graver directement l’image générée /tmp/kde-xeresis/k3bimage.iso avec la ligne de commande qu’il te donne dans son log, puis avec une ligne simple du genre cdrecord -v blabla.iso
et copie nous les messages d’erreur (tous les messages tant qu’à faire ;))

Bon bah j’ai trouvé d’ou venait mon probleme voici donc la solution la plus simple que j’ai trouvé
il faut d’abord télécharger les sources de la derniere version stable et mettre le fichier télécharger dans le répertoire personnel
http://k3b.plainblack.com/download
ensuite il faut la compiler mais d’abord il faut installer ça


sudo apt-get install xorg-dev
sudo apt-get install kde-devel 

et enfin on compile en mode super utilisateur


& sudo -s
# tar -xjvf k3b-0.11.10.tar.bz2
# cd k3b-0.11.10
# ./configure
# make
# su -c "make install"

merci a tous de votre aide
cordialement

un peu radicale quand même ta solution :paf:

au passage, tu n’est pas obligé de compiler en root ! c’est juste pour l’installation.

et même pour l’installation, tu peux utiliser checkinstall, ça te créé un paquet .deb, il ne gerera pas les dépendances “comme les vrai” mais au moins enregistera les fichiers dans la base dpkg.
parce que là, à la prochaine mise à jour de k3b, tous les fichiers sont écrasé par ceux de la mise à jour. et si tu en avais en plus, et qui ne fonctionnaient que avec la 1.0 et pas la 0.12, ça peut causer des soucis !

effectivement je n’y avais pas penser mais bon j’en profite tant que ce ça marche :ane:
merci encore pour ton aide