Forum Clubic

Reconnaisance de caractere

voila j’ai un tres gros souci qui me pouri la vie sur ma redhat9

qd je creer moi meme des page php ou html et que je les met sur un serveur web, les caracteres accentuer deraille un max.

en revanche, si c mon boss qui cree ces page(sous windows), ca fonctionne, et la moi aussi je les voi correctement…

je ne comprend pas… si qq’un a une idee, merci

tes fichiers textes doivent être enregistrés en utf-8 je pense alors que la majorité des navigateurs sont réglés pour lire de l’iso-8859-1(5)

+1, problème d’encodage des caractères

ba j’ai tt essayé, de les mettre ne utf8 - en iso etc…

sans succes !!!

AU SECOOOOOOUUUUURR !!!

Utilise les balises HTML adaptées au caractères non US-ASCII.

lol, ba ouai, mais bon, je ne fait pas ce que je veu moi !!!

je suis dépendant du grand chef !

non, personne ne voi??? :frowning:

[fixed]

W3C crée des standards pour le Web. [/fixed] Est-ce que tu as un truc comme çà où tu fixes l'encodage de la page web ?

non, mais ca ca y ai deja… en fait, ca vien de mon pc, de ma config global puisque quelque soit l’editeur utilisé, ca me plante tt mes accent. si je retourne soous win, je voi bien que ca merde, je les modifi, et c’est de nouveau bon sous redhat, et la, moi sous linux, je vois des caré, mais pourtant, c bon !

Peux-tu mettre l’entête d’une de tes pages web. Ou la mettre en ligne, qu’on puisse voir ?

euh…dans kwrite par exemple, quand on met “enregistrer sous”, en haut à droite de la ptite fenêtre on peut choisir l’encodage…

Normalement ton éditeur doit avoir une option pour choisir le bon encodage :slight_smile: