Forum Clubic

Ralentissement du son sur SB Audigy

:hello:

Je me suis acheté ces jours-ci une Sound Blaster Audigy SE (je n’avais plus de carte son depuis mon passage à Vista qui était très méchant avec les cartes de l’époque :ane:), tout fonctionne, le son est indiscutablement meilleur qu’avec le chip de la carte mère, le hic étant que régulièrement le son semble ralentir (juste une demi-seconde, mais ça se perçoit quand même et ça fait un craquement), notamment quand le PC bosse (au hasard, quand je surfe sur Clubic :o ).

Pourtant avec une carte son ça devrait logiquement être le contraire :confused: (son géré par la carte, donc ça décharge le proco ?) J’ai bien désactivé le chip de la carte mère dans le BIOS, les pilotes sont à jour (téléchargés automatiquement par Seven (64bits) lors de l’installation de la carte), et la suite logicielle fournie avec est à jour également, je ne vois pas trop à quoi ça pourrait être dû ?

Si quelqu’un a des suggestions, je suis preneur :smiley:

Merci d’avance :wink:

Désolé du up sauvage ^^ mais je profite d’une connexion temporaire :stuck_out_tongue:

J’ai finalement remarqué que ce problème n’intervient que sur la lecture de MP3, dans les vidéos ou dans le jeux, RAS, ça fonctionne très bien :heink:

Ca le fait aussi bien avec le Windows Media Player qu’avec le lecteur intégré de Creative (:riva:), et ça semble le faire un peu moins avec VLC. La qualité des MP3 ne semble pas en cause, ça le fait autant sur n’importe quel fichier, quel que soit sa qualité :paf:

Je continue à parler tout seul ^^

Après d’autres tests, ça ne déconne presque pas avec Winamp :heink:

Quelqu’un saurait le pourquoi du comment ? :smiley:

EDIT : fausse alerte, maintenant que j’ai récupéré ma connexion Internet et que je peux faire autre chose en écoutant de la zique, ça craque aussi avec WinAmp :grrr:
Edité le 19/04/2010 à 19:56

:hello:

Tu as installé quels drivers?

J’ai connu les mêmes problèmes avec une Emu en USB : ralentissement perceptible et craquements, y compris avec un player léger comme foobar.

On s’est apperçu assez rapidement que ca venait en grande partie de l’USB : la carte son et le disque externe étaient branchés sur le même Hub ce qui semblait contrarier le processeur. En les mettant sur des prises séparées il y a eu une nette amélioration.

Ensuite on a utilisé les réglages avancés de Foobar : mettre la priorité du thread de lecture à 7 (max), augmenter le buffer de lecture, laisser le taux d’échantillonnage à 44100 hz et restitution sur 24 bits. Utilisation aussi des drivers Asio4All pour réduire la latence au minimum. www.asio4all.com… . Pour finir, j’ai aussi modifié les réglages de l’antivirus pour qu’il n’analyse plus en temps réel les MP3 et les Flac.

Je ne connais pas trop le driver Creative actuel, mais tu devrais régler ton player et les drivers pour une restitution en 16 bits / 44.1 khz maxi.

J’ai aussi pu expérimenter des craquements avec ma M-Audio en utilisant le DSP de suréchantillonnage en qualité “ultra”. On ne voit pas une charge de processeur trop importante pourtant c’est bien ce qui semble poser problème.

Ben c’est une carte interne, pas USB :confused:

Pour les pilotes Windows a automatiquement téléchargé les derniers (ceux du CD étaient plus anciens) donc à priori c’est bon…

J’ai déjà augmenté le buffer, c’est vrai que ça a amélioré un peu les choses, je vais voir pour les autres pistes :wink:

Merci :wink:

J’ai eu des craquements aussi sur une carte PCI M-Audio, mais je dois dire que je l’avaisun peu cherché : décodage en 36 bits, échantillonnage en 96khz et resamplig en qualité ultra… en décochant juste l’ultra tout est revenu à la normale et je ne sens pas de différence de rendu.

J’ai remarqué aussi que c’est souvent des choses comme le surf internet qui déclenchent les craquements :confused: comme si le proco et/ou le disque n’arrivaient pas à suivre la cadence. Par contre la lecture des fichiers sur un partage réseau ne semble pas poser de problème :confused:² :heink:

'tain, elles sont limitées les options du WMP :paf:

Bon, en fouillant dans les options j’ai trouvé une case “désactiver les optimisations Sound Blaster”, ça à l’air de fonctionner un peu mieux, je teste plus avant pour être sûr :wink:

EDIT : fausse alerte :ane: Ca dépend fortement du fichier on dirait :confused:

EDIT 2 : baissé le taux d’échantillonnage, ça ne change rien (même au mini :() (ou alors un léger mieux, mais difficile de se faire une idée si rapidement)
Edité le 21/04/2010 à 21:07

De mieux en mieux, ça me fait la même chose… sur Deezer :paf:

Pourtant c’est du streaming là :confused:

EDIT : et sur Youtube, après vérification :confused:
Edité le 24/04/2010 à 10:23

Je sais, ca fait quelques jours mais j’ai fait des tests :o

J’ai joué sur plusieurs paramètres sur mon ordi et celui du cousinos : on arrive à régler les problèmes de craquements et/ou de ralentissement en jouant sur la taille du buffer. En gros, on dirait que c’est le disque dur qui n’arrive pas à suivre :confused:

Ca peut se confirmer par la première grosse amélioration chez le couz avec la désactivation de l’antivirus sur le flac et le mp3. Chez moi j’ai pu passer en 96 khz / mode ultra juste en passant le buffer à 1 Mo et plus aucun craquement :slight_smile:

Si tu veux tester avec foobar, Files -> preferences, ligne “advanced” -> Playback -> File buffering (mettre la valeur en ko). Mais bon si ca le fait aussi avec la musique en ligne, ca peut venir aussi de ta connexion internet qui a du mal à suivre.

Si ca le fait quand aussi quand tu lis des fichiers en local, faudrait vérifier tout ce qui peut perturber la lecture (accès disque, occupation processeur…). Un bon defrag, un glary utilities pour faire un peu de nettoyage, éventuellement exclure tes fichiers audio de l’analyse anti virus. Vérifier que tu n’a pas de processus “exotique” qui occupent ton disque ou ta connexion internet (il y a un module Glary pour ca aussi).

Bon courage ! :super:

Tu a essayer avec les drivers de daniel K ?

Au kazoo, le lien vers les drivers Audigy SE 7/64 forums.creative.com…

Il semblerait que j’ai reslu le probleme en arretant l’overclocking pour ma part (a priori c’est que le proc et la ram etaient pas d’accord mais je suis totalemnt ignoant pour ce qui est de regler la ram