Forum Clubic

Questions divers sur Archlinux Résolu

Bonsoir à tous,

hier soir, j’ai installé sur l’un de mes Pc Archlinux. Bon, avec mes 2 neurones qui me restent, le résultat est presque satisfaisant… Mais j’ai quelques questions à vous poser:

  1. J’ai comme carte graphique une Nvidia 9400GT. (04:00.0 VGA compatible controller: NVIDIA Corporation G96 [GeForce 9400 GT] (rev a1)) D’après ce que j’ai lu sur le site Archlinux, j’ai pris comme driver: Nouveau.
    Ai-je fait le bon choix? Parce que dans Information sytème, Carte graphique Inconnue

  2. Avant de lancer gdm, mon clavier est bien en azerty. Ensuite je lance gdm. Et là patatra, au moment de sasir mon mot de passe, mon clavier devient qwerty. Et quand j’arrive dans gnome, le clavier redevient azerty (Une histoire de fou) Pouvez-me dire comment régler ce problème?
    Le réglage se fait-il dans /etc/X11/xorg.conf.d/10-evdev.conf

Section “InputClass”
Identifier “evdev keyboard catchall”
MatchIsKeyboard “on”
MatchDevicePath “/dev/input/event*”
Driver “evdev”
EndSection

Ou bien dans /etc/rc.conf

HARDWARECLOCK=“UTC”
TIMEZONE=“Europe/Paris”
KEYMAP=“fr-pc”
CONSOLEFONT=“lat9w-16”
CONSOLEMAP=
LOCALE=“fr_FR.utf8”
DAEMON_LOCALE=“yes”
USECOLOR=“yes”

  1. Et une dernière question pour la route. Pouvez-vous m’expliquer, en quelques mots, la différence en startx et gdm?
    J’ai lu plusieurs fois le wiki mais à chaque à fois mes 2 neurones se sont déconnectés…

Sinon, je trouve cette distrib superbe. Je me suis vite habitué à gnome3. Que du bonheur!!!

Je vous remercie mille fois pour votre aide.
Edité le 17/03/2012 à 19:12

gdm est un gestionnaire de sessions graphique.
startx lance une session X sous le nom de la session utilisateur depuis laquelle il est appelé.

La disposition du clavier doit pouvoir se régler via le menu gdm.
Mais normalement il se contente de suivre les les paramètres des locales système. Ça fait un bail que j’avais pas vu ça dans xorg.conf.

C’est quoi “Information sytème” ?
Sinon, si “nouveau” ne te suffit pas, tu peux installer le driver proprio. Le wiki est assez explicite là dessus.

Ajoute ce fichier (/etc/X11/xorg.conf.d/01-keyboard-layout.conf) et X prendra la layout Fr pour ton clavier :

Section "InputClass"
        Identifier "keyboard-layout"
        Driver "evdev"
        MatchIsKeyboard "yes"
        Option "XkbLayout" "fr"
EndSection

Lithium a répondu à cela :slight_smile:
Edité le 10/03/2012 à 00:25


[quote="lithium_1_1"]

Mais normalement il se contente de suivre les les paramètres des locales système. Ça fait un bail que j’avais pas vu ça dans xorg.conf.
[/quote]

Une locale ne défini pas un layout de clavier :slight_smile:

Merci pour l’aide. Dès le lever du soleil, Archlinux toute la journée…

Bonne nuit à tous

Ps: Information système, c’est une application que j’ai trouvé dans Gnome
Edité le 10/03/2012 à 00:40

C’est encore moi.

Tout d’abord, mon problème de clavier est réglé. Bonne chose de faîte. Merci 1000 fois à olafkewl
Ensuite, j’ai réussi d’installer mon imprimante Hp (branchée sur ma Freebox) et ma webcam Logitech C270 sans problème.

Mon dernier problème, c’est mon disque dur externe (usb). Il refuse de se monter. J’ai bien mis hal mais rien à faire. Avez-vous une idée??? (Sous Linux Mint, j’accède à ce disque dur sans difficulté)
Je vous remercie pour votre aide.
Edité le 16/03/2012 à 09:59

Quel WM et comment le demarres tu ? (paste ton .xinitrc)

Excuses-moi pour mon ignorance mais je ne comprends pas WM.
N’ayant pas mon Pc Archlinux sous la main, je te copierai mon .xinitric ce soir

WM = Window Manager ou Desktop Manager

Bizarre depuis ce matin plus de problème avec mon disque dur externe.