Forum Clubic

Quelle Distribution Me Conseillez Vous Pour... - un simulateur WAN

salut tous les linuxeurs :\

J’ai pour projet de tester l’effcicaté de différents protocoles de voix sur ip. Pour cela je procederait de la maniere suivante.

SERVEUR-----------SIMULATEUR WAN----------------CLIENT VoIP

Serveur = serveur asterisk
Client voip = un pc sous windows avec Firefly
Simulateur WAN = un pc sous linux avec les packages nécessaires ici

donc je voulais vous demandez quelle distribution vous me conseiller pour mon simulateur WAN selon ces packages.

PS: j’ai deja tenter red-hat Fedora Core 3 et je m’en suis mordu les doigts. Alors now je demande avant de me lancer.

merci a tous

Debian Sarge :slight_smile:

euh si avec FD3 il en chie je lui dirais pas de sarge à part si il est près à bouffer de la doc…
A mon avis une ubuntu ferait bien l’affaire

et pourquoi pas, le forum ubuntu tourne sur une ubuntu :stuck_out_tongue:

Ubuntu n’est pas fait pour les serveurs :o

Je voudrais juste une distribution ou les packages cités au debut tourneraient sans probleme de compilation, installation… comme j’ai eu sous FC3 avec des nombreux logiciels…

Personne ne pense a mandrake ? c’est peut etre trop noob…

sur toutes les distrib les packages tournent sans pb. Ce qu’il faudrait regarder c’est qu’ils soient dans synaptic.
Tu peux prendre aussi une mandrake si tu veux.
Si ce n’est qu’un test n’importe qu’elle distrib fera l’affaire. Si c’est pour faire quelque chose de durable qui doit être très optimisé, tourne toi comme lithium l’a dit vers une sarge

ah non c juste pour faire une serie de mesure en faisant varier de nombreu parametres. Mes tests dureront de 1 semaine maxi. Alors Mandrake s’est coolos ?

merci les gars :slight_smile:

mandrake tournera nickel tu peu viser une knoppix n install dur c est assez stable sinon

je prefers ubuntu à mdk mais fait comme tu veux, les 2 sont aussi simple

netem semble integre au noyau

http://developer.osdl.org/shemminger/netem/contact.html

tu ne devrais avoir aucun souci avec aucune distrib pour l’utiliser…

a moins que la fedora soit trop patchee ??? quels etaient tes problemes avec ?

installation et surtou compilation de client de VoIP. Rien a voir donc avec netem. Donc je v prendre Madrake 10.1 et sa devrait rouler.

Merci a vous obscur utilisateur de linux… :ph34r:

ah ok ! donc ta question est : "quelle distribution me conseillerez vous pour installer le logiciel X de VoIP ?" <_<

detaille tes problemes de compil ou d’install avec la fedora, car j’ai du mal a imaginer ce qui pourra bien changer avec une mandriva…

Et bien je telechargeais un fichier en .tar.gz (un truc comme sa).
Donc je dézip et sa me donne un dossier avec des fichier dedans, et apres que faire… ./configure make make install

je trouve ces 3 instructions tres vastes (quel repertoire cible entre autre et quel parametres a ces fonctions??)

sinon pour mon simulateur de WAN il est di qu’il fau 3 packages. Pour le NIST et l’ip route2 sa devrai aller, encore faut il savoir compiler. Mais pour dummynet je ne vois pas ce qu’est FreeBSD et comment l’utilisé.

merci

pour info :

./configure genere un Makefile en fonction de ton environnement.
make compile les sources en fonction du Makefile
make install copie les fichiers compile la ou il faut

Dans la pratique, il est rare qu’on recompile une appli (ca arrvie encore car c’est pas bien complique a faire sous linux)
As tu verifie si des packages officiels de ton appli existent pour ta distrib ? des packages non officiels ?
Si non, as tu verifie si le site sur lequel tu as telecharge l’appli proposait une version .tar.gz binaire ?
Si non, quelles sont les erreurs de compilation ? as tu installe les packages de dev ?

Si tu ne sais pas ce qu’est un package, lis la doc de ta distrib, tu te simplifieras beaucoup la vie ! :slight_smile:

ah je viens de trouver une doc sur NISTnet qui est un equivalent de dummynet qui ne tourne que sur freebsd (freebsd est un OS comme unix au meme titre que linux… il est juste moins populaire)
M’enfin, ca n’a pas l’air tout jeune et pas vraiment encore actif… peut etre devrais tu chercher autre chose ?
iproute2 est preinstalle sur toutes les distrib moderne… donc rien a faire la dessus
quelle est la doc que tu utilises ?

hihihi ca y est j’ai installer Mandrake 10.1

3615 MAVIE [ON]
L’ordinateur ayant tourné pendant toute la nuit j’ai super mal dormit :wacko:
3615 MAVIE [OFF]

Et la, ôôôôôôôôôhhhhhhh joie linuxienne !!!! :

Je prend .tar.gz
Je le dezip
je fais ./configure
il repond : "You need install the kernel source!" ok…
je fais ./Load.Nistnet
il repon :"Sorry, NIST Net runs only on 2.0 2.2 or 2.4 kernels"

Sa veut dire que je tourne sur une version de kernel plus élevé ?
Bref comment je fais…

Et autre bonne surprise, mandrake ne voit que une carte reseau a la fois (je suis sur un portable plutot vieux, celeron 1.2Ghz et win98 pour situer)

voila je commence a deprimé :frowning: puisque mon stage se termine en fin de semaine prochaine :frowning: et ma simulation de WAN n’est pas prete de marcher ! :frowning:

merci all,

le weak de linux…

t’arrive pas à avoir ce logiciel via le gestionnaire de package? ca t’éviterais de le compiler…

Mouarf c’est quoi cte bete. Des gestionnaires de fichiers yen a plein sous Mandrake 10.1.

Tu parles de celui qui est dans Configurer Votre Ordianteur ?

Si oui (ou si non) explique un peu comment sa marche, la fonstion recherche ne trouve pas le .tar.gz de iproute2

si vous voulez tester vous meme : http://developer.osdl.org/dev/iproute2/download/
(j’ai pris le .tar.gz le plus en haut…)

mille merci pour vos conseils, j’avance peu a tous vos posts

non en fait t’as un gestionnaire de package qui contient près de 3000 logiciels, il te suffit de tire rechercher le package que tu veux, et ensuite ça le télécharge et ça l’install, t’as pas à t’occuper de la compilation et des dépendances.
Par contre je suis plus comment il s’appelle, cherche un peu tu devrais le trouver dans les menu de KDE

urpmi peut-être ?