Forum Clubic

Pub pour IE8 javascript - Navigateur autre qu'IE et FF

Bonjour,

En jouant avec l’extension FF noscript, je me suis rendu compte qu’un moche bandeau apparait en autorisant le javascript, à savoir
“Vous ne disposez pas de la dernière version d’Internet Explorer. Pour une navigation plus rapide, TELECHARGER Internet Explorer 8 !”

Utilisant FF sous Linux, ce truc (IE) est complètement inutile.

Pourquoi ne pas l’afficher que pour les utilisateurs d’IE ? Ca semble plus logique … :neutre:

edit: titre modifié
edit2: titre modifié de nouveau
edit3: y a pu le bandeau (même sous IE7) tant mieux :stuck_out_tongue:
Edité le 11/07/2009 à 22:24

Hum,

Etant curieux de nature, j’ai testé sur un winXP, avec FF 3.07, point de pub, avec IE7 le bandeau est la !
Mea culpa, donc, votre analyseur de butineurs ne doit surement pas prendre en compte Iceweasel (FF sous Debian)

Si vous pouvez ajouter un test sur la valeur Iceweasel de HTTP_USER_AGENT, vous aurez ma reconnaissance (et celle des debianistes passant par ici)

Merci d’avance :slight_smile:

Pour être précis, ça reconnait uniquement Firefox et IE 8, et affiche le lien sur tous les autres navigateurs. Lien qui ne fonctionne d’ailleurs même pas :paf:.

En attendant une correction, pour les utilisateurs d’Opera, voilà un petit user.js pour faire disparaître le bandeau :

// ==UserScript==
	// @include http://www.clubic.com/*
	// ==/UserScript==
window.opera.defineMagicFunction(
  'check_version',
  function ( oRealFunc, oThis) {
    return 4;
  }
);

Merci pour cette précision de taille, kookiz33 !!

Le team Cluclu n’utilise qu’IE ou FF ?
Piste -> www.clubic.com… :smiley:

Pareil, sous Safari (Mac) et Konqueror (Linux), on ne se sent pas trop concerné. Et le bandeau pique les yeux.

Bon il y a toujours la solution de se faire passer pour un Firefox (les 2 permettent de changer l’identité du navigateur), mais c’est pas terrible comme solution :confused:

UP, parce que le liseré est réapparu aujourd’hui (safari Mac)

Vous faites un test “si la version n’est pas bonne et si ce n’est pas firefox”.

Ça n’est pas possible de faire “si la version n’est pas bonne et si c’est IE” ?