Forum Clubic

Proxy au bureau mais pas à la maison. Automatisable ?

Bonjour tous

Voilà au bureau et à la maison mon portable se connecte via un profil WIFI à Internet, en DHCP, ça marche finement. Il obtient la bonne ip, la passerelle, et le lan fonctionne bien.

En revanche pour le web, au bureau, j’ai besoin d’un proxy pour naviguer, je dois donc cocher proxy dans mon internet explorer et renseigner manuellement 192.168.0.1 port 3128, idem dans avast pour les mises à jour, idem dans msn

Une fois à la maison c’est l’inverse, il faut encore que je fasse le tour de tous mes programmes pour désactuver le proxy du bureau

Existe-t-il un logiciel ou un paramétrage qui permette de configurer le proxy automatiquement (ou de le désactiver automatiquement) lorsque la connexion wifi se fait au bureau, ou à la maison ?

Merci

Oui, facilement automatisable à l’aide d’un fichier.pac

exemple www.ac-creteil.fr…

Merci pour cette piste :hello:

J’ai donc fait un fichier pac qui je pense est adapté au bureau (ftp en direct et http via squid)

function FindProxyForURL(url, host)
{
	if (url.substring(0, 4) == "ftp:")
	{
		return "DIRECT";
	}
	else
	{
		return "PROXY 192.168.0.1:3128 ; DIRECT";
	}
}

Par contre je vois bien ou on le configure dans IE, mais pas ou on le place physiquement. Je n’ai pas de serveur web, juste une machine Linux en passerelle avec Squid installé

Le fichier pac doit être sur mon pc ou sur la machine qui héberge squid ?

edit : Merci ça marche pour le bureau déjà !

Je l’ai mis dans la racine de mon pc et j’ai mis dans IE :

file://c:/proxy.pac

Me reste à tester si c’est bien pris en compte dans msn et avast, puis à tester à la maison que tout passe en direct :super:
Edité le 23/01/2008 à 12:23

non sur ta machine

dans ie --> outils - options internet --> connexion --> parametre R --> utiliser un fichier de … tu met ton lien [c:…](file://c:/ton) fichier.pac

La synthax que tu a copier coller ne marchera pas :slight_smile:

La ça marche pour IE et Avast déjà, avec le proxy actif au bureau

aMSN ne permet pas de configurer automatiquement le proxy, tout est en manuel, je vais essayer avec Pidgin ou Trillian basic :frowning:

Heuu, quelle syntaxe ne marchera pas ?

if (url.substring(0, 4) == “ftp:”)
{
return “DIRECT”;
}

quand tu sera chez toi ca ne marchera pas :slight_smile:

car il faut que tu configure l’adresse ip de ton réseau

En fait cette syntaxe c’est juste que le ftp passe en direct sans proxy au bureau contrairement au http

Par contre les conséquences a la maisons là, effectivement je peux pas te dire

Je vais essayer de brancher le portable en filaire en DMZ pour voir comment ça se comporte quand 192.168.0.1 ne répond pas

edit : ca marche aussi en DMZ :super:

Je reposte si je trouve des trucs louches, merci encore
Edité le 23/01/2008 à 12:50

De rien :slight_smile: