Forum Clubic

Programme XHTML firefox/ie

Bonjour je dois creer un site en XHTML stric 1.0 cependant je le test en local et quand je l’ouvre avec firefox l image n’apparait pas alors que sous ie elle apparait. quelqu’un pourrait il me dire comment faire pour pouvoir aficher cette image sur firefox
merci d’avance

Salut,

Peux-tu nous montrer le code qui affiche cette image ? Sans ça on ne pourra pas t’aider.

:jap:

CSACCEUIL

Acceuil

CS, né à Marseille en France

22 ans, détenteur d'un "DUT Réseaux et Telecommunication" (bac+2)

marier 12 enfants, un chien, un cactus, un paquet de car en sac et trois dragibus.

Mon CV

Edité le 12/09/2007 à 13:51

Normal, car ton code n’est pas en XHTML mais en HTML. Et Firefox est moins laxiste que IE. En XHTML 1.0 strict, toutes les balises sont en minuscules…


<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" lang="fr">

<head>
<title>CSACCEUIL</title>
</head>

<body bgcolor="#3399FF">
<h1 align="center">Acceuil</h1>
<p align="center"><img src= "C:\Documents and Settings\Fasyr\Bureau\Cours\TDI\index.jpg" /></p>
<p align="center">CS, né à Marseille en France</p><p align="center">22 ans, détenteur d'un "DUT Réseaux et Telecommunication" (bac+2)</p><p align="center"> marier 12 enfants, un chien, un cactus, un paquet de car en sac et trois dragibus.</p>
<p align="center"><a href="cv.html">Mon CV</a></p>
</body>
</html>

De plus, pour ton image (<img … />), c’est une très mauvaise idée de mettre un chemin complet, surtout un chemin de ce genre si ton hébergeur tourne sous Unix.
Edité le 12/09/2007 à 16:58

Pour que tu sois indépendant, tu peux déboguer des pages (x)html ici :
validator.w3.org…
et tes css ici :
jigsaw.w3.org…

Remplace :

par un chemin relative du type :
ou sa depend ou ce trouve ta page html

Si tu tiens à garder ton chemin absolu.

file:///C:/Documents%20and%20Settings/Fasyr/Bureau/Cours/TDI\index.jpg

Voilà !
Le mieux serai encore un Easy php ou Wamp5.
Même si tu n’utilise pas php ou MySQL.
Comme ça, un simple : localhost / 127.0.0.1 …

C’est bon ca marche merci!!!

Penses à rajouter la mention {RESOLU} dans ton titre :wink: