Forum Clubic

Problèmes divers et variés sur Mandriva 2007 - Tout est dans le titre

Déjà, avant tout, désolé de vous importuner et merci pour votre attention.

J’ai récemment acquis Mandriva 2007 et je l’ai installé sans problème.

Mais depuis, je passe de Charybde en Scylla !

Après avoir passé un moment sur quelques problèmes sans envergure, je suis confronté à d’autres plus contreignant.
J’ai déjà fouillé un peu ce forum, mais tout ce que j’ai essayé n’a pas aboutit.

Voici mes problèmes :

  1. J’ai un écran plat Benq (certains auront déjà deviné le problème) et dès que je suis dans Mandriva, une “fenêtre” bleue apparaît au milieu de l’écran et affiche “out of range”. Le truc, c’est que cette “fenêtre” (qui est un message d’erreur de l’écran) ne disparaît pas et me gâche tout.
    En suivant certains conseils, je suis allé dans le root et ai tenté de modifier quelque chose, mais rien ne change, Out of Range persiste et signe.
    Que faire ?

  2. N’ayant pas droit au LAN, je capte ma connexion grâce à une clef USB WIFI Netgear WG111T.
    Mais je ne vois pas comment je pourrais installer les pilotes sur Mandriva, donc impossible de me connecter à internet depuis Mandriva.

  3. Le truc le plus stupide, car je suis totalement inexpérimenté sur Linux, comment on installe un logiciel ? (j’ai télécharger ici même Opéra 9.2 pour Linux mais je ne suis pas allé plus loin que la décompression XD)

Merci de répondre vite que je puisse quitter Windows à tout jamais ^^

Pour ton écran, la résolution ou les fréquences d’affichage ne doivent pas être bien détectée.
Ces informations sont définies dans le fichier /etc/X11/xorg.conf
En gros tu dois aller dans la section screen et voir si les modes définis corespondent bien à ce que tu attends.
Pour les fréquences de ton écrans, elle doivent être définis sur une étiquette dessus ou autrement tu devrais les trouver sur le site de benq dans le détail des caractéristiques.

Tu trouveras plus d’infos ici, meme si cette documentation est pour ubuntu, elle doit en très grande partie s’appliquer à ton cas (juste le sudo qui ne marche pas et il faut tape su avant de lancer la commande).

Pour ta clé wifi, attends d’avoir une interface graphique. Ensuite tu pourra voir si elle a été automatiquement. Si ce n’est pas le cas, regarde si un pilote linux existe et sinon utilise le pilote windows avec ndiswrapper.

Pour installer des logiciels sous une mandriva, il faut utiliser le gestionnaire de paquets (comme pour toutes les distribution de linux). Pour mandriva c’est rpmdrake ou urpmi: http://fr.wikipedia.org/wiki/Urpmi[/url] et [url=http://easyurpmi.zarb.org/?language=fr]http://easyurpmi.zarb.org/?language=fr

Sinon, pour l’écran, tu vas dans une console, tu passe en root (avec su) et tu tapes drakxconf
Il y aura alors un menu à l’écran, tu navigue avec les flèches du clavier, entrée pour sélectionner un item. Si tu trouve le modèle de ton écran dans la liste, c’est tout bon. Sinon, c’est modification du xorg.conf à la main ^^
Si la partie “drakxconf” ne marche pas, poste nous ton xorg.conf et indique le modèle de ton écran, qu’on te file le xorg.conf modifié qui va bien.

(pour la commande drakxconf : si c’est pas ça, tape le début, par exemple drak puis appuie sur tab : tu verras une liste des commandes existantes commençant par drak. Tu pourras ainsi voir ce qui s’en rapproche le plus. Il me semble qu’il existe aussi la commande drakconf, qui est plus générale : tu va alors dans la section “display”, et ça te permettra de paramétrer ton écran.)

Salut,

Évidement, les conseils précédent sont à effectuer avec un AUTRE écran (CRT?) si tu en as un sous la main sinon tu ne pourras rien faire :ane:

J’ai réussi à faire comme l’a dit jeanrhum.

D’après le long texte que j’ai lu, mon écran avait une préférence pour le 1680x1050

Donc j’ai modifié en mettant cette taille.
Après quoi, j’ai reçu le fameux message m’invitant à relancer la session pour que les changements soient pris en compte.

MAIS, car il y a un mais, ça a empiré XD

Maintenant, au lieu d’avoir juste le “Out of Range” qui me gachait l’écran (et m’empéchait de profiter pleinement du cube 3D), le reste de l’écran est devenu noir.

Arrivant toujours à accéder à la console, je me suis mis sur le root et ai suivi les conseils de Nico C’ys. Mais ça n’a servis à rien…

En clair, là j’ai encore plus besoin d’aide :riva:

Heureusement que j’avais gardé Windob pour pouvoir quand même me connecter à internet

Mon écran est un Benq de modèle FP202W (si ça peut aider d’une quelconque façon)

Poste ici ton xorg.conf, on va te modifier les lignes qui vont bien ^^

J’ai réussi à enlever le Out of Range !!!!
C’était bien un problème de résolution !

Reste le prob du Wi-Fi :neutre:
Je vois pas comment fonctionne ndiswrapper…

Et l’urpmi… c’est pas trop mon truc mais pour l’instant je vais faire sans…

Etant donné que j’ai le CD pour la clé USB Netgear (WG111T), je fais comment pour installer les pilotes ? :neutre:
Quelqu’un peut me dire plus ou moins la marche à suivre ?

T’embête pas avec urpmi : t’as déjà assez fait mumuse avec la ligne de commande pour l’instant :smiley: Fait une pause :wink:

Il me semble que le gestionnaire de paquets est accessible depuis le menu “Mandriva” (a la place du menu “démarrer” de win) -> Système -> Configuration -> Paquetages -> Installer, supprimer… Ou bien plus simplement par le menu “configurer votre ordinateur” (il te demandera ton mot de passe root). Si tu ne trouves pas, c’est mcc depuis une console, et tu as l’interface graphique du truc qui se lance. Le gestionnaire de paquets, c’est ce qui remplace tous les .exe et autre sous win. Il faut d’abord configurer les sources des paquetages, ceci se fait grâce au site http://easyurpmi.zarb.org
Tu y choisis ta distribution (2007.1 je crois, c’est écrit en haut de la fenêtre du centre de contrôle mandriva), tu fais ensuite “étape 2” Il te demandes alors de choisir quoi prendre, et où. Tu choisis dans les menus déroulants un serveur pas trop loin de chez toi (enfin, tu essayes, tu verras bien si le serveur est rapide ou non, tu peux recommencer la manip pour en changer plus tard) et tu coches les cases des sources que tu désires. Tu peux commencer par prendre main, contrib, non-free (pour des pilotes ou applis non libres), main_updates, contrib_updates, non-free_updates (toutes les mises à jour), et je te conseille aussi les plf, qui sont une mine incroyable de programmes en tout genres. Rajoutes donc plf-free et plf-nonfree. Tu peux cocher si tu le désire la case “utiliser les indexs compressés”, qui limiteras la taille des “listes” que tu vas récupéré, mais sache que j’ai rencontré quelques problèmes avec cette option, et tu y perds pas mal en informations. Donc au final, évites ^^
Passe ensuite à l’étape 3.
Tu n’échappes pas à la console ^^
Tu ouvres une console en root, et tu commences par taper ça :
urpmi.removemedia -a
Ça va enlever de tes sources de programmes les cd d’install, pour ne pas tout surcharger. Tu copiera ensuite une à une les commandes indiquées par le site. Une commande est de cette forme :
urpmi.addmedia machin url with hdlist.cz (ou with media_info/hdlist.cz)
Pour le copier/collé, tu sélectionne le texte à copier et tu fais un clic avec le bouton du milieu dans la console.
Si tu as un message d’erreur indiquant que le media n’a pas pu être mis à jour, c’est que le serveur est pas bon, dans ce cas, change le en retournant à l’étape 2.

Edit : pour ndiswrapper, je regarde d’abord si tu n’as pas un pilote compatible linux directement ^^

Bon je viens de regarder : il te faut ndiswrapper. Je ne connais pas la méthode en mode graphique, donc ligne de commande pour commencer ^^
Tu installes d’abord ndiswrapper (avec ton gestionnaire de paquetages maintenant configuré ^^).
Une fois cela de fait, tu récupère le pilote qui est sur ton cd et tu le mets quelque part où tu saura le retrouver sans problème ^^
Lance konqueror (l’explorateur de fichiers) et tapes dans la barre d’adresse man:ndiswrapper
Tu auras la doc sous les yeux :wink:
Tu ouvres ta console et tu pases en root.
Branches ta clé.
Tu tapes ndiswrapper -l pour vérifier qu’elle soit bien reconnue.
Ensuite tu vas chercher ton pilote (le fichier .inf). Pour cela, tapes ndiswrapper -i chemin/vers/lefichier.inf
Le pilote est maintenant installé.
Tapes alors ndiswra^er -m pour permettre à ndiswraper de charger ton pilote au démarrage. Normalement, ta clé wifi devrait fonctionner.

J’ai réussi a installer ndiswrapper, mais je bloques après.

Comment je passe de la console (j’utilise Konsole, est-ce bon ?) au root ?

Pour passer en root, tu utilise la commande su
Ça va alors te demander ton mot de passe root, que tu as défini lors de l’installation. Ne t’étonne pas de ne rien voir à l’écran quand tu vas le taper : c’est normal.
Pour la console, tu peux utiliser ce que tu veux : konsole marche très bien aussi ^^

Root, c’est le nom du “superutilisateur”, une sorte d’admin avec tous les pouvoirs. Faut pas faire trop de bêtises avec ^^

Merci ^^

Une fois dans le root, j’ai entré ce que tu m’as dit (ndiswrapper -i puis le chemin jusqu’au fichier .inf).

Déjà j’en avais trois, mais je les ai tous essayé.

A chaque fois, il m’affiche un truc, “ndiswrapper option” m’affichant toutes les commandes utilisables (-i pour installer, -d pour etc…)

Mais il ne semble pas vouloir installer ce pilote :neutre:

Copie/Colle ici la commande que tu as tapé.

Ah oui, si tu as des espaces dans le chemin, c’est comme ça :

/home/un\ type/bidule/fichier.inf

Le nom de l’utilisateur contient ici un espace (“un type”). Pour pas que la console pense que tu sépare deux options par l’espace, tu mets un antislash devant (altgr 8). Pour faire encore plus simple (magie de l’autocomplétion), tu ne tapes que le début du chemin et tu appuies sur tab : ça te complètera tout seul la suite du nom de dossier ou de fichier, et en cas de plusieurs possibilités, ça te complètera le nom autant que possible pour ensuite t’afficher les choix possibles. Tu ajoutes alors 1 lettre ou 2 et tu rappuies sur tab.

Voila la commande que j’ai tapé :

ndiswrapper -i home/raharu/WG111T_GRV1.2/WG111T_GR V1.2/un des trois fichier.inf

C’est l’espace qui va pas. Essaye voir aussi avec un / devant home

ndiswrapper -i /home/raharu/WG11T_GRV1.2/WG111T_GR\ V1.2/fichier.inf

en fait, habitue toi à utiliser l’autocomplétion : c’est très simple et ça te permet de gagner beaucoup de temps. Par exemple :

ndiswrapper -i /ho"tab" va te donner : ndiswrapper -i /home/ et ainsi de suite : tu ne tapes que le début à chaque fois, et ça complète tout seul, donc fini les problèmes avec la mise d’un espace ou non…

j’ai fait ce que tu m’as dit, mais ça m’a semblé léger comme installation…

J’ai encore une fois essayé avec les trois fichiers .inf, met à chaque fois, à peine les commandes entrées, il me disait instantanément que l’installation était finie.

j’ai ensuite fait -m, mais ça ouvre juste le fichier au démarrage…

Après j’ai essayé de paramètrer un réseau sans fil en cherchant dans le Centre de commande de Mandriva, mais il me dit à chaque fois qu’il y a un problème avec ndiswrapper.

Tape ndiswrapper -l pour lister les drivers installé.

Si c’est ok, tape modprobe ndiswrapper pour lancer ndiswrapper. Si tout va bien, tu n’as aucun message d’erreur. Tu peux alors vérifier que c’est le cas avec la commande : dmesg | tail

Bref voila les détails à cette adresse: http://www.andesi.org/index.php?node=109#A13