Forum Clubic

Problèmes avec Suse 9.3 - wifi et accéleration 3D materielle

Salut à tous.

J’ai decidé de mettre Linux sur mon portable, j’en ai marre des anti-spyware, anti-virus, anti-bidules de toutes sortes :na:

Donc, je me suis installé une Suse 9.3 qui marche très bien sauf que :

  • Impossible de faire marcher mon réseau wifi avec (chip Intersil), le materiel semble détecté correctement, la configuration se passe sans echec, mais au moment de tester la connexion, rien ne se passe. Dans un premier temps, j’ai pourtant ouvert en grand mon routeur : diffusion de SSID, pas de cryptage, pas de filtrage MAC. Quand je fais un scan wifi pour trouver un réseau, ya rien :frowning: .
  • Autre petit point qui me gêne (bien que moins grâve que le wifi), est que l’accélération materielle 3D n’est pas disponible (Radeon 9700). Même chose que plus haut, le materiel est détecté et fonctionne correctement, mais pourtant, impossible d’avoir de la 3D.

Vala :hello:

Pour le wifi, c bizarre et je ne vois pas vraiment ce qui pourrait coincer… :confused:

Pour l’ATI, tu peux la jeter a la pou… heuuu a on me dit dans l’oreillette que on peut pas…
Bon, alors tu installes les source du kernel (kernel-sources dans YaST) ansi que GCC (gcc dans YaST). Tu mets tout ca a jour avec YOU (YaST Online Update). Puis tu télécharge ça : http://www2.ati.com/drivers/linux/ati-driv…16.20-i386.run

Tu le rends executable (clic clic ou bien chmod +x blabla.run) et tu le lance en root (dans une console mais sous X (en graphique) quand meme).

Tu demandes “Generate Specific Driver Package” et ‘continue’
Tu acceptes la licence (et tu la lis hein :smiley: )
Tu choisis ta distrib (SuSE 9.3 en IA32 ou 64)
Il va te pondre le fichier spécifique a la SuSE 9.3

Ensuite tu tapes (toujours en root) : rpm -vih blablabla.rpm
Il va compiler le module après l’install du rpm tout seul.
Normalement ya pas d’erreur (sinon verifie tout les points)

Et pour finir, tu tapes la chtite ligne qu’il te dis a la fin, càd :

sax2 -r -m 0=fglrx -b /usr/share/doc/packages/fglrx/sax2-profile

tu fermes sax (pas tester)

Et tu relance X :sol:

Merci de tous ces details.
Je téléchargerai les drivers quand mon wifi marchera :wink:

A ce propos, quand il n’arrive pas à se connecter, il me propose d’aller voir le log de connexion. Je devrais ptet y jeter un coup d’oeil pour voir ce qui cloche :whistle: …

Je ferais un copier-coller des messages du log demain :hello:

Re …

Bon alors voici ce que me dit le log :

Un problème de firmware on dirait :??:

Oui il faut un firmware en fichier.

tape en root
locate isl3890

Jette un oeil là-dessus :
http://prism54.org/cgi-bin/viewcvs.cgi/tag…473&view=markup

Ayest j’ai trouvé :clap: :clap:

En fait il faut :

  • télécharger le firmware ici
  • copier ce fichier (c’est un fichier .arm normalement) dans /usr/lib/hotplug/firmware/
  • ensuite on ouvre un terminal dans ce dossier et on tape ln -s <fichier arm> isl3890

Vala :oui: .
Pour copier le firmware, il faut être admin bien sûre …

Pour revenir à l’accélération 3D materielle, j’ai pas trop bataillé (ça marchait pas), mais en fait je m’en balance, ça sera pas l’utilisation principale de l’ordi …