Forum Clubic

Problème serveur apache2

Bonjour,
il y a une semaine j’ai démarrer un serveur et je n’ai pas modifier depuis la création, je suis sur openSUSE leap
et depuis le lancement du serveur dès que je me connecte ça me met
ça:

Le délai d’attente est dépassé

Le serveur à l’adresse 00.00.000.000(c'est pas lui) met trop de temps à répondre.

Le site est peut-être temporairement indisponible ou surchargé. Réessayez plus tard ;
Si vous n’arrivez à naviguer sur aucun site, vérifiez la connexion au réseau de votre   ordinateur ;
Si votre ordinateur ou votre réseau est protégé par un pare-feu ou un proxy, assurez-vous que Firefox est autorisé à accéder au Web.

et j’ai verifié que je peut aller sur un site, je n’ai normalement pas de pare-feu et firefox marche très bien.
merci d’avance!

As tu vérifié que le processus Apache est bien lancé sur le serveur ? Selon la façon dont c’est configuré, il ne se lance pas forcément au démarrage du serveur.

Pour vérifier l’état d’Apache (s’il y a un souci, ça devrait aussi te donner des pistes) : sudo systemctl status apache2

S’il n’est simplement pas démarré, tu peux le démarrer avec sudo systemctl start apache2, et activer le démarrage automatique lors du démarrage de l’OS avec sudo systemctl enable apache2

Si Apache ne démarre pas, vérifie ce qu’il dit dans les logs (sudo journalctl -u apache2).

D’accord je vais le faire le plus vite possible parce que hier grub a fais la
" Fiesta " en réalité grub n’arrive pas à booter sur opensuse.

ça me met ça:

● apache2.service - The Apache Webserver
 Loaded: loaded (/usr/lib/systemd/system/apache2.service; disabled; vendor preset: >
 Active: inactive (dead)
lines 1-3/3 (END)...skipping...
● apache2.service - The Apache Webserver
 Loaded: loaded (/usr/lib/systemd/system/apache2.service; disabled; vendor preset:    disabled)
 Active: inactive (dead)

le dead :skull_and_crossbones: me fait un peut peur quand même je pense pas que dead :skull_and_crossbones: veut dire qu’il va bien mon serveur :sob:

ça me met rien juste il me mette une fênetre qui demande le mot de passe

je vais re-essayer sudo systemctl status apache2

ça me donne ça:

attention c'est énorme

● apache2.service - The Apache Webserver
Loaded: loaded (/usr/lib/systemd/system/apache2.service; disabled; vendor preset: disabled)
Active: active (running) since Wed 2021-08-04 13:55:26 CEST; 2min 3s ago
Main PID: 4063 (httpd-prefork)
Status: « Processing requests… »
Tasks: 6
CGroup: /system.slice/apache2.service
├─4063 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f>
├─4072 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f>
├─4073 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f>
├─4074 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f>
├─4075 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f>
└─4076 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f>

août 04 13:55:26 localhost.localdomain systemd[1]: Starting The Apache Webserver…
août 04 13:55:26 localhost.localdomain start_apache2[4063]: AH00557: httpd-prefork: apr_sockaddr_info_get() failed for localhost.localdomain
août 04 13:55:26 localhost.localdomain start_apache2[4063]: AH00558: httpd-prefork: Could not reliably determine the server’s fully qualified domain name, using 127.0.0.1. Set the 'ServerNam>
août 04 13:55:26 localhost.localdomain systemd[1]: Started The Apache Webserver.

j’essayer de connecter et ça me donne toujours l’erreur :

et quand je fais sudo journalctl -u apache2

ça donne ça:

Log

– Logs begin at Wed 2021-08-04 13:37:52 CEST, end at Wed 2021-08-04 14:03:01 CEST. –
août 04 13:55:26 localhost.localdomain systemd[1]: Starting The Apache Webserver…
août 04 13:55:26 localhost.localdomain start_apache2[4063]: AH00557: httpd-prefork: apr_sockaddr_info_get() failed for localh>
août 04 13:55:26 localhost.localdomain start_apache2[4063]: AH00558: httpd-prefork: Could not reliably determine the server’s>
août 04 13:55:26 localhost.localdomain systemd[1]: Started The Apache Webserver.

re-bonjour,
quand je fais http://mon_ip ça me met ça:

erreur

Le délai d’attente est dépassé

Le serveur à l’adresse 00.00.000.000(c’est pas lui) met trop de temps à répondre.

Le site est peut-être temporairement indisponible ou surchargé. Réessayez plus tard ;
Si vous n’arrivez à naviguer sur aucun site, vérifiez la connexion au réseau de votre ordinateur ;
Si votre ordinateur ou votre réseau est protégé par un pare-feu ou un proxy, assurez-vous que Firefox est autorisé à accéder au Web.

et quand je fais http://localhost il me mette ça:

2er erreur

Accès interdit!

Vous n’avez pas le droit d’accéder au répertoire demandé. Soit il n’y a pas de document index soit le répertoire est protégé.

Si vous pensez qu’il s’agit d’une erreur du serveur, veuillez contacter le webmestre.

Error 403

localhost
Apache

sur la 2er erreur il me mette que j’ai pas le droit de venir :thinking:

Bonjour,
bonne nouvelle je ne pouvais pas me connectez parce que j’avais pas mis la bonne adresse ip mais par contre il me mette cette erreur:

Résumé

Accès interdit!

Vous n’avez pas le droit d’accéder au répertoire demandé. Soit il n’y a pas de document index soit le répertoire est protégé.

Si vous pensez qu’il s’agit d’une erreur du serveur, veuillez contacter le webmestre.

Error 403

192.168.0.240
Apache

Ok, donc la 2ème erreur, elle montre bien que Apache est lancé et fonctionnel (accès refusé, ça peut être par exemple parce que le répertoire pointé par DocumentRoot est vide). C’est une erreur Apache, du coup tu auras les détails de cette erreur dans /var/log/apache2/error.log normalement (à adapter éventuellement, le chemin peut varier d’une distro Linux à l’autre, mais aussi en fonction de la conf Apache).

Le fait que tu n’y accèdes que via localhost et pas via l’IP, ça peut être parce que dans la conf Apache tu n’écoutes pas sur cette IP (par exemple écoute explicite sur 127.0.0.1, au lieu de l’IP LAN de la machine). Voir l’instruction Listen dans la conf Apache, qui doit être quelque part dans /etc/apache2/

bonjour,
maintenant j’arrive a me connecter en ip!
mais il reste le probleme 403

et quand je viens sur error.log il me mette Permission refusée

j’ai trouvé error.conf mais je pense pas que c’est ça

error.conf

Customizable error responses come in three flavors:

1) plain text 2) local redirects 3) external redirects

Some examples:

#ErrorDocument 500 « The server made a boo boo. »
#ErrorDocument 404 /missing.html
#ErrorDocument 404 « /cgi-bin/missing_handler.pl »
#ErrorDocument 402 http://www.example.com/subscription_info.html

Putting this all together, we can internationalize error responses.

We use Alias to redirect any /error/HTTP_.html.var response to

our collection of by-error message multi-language collections. We use

includes to substitute the appropriate text.

You can modify the messages’ appearance without changing any of the

default HTTP_.html.var files by adding the line:

Alias /error/include/ « /your/include/path/ »

which allows you to create your own set of files by starting with the

/usr/share/apache2/error/include/ files and copying them to /your/include/path/,

even on a per-VirtualHost basis. The default include files will display

your Apache version number and your ServerAdmin email address regardless

of the setting of ServerSignature.

The internationalized error documents require mod_alias, mod_include

and mod_negotiation. To activate them, uncomment the following 30 lines.

Alias /error/ « /usr/share/apache2/error/ »

AllowOverride None Options IncludesNoExec AddOutputFilter Includes html AddHandler type-map var Require all granted Order allow,deny Allow from all LanguagePriority en cs de es fr it ja ko nl pl pt-br ro sv tr ForceLanguagePriority Prefer Fallback
ErrorDocument 400 /error/HTTP_BAD_REQUEST.html.var
ErrorDocument 401 /error/HTTP_UNAUTHORIZED.html.var
ErrorDocument 403 /error/HTTP_FORBIDDEN.html.var
ErrorDocument 404 /error/HTTP_NOT_FOUND.html.var
ErrorDocument 405 /error/HTTP_METHOD_NOT_ALLOWED.html.var
ErrorDocument 408 /error/HTTP_REQUEST_TIME_OUT.html.var
ErrorDocument 410 /error/HTTP_GONE.html.var
ErrorDocument 411 /error/HTTP_LENGTH_REQUIRED.html.var
ErrorDocument 412 /error/HTTP_PRECONDITION_FAILED.html.var
ErrorDocument 413 /error/HTTP_REQUEST_ENTITY_TOO_LARGE.html.var
ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var
ErrorDocument 415 /error/HTTP_UNSUPPORTED_MEDIA_TYPE.html.var
ErrorDocument 500 /error/HTTP_INTERNAL_SERVER_ERROR.html.var
ErrorDocument 501 /error/HTTP_NOT_IMPLEMENTED.html.var
ErrorDocument 502 /error/HTTP_BAD_GATEWAY.html.var
ErrorDocument 503 /error/HTTP_SERVICE_UNAVAILABLE.html.var
ErrorDocument 506 /error/HTTP_VARIANT_ALSO_VARIES.html.var

je n’ai
pas trouvé error.log :sob:

bonjour problême réglé! :grinning: c’etait juste opensuse qui n’avait réussi a s’installer