Forum Clubic

Problème server DNS sur machine CentOS

Bonjour à tous !

Je viens d’installer une machine virtuelle CentOS sur un serveur Windows 2008 (hyper-v) pour y installer GLPI et OCS Inventory.
Après une longue matinée je suis enfin arrivé à y mettre ma carte réseau virtuelle et la configurer pour pouvoir accéder au réseau de l’entreprise et à internet !

les fichiers “ifcfg-eth0”, “network” et “resolv.conf” sont ok mais j’ai un problème avec le serveur DNS !!!
En effet dans le fichier “resolv.conf” après avoir mis l’adresse du serveur DNS de l’entreprise je fais un petit “ifup eth0” et le fichier “resolv.conf” devient :

" # Generated by NetworkManger
search MonDomaine
Nameserver 192.169.X.X"

Exactement l’adresse de mon serveur DNS et le nom du domaine.

Vous allez me dire que jusqu’à là tout vas bien mais impossible d’aller sur internet en tapant l’url (“adresse introuvable”), alors qu’avec l’ip ça marche niquel, je peux accéder aux sites. Donc j’en déduis qu’il y a bien un soucis avec le serveur DNS mais je ne vois pas du tout… J’ai essayé d’y mettre le DNS de google 8.8.8.8 et 8.8.4.4 mais exactement le même soucis…
Je pense que le problème vient de ma machine car le serveur DNS marche pour au moins pour une cinquantaine de poste et 5/6 serveurs sur Windows xp, 7, 2003 ou bien 2008…
Je peux pinguer mon serveur ou bien pinguer les autres pc du réseaux de mon serveur le seul problème vient du DNS.

J’espère que vous allez pouvoir m’aider…

Merci d’avance!

Cordialement,
Jordane

Tu utilises quoi, virtuel server ou VMware?
De toutes façon les deux refiltrent les flux…
Donc le problème ne se situerait pas sur ta machine virtuelle…

Bonjour,

à tout hasard, tu n’aurais pas un iptables ou alors un SE Linux d’activé ???

Tu sais que GLPI et OCS tournent sur un Windows server ? Tu peux t’aider de Xampp pour ça. Voici un lien qui peut t’être utile :

fr.wikipedia.org…

Ca pourrait t’éviter de t’ennuyer avec une machine virtuelle.

j’utilise VMware.
Non je n’ai pas d’iptable ni de SE linux d’activité.
CentOS est installé en virtuelle sur un serveur Windows 2008 avec 4 autres machines, je n’ai pas eu le choix du système d’exploitation, je suis seulement un petit étudiant en informatique qui fait son stage de fin d’année dans une entreprise ^^

juste pour tester, que donne un “iptables -L” ?

iptables -L
chain IMPUT (policy ACCEPT)
target        prot opt SOURCE               destination
ACCEPT    all -- anywhere                   anywhere               state related, estab
LISHED
ACCEPT    icmp -- anywhere                anywhere
ACCEPT    all -- anywhere                   anywhere
ACCEPT    tcp -- anywhere                  anywhere             state NEW tcp dpt : s
sh
REJECT     all -- anywhere                   anywhere             reject-with icmp-ho
st-prohibited

chain FORWARD (policy ACCEPT)
target       prot opt source                    destination
REJECT     all -- anywhere                   anywhere             reject-witch icmp-ho
st-prohibited

cahin OUTPUT (policy ACCEPT)
target      prot opt source                    destination

Si ça peut t’aider… Merci

ça marcheeeeeeeeeeeeeeeee :slight_smile:
Vous allez surement rire mais c’est seulement que j’ai tapé la mauvaise ip du DNS dans etc/sysconfig/network-scripts/ifcfg-eth0
Honte à moi et désolé du dérangement…

Merci !