Forum Clubic

Probleme redirection de ports, comportement étrange

Salut,

Voici mon problème:
J’ai une freebox V4 en mode routeur, un switch, des PC avec des baux DHCP permanents, et un serveur web apache avec debian.
Je redirige donc les ports vers mon serveur, je redémarre ma freebox, rien ne change! impossible d’acceder au site avec mon IP publique, mais ça marche avec mon IP privée.
Pour etre sur que la redirection marche, je redirige les ports emule sur mon autre PC, et la ca marche! (le passe de LowID a HighID)
J’ai essayé d’activer la DMZ sur le serveur, j’ai activé/desactivé le WOL, j’ai redirigé un autre port vers un autre pc avec apache lancé sur ce port… rien n’a marché.
de même avec FTP, SSH…

Rien a faire.

N’y aurais t’il pas d’autres choses a faire pour que le serveur soit visible de l’extérieur?

Merci de vos réponses
Edité le 12/01/2008 à 11:28

Salut,
Quand tu as mis l’Ip de ton serveur en DMZ cela fonctionne pas.?


met ton serveur en Ip statique qui rentre dans la plage DHCP

non ça n’a pas marché, je ne comprend pas…

je me suis dit que cela pouvais venir de mon serveur, j’ai mis dans hosts.allow “ALL: *” pour être tranquille. Mais ça ne change rien!

Tout mes PCs ont un bail DHCP permanent par adresse MAC
Edité le 13/01/2008 à 12:18

Bonjour montre nous ta config IP, la configuration de ton routeur…
Et la configuration de ton apache2.

Pour etre sur montre moi bien les port qui ecoute sur ton serveur…
netstat -anp | grep apache2

Personne ne pourra joindre ton serveur de l’exterieur s’il tente avec son ip (du serveur), poupoudoum !

Au pire on peut aller jusqu’à ta freebox, mais pas plus loin sans un outil du style noip, il me semble

Dis moi si je me trompe :wink:

Merci de vos reposes!

ma config freebox: alexlamoureux.free.fr…

la commande: netstat -anp | grep apache2
tcp6 0 0 :::80 :::* LISTEN 2268/apache2

la conf apache2 est celle par défaut (paquet apache2 sur debian)

pour ce qui est de l’ip que je cherchais a joindre c’était bien mon ip publique 81.56… et non 192.168.2…
je suis en IP statique

j’ai essayé de désactiver la fonction routeur de la freebox, en donnant l’ip de mon serveur a un copain il a pu voire mon site et acceder au ssh…

si je n’arrive pas a régler le problème, je vais sans doute faire de mon serveur un serveur-router (j’ai 2 cartes reseau)

je vais essayer avec noip voir si ça marche mieux…

en mode non routeur ca fonctionne ???

tente alors, dans le mode routeur, de rediriger la plage de ports 1 à 64000 en tcp et udp vers ton serveur (antivirus et firewall obligatoire) juste pour voir :wink:
Edité le 13/01/2008 à 18:55

j’ai fait la redirection brutale, regarde le lien alexlamoureux.free.fr…

comme mon serveur est sous linux… j’ai pas trop peur des virus!

je pense que je vais faire un routeur-serveur et desactiver la fonction routeur de ma freebox… mais ca vas pas etre facile

j’ai essayé avec NOIP, rien a faire ca ne marche pas

si ca marche quand ta freebox est en mode modem, c’est juste que tu ne redirige pas correctement des ports…
C’est quoi ce lien ?? alexlamoureux.free.fr
Edité le 13/01/2008 à 20:02

ce lien c’est mon site perso, j’ai mis le fichier html de ma configuration de freebox.

De quoi peut venir le dysfonctionnement de la redirection des ports?

ton serveur est en 192.168.2.20 ?

la redirection est faite, bien que je ne comprenne pas que tu ouvre tant de ports

En effet tout est censé marcher mais non…

Conclusion j’ai mis une deuxième carte réseau sur mon serveur, je vais en faire un routeur NAT en plus des serveurs…
C’est bien pour le coté apprentissage, mais c’est pas evident!

Je vous tiendrais au courant.

Bonsoir,

Je viens de regarder tes deux screenshots.

Ton ip DMZ est sur le même réseau que ton réseau local. Change l’adresse réseau de ta DMZ (met la par exemple sur le réseau 192.168.1). Le principe d’une DMZ est d’être une zone démilitarisée, donc qu’elle soit seule dans son coin, ne travaillant pas avec le réseau local. C’est un isolement. Elle ne doit donc pas être sur le même réseau. Tu peux par contre conserver le même masque. Je ne suis même pas sûr que la freebox accepte ce paramètre.

Ensuite, si ça ne fonctionne toujours pas, merci de nous montrer tes logs apaches, le résultât de la commande netstat.

Et fait une redirection unique de port, pas un lot d’adresses, histoire de faire un peu plus propre et ce n’est pas ça qui pose problème.

EDIT : question supplémentaire : pourquoi mettre ton serveur web en DMZ ? Si il est en DMZ, il va te falloir un équipement particulier pour pouvoir accéder à ton serveur depuis une machine tiers et créer un pont entre les deux réseaux. Comme je l’expliquai, un DMZ est une zone inaccessbile depuis le réseau local. Donc deux solutions :

  • Tu le laisses en DMZ : il va soit falloir créer un pont entre les deux réseaux (local et DMZ) soit brancher une deuxième interface réseau sur ton serveur et la machine sensée administrer le serveur web. On perd donc ici tout bénéfice de la DMZ, donc inutile de faire une DMZ.
  • Tu le retires de la DMZ, ce qui à mon sens est la meilleur option pour toi si tu n’as pas les équipements nécessaires (routeur supplémentaire) et/ou si tu n’as pas les connaissances nécessaires pour mettre en place une zone démilitarisée.

En bref, vire la DMZ sauf si tu veux apprendre à en manipuler une. Attention toutefois à mettre en place la sécurité qui s’impose à ce type d’utilisation.

Information supplémentaire : on ne distribue pas d’adresse via DHCP sur une DMZ, c’est un des premiers principes de sécurité pour cet objet. Donc passe ton serveur Debian en IP fixe si tu choisis cette solution (en plus, ça ne devrait pas fonctionner avec la freebox – clairement en ce moment ta freebox alloue l’adresse machine 20 à ton serveur debian mais il n’est en aucun cas en DMZ). Exemple de configuration :

  • IP réseau local : 192.168.2
  • DHCP sur réseau local
  • IP DMZ : 192.168.1 (donc ici l’adresse à renseigner dans ta freebox sera 192.168.1.20 car je suppose que tu n’auras pas de routeur entre la freebox et la DMZ – normalment l’adresse à rentrer est l’adresse d’un routeur qui sera lui le point d’entrée de ta DMZ et qui “routera” lui-même les paquets au bon destinataire. Pas de routeur donc on cause directement avec ta machine Debian – Enorme trou de sécurité en fait ;))
  • IP Debian : 192.168.1.20
  • Redirection du port 80 sur la machine 192.168.1.20 (donc en DMZ)
  • Mise en place d’un pont réseau en les réseaux 192.168.2 (réseau local) et 192.168.1 (DMZ) ou installation d’une interface réseau supplémentaire sur le serveur Debian et sur un poste du réseau local. Ces deux interfaces devront être en IP fixe et sur un nouveau réseau différent pour des raisons de sécurité (192.168.3 par exemple).

PS : vire moi cette DMZ ! :stuck_out_tongue:

EDIT 2 : Configuration conseillée, recommandée (qu’il faut faire en fait) :

  • IP réseau local : 192.168.2.
  • IP sur réseau local en DHCP.
  • Bail DHCP fixe ou adresse ip fixe pour la Debian.
  • redirection de port 80 sur l’adresse de la Debian.
  • Suppression de la DMZ
  • Enjoy.

Piqure de rappel : la zone en DMZ ne profitera pas de la protection que t’offre la freebox en mode routeur sur ton réseau local.

Piqure de rappel 2 : vire moi cette DMZ :wink:

Bon courage.

AtY
Edité le 17/01/2008 à 10:00