Forum Clubic

Probleme passerelle Linux

Bonsoir,
Je vous soumet un schéma de mon réseau.

http://img172.imageshack.us/img172/9568/sanstitrevz8.jpg

Alors j’essai d’accéder à Internet à partir du réseau 192.168.49.0 mais je n’y arrive pas

Le poste fesant office de passerelle est un poste sous Fedora 8, possédant donc 2 cartes réseaux :

  • Une vers le routeur : ip 192.168.1.2
    masque 255.255.255.0
    passerelle par défaut 192.168.1.1
    dns primaire 194.117.200.10
    dns secondaire 194.117.200.15
  • Une vers le réseau 49.0 : ip 192.168.49.254
    masque 255.255.255.0

Les postes du réseau 192.168.49.0 sont configurés de la manière suivante :
ip 192.168.49.xx
masque 255.255.255.0
passerelle par défaut 192.168.49.254
dns primaire 194.117.200.10
dns secondaire 194.117.200.15

A partir des postes du réseau 192.168.49.0 je peux faire un ping sur les 2 interfaces de la passerelle (192.168.49.254 et 192.168.1.2) mais pas sur le routeur 192.168.1.1 (“Délai d’attente de la demande dépassé”).
Pourtant à partir du poste jouant le rôle de passerelle je peux faire un ping vers les postes du réseau 192.168.49.0 ET vers l’interface192.168.1.1.
Je précise que le service routage est actif sur la passerelle sinon je ne pourrais pas ping l’interface 192.168.1.2 à partir du réseau 192.168.49.0.

Bref je ne comprends vraiment pas, j’ai du sauter une étape ou simplement oublier un détail, après tout je ne suis pas administrateur réseau. :stuck_out_tongue: Si quelqu’un voit où se situe le problème qu’il parle maintenant ou se taise à jamais ! (mais plutôt qu’il parle :D)

Merci à vous.
Bonne soirée.
Edité le 30/12/2007 à 10:21

Bonjour,
J’ai essayé de mettre la règle suivante au niveau de la box :

Destination Masque Passerelle Interface
192.168.49.0 255.255.255.0 192.168.1.1 192.168.1.2

Cependant mon problème est le même, peut être que ma box ne l’a pas pris en compte ou peut etre que le problème ne vient pas de là, mais en principe lorsque l’on effectue une requete ping, s’il y a en réponse “Délai d’attente de la demande dépassé”, c’est que la requête passe mais que la réponse ne passe pas non ?

Salut,
peut être qu’il manque a faire une route manuelle sur les 2 pc’s vers le reseau 192.168.1.0.

Je ne pense pas que ce soit la route, vu que je peux effectuer un ping sur l’interface 192.168.1.2, je peux donc atteindre ce réseau 192.168.1.0
Mais peut être qu’il manque en effet une route sur le routeur.

Vu qu’il ya un double NAT, ça peut être un problème de retour de trames. Ton réseau 49 connais le réseau 1 mais l’inverse n’est pas forcément vrais.
La solution idéal pour palier à ça étant de pouvoir rajouter une route static à ton routeur Club internet box …

Alors une petite route de la box.; à tenter tient nous au jus.

En effet c’est ce que j’avais compris et ce que j’avais fait mais je me suis rendu compte que ma route était fausse il y a 5minutes :@
Ce n’est pas : 192.168.49.0 255.255.255.0 192.168.1.1 192.168.1.2
mais : 192.168.49.0 255.255.255.0 192.168.1.2 192.168.1.1 !

Il me semble que cette route semble plus correcte :smiley: j’avais inverser la passerelle et l’interface …
Comme quoi même avec un schéma assez clair, avec ces chiffres partout on s’y perd !

Je vais donc essayer ca.

héhé … Après modif de cette fameuse ligne … :love:

Ca ne fonctionne toujours pas :op
Et moi qui pensais que ce serait simple…
Je commence à accuser cette fichue clubinternet box de m’empecher de faire mon petit réseau :frowning:

Tu arrives a pinguer ton routeur depuis les PC’s?
oupsss j’ai vu que non…!
normalement une route est fait pour atteindre un reseau différent a celui qu’on appartient… sur ta box tu n’as pas un option pour ne pas répondre au ping.?
Edité le 29/12/2007 à 15:39

Bon ca y est j’arrive a faire un ping sur le 192.168.1.1 :slight_smile:

Et j’ai fais quoi ? bah j’ai changé de port sur le switch … En me disant sait on jamais :ane: Bref pourquoi le switch m’a-t-il fait ce coup ? Aucune idée, les mystère de l’informatique … (bien sur j’ai testé tous les autres ports et il y a qu’avec celui que j’utilisais avant que le ping n’a pas de retour …)

Bon déja un gros progrès. Bon par contre maintenant le plus dur reste à faire parce que je n’ai pas accès au net.
Ce n’est pas un problème de DNS car je ne peux pas effectuer un ping sur l’ip d’un site. Donc je vais re-re-re-voir toutes ces ip ainsi que cette zoulie passerelle et ce beau routeur tranquillement. :slight_smile:

Bien que j’en ai un peu marre :smiley:

Voila problème résolu.

1 - Activer l’ipforward :
echo 1 > /proc/sys/net/ipv4/ip_forward

2 - Créer une route statique au niveau de la box :
192.168.49.0 255.255.255.0 192.168.1.2 192.168.1.1

3 - Mettre du nat au niveau du poste Linux
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
Avec bien sur eth0 etant l’interface connectée à la box.

Merci à tous. :slight_smile:

Cool t’as résolu ton problème…
Bon a savoir tout ca…:wink:

Maintenant on va faire en sorte que ce joli poste, avec ce beau fedora, serve de proxy avec squid :wink:

ha ce que je vois on se planque… héhé :wink:

non on travaille :smiley:

oui je m’en doute…
Au niveau 3, nat linux ca sert quoi cette commande (masquerade…)?

MASQUERADE fonctionne sur le même principe que SNAT (utilisé pour changer l’adresse source des paquets (adresse privé du réseau en adresse du firewall donc publique), et permettre ainsi une réponse du réseau publique vers le privé) sauf que celle ci vérifie l’adresse IP à utiliser. MASQUERADE permet de faire fonctionner un systeme d’adressage IP dynamique sous DHCP étant donné qu’elle vérifie l’adresse alors que SNAT utilise seulement l’adresse IP configurée.

Difficile d’être clair désolé :smiley:
Edité le 30/12/2007 à 23:34

Merci de ta réponse mais effectivement pas evident a comprendre… Je pense y être arriver quand même…!
:wink: