Forum Clubic

Problème packages Windows Installer - XP Pro SP2

Bonjour,

Après de nombreuses recherches sur les forums et diverses méthodes pour venir à bout de mon problème, je désespère de trouver une solution.

Voilà : Depuis quelques temps, l’installation de nombreux programmes est devenue impossible. Apparament, il s’agit des programmes contenus dans les packages MSI pour Windows Installer (c’est la cas pour Quicktime, certains plugins pour 3ds Max, ou autre Outlook Connector).

Les messages d’erreur rencontrés jusqu’alors selon les cas sont :

  • “Impossible d’ouvrir le package d’installation. Contactez le revendeur de l’application pour vérifier qu’il s’agit d’un package Windows Installer valide.”
  • “Erreur lors de l’ouverture de fichier journal d’installation. Vérifiez que l’emplacement du fichier journal spécifié existe et qu’il n’est pas en lecture seule.”

J’ai tenté les solutions suivantes :

  • désinstallation complète des versions antérieures des programmes à installer
  • nettoyage avec l’utilitaire Windows Installer CleanUp
  • désactivation des pare-feu Windows et Kaspersky pendant l’installation
  • Réinstallation de la mise à jour Windows Installer 3.1 (KB893803)
  • Réparation de Windows XP avec CD d’origine

Mais rien n’y fait.

Ma configuration :
PC Intel Core 2 Quad Q6600 @ 2.4 GHz
RAM 3,25 Go
DD partition système/données 100Go/400Go
DD travail Raptor 150Go
Windows XP Pro SP2
Je suis l’utilisateur unique (donc l’administrateur?) du système.

Voilà, je vous appelle à l’aide, cette situation me pénalise professionnellement et je ne sais plus quoi faire…
Merci d’avance!

Bonjour,

Une suggestion bateau, mais comme tu n’en parles pas dans ton exposé : as-tu fait tout le nécessaire pour vérifier qu’il n’y aurait pas une petite infection là-derrière ?

Sinon est-ce que tu as les MAJ automatiques activées (une MAJ manuelle particulière a pu créer une incohérence dans le système) ?

Enfin dernière idée : peut-être qu’une installation du SP3 remettrait tout ça en ordre…

Bon courage.

Salut

Met a jour ton windows via microsoft update la derniére version de Windows Installer n’est 3.1 mais 4.5 :wink: )

Sinon sa peut être une infection comme de la dit decalcomanie
Edité le 30/09/2008 à 10:32

Merci beaucoup pour votre rapidité.

J’ai mis à jour Windows Installer avec la version 4.5… toujours le même problème (testé avec les 3 applications citées).
Au moment où je vous écrivais, une analyse complète par Kaspersky + Spybot était en train de tourner… aucune infection détectée.

Faut-il que j’installe SP3? C’est bien la seule mise à jour que Windows Update me recommande. Je suis toujours un peu frileux à l’idée de bouleverser un système qui marchait jusqu’à présent… (en l’occurence il ne marche pas si bien que ça, je vous l’accorde).

Sinon, d’autres idées?

Si ton Windows complètement à jour (SP3 compris donc) manifeste toujours les mêmes symptômes, et à moins de pouvoir faire intervenir un expert sur site, ça risque fort de se terminer en ré-installation complète du système ton affaire. Je ne te le souhaite pas, mais il vaut parfois mieux prendre 1 ou 2 jours pour tout refaire à neuf plutôt que d’être em…dé pendant des semaines ou des mois par un bug casse-bonbon.

Bon courage en tout cas.
Edité le 30/09/2008 à 13:30

Bonne nouvelle, j’ai trouvé ce qui coinçait…

Au lieu de double-cliquer sur les packages “setup.exe”, j’ai fait clic droit > “executer en tant que”, puis “administrateur”, et là l’installation a fonctionné sans problème.
J’avoue ne pas être un expert de Windows, mais ce n’était pas très clair! Lorque je vais dans la gestion des comptes utilisateurs du panneau de configuration, le compte portant mon nom est annoncé comme “compte administateur”. Or, dans certains cas il apparait comme “compte utilisateur”, et je dois préciser que je veux l’utiliser en tant qu’administrateur…
Tout ça pour ça! Il faut que j’apprenne à parler la langue…

Merci de votre aide, en tous cas!

salut a tous ayant installer le sp2 pour xp pro je n ai pu plus brancher mon media center donc desinstallation du sp2 et oh sur prise aux redemarrage du pc je suis sur la page windows et redemarrage je ne peux pas redemarrer en mode sans echec ni sur les trois autre aux secours comment puis je faire merci par avance de votre aide