Forum Clubic

Problème OpenGL avec Quake IV - Comment le résoudre?!

Je viens à l’instant de me payer Quake IV, je l’installe avec Direct X 9.0, aucun problème. Mais quand je lance le jeu, ça devient noir et ça revient au bureau avec une fenêtre nommée “Unable to initialize OpenGL”. Voici le rapport de la fenêtre:

"Winsock Initialized
Found interface: {722CF6B1-05F6-41ED-8461-F5D7C8DD3B50} 802.11g USB 2.0 adapter - Miniport d’ordonnancement de paquets - 192.168.1.159/255.255.255.0
Found interface: {5F294C77-42A2-489F-A73F-2C921D5019DB} Realtek RTL8139/810x Family Fast Ethernet NIC - Miniport d’ordonnancement de paquets - 0.0.0.0 NULL netmask - skipped
Sys_InitNetworking: adding loopback interface
engine using MMX & SSE & SSE2 for SIMD processing
enabled Flush-To-Zero mode
enabled Denormals-Are-Zero mode
--------- Initializing File System ----------
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/game000.pk4 with checksum 0x9321cee4
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak001.pk4 with checksum 0xf2cbc998
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak002.pk4 with checksum 0x7f8d80d1
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak003.pk4 with checksum 0x1b57b207
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak004.pk4 with checksum 0x385aa578
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak005.pk4 with checksum 0x60d50a1d
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak006.pk4 with checksum 0x9099ed11
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak007.pk4 with checksum 0xaf301fff
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak008.pk4 with checksum 0x4ac6f6d9
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak009.pk4 with checksum 0x36030c7d
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak010.pk4 with checksum 0x4b80fbda
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak011.pk4 with checksum 0x8acf4cfa
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak012.pk4 with checksum 0xbe4120b0
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/zpak_french.pk4 with checksum 0xbec7cb4
Current search path:
C:/Program Files/id Software/Quake 4/q4base
C:/Program Files/id Software/Quake 4/q4base/zpak_french.pk4 (3462 files)
C:/Program Files/id Software/Quake 4/q4base/pak012.pk4 (1081 files)
C:/Program Files/id Software/Quake 4/q4base/pak011.pk4 (5620 files)
C:/Program Files/id Software/Quake 4/q4base/pak010.pk4 (5539 files)
C:/Program Files/id Software/Quake 4/q4base/pak009.pk4 (1284 files)
C:/Program Files/id Software/Quake 4/q4base/pak008.pk4 (1289 files)
C:/Program Files/id Software/Quake 4/q4base/pak007.pk4 (1330 files)
C:/Program Files/id Software/Quake 4/q4base/pak006.pk4 (1343 files)
C:/Program Files/id Software/Quake 4/q4base/pak005.pk4 (1395 files)
C:/Program Files/id Software/Quake 4/q4base/pak004.pk4 (2249 files)
C:/Program Files/id Software/Quake 4/q4base/pak003.pk4 (1281 files)
C:/Program Files/id Software/Quake 4/q4base/pak002.pk4 (313 files)
C:/Program Files/id Software/Quake 4/q4base/pak001.pk4 (5837 files)
C:/Program Files/id Software/Quake 4/q4base/game000.pk4 (2 files)
game DLL: 0x0 in pak: 0x0
Addon pk4s:
file system initialized.

------------ Initializing Decls -------------
Loading guides… 59 loaded
514ms to load 1071k of material
108ms to load 43k of skin
281ms to load 716k of sound
5ms to load 1k of materialType
555ms to load 2078k of lipSync
152ms to load 105k of playback
2245ms to load 1665k of effect

-------- Initializing renderSystem ----------
using ARB renderSystem
renderSystem initialized.

Found default language English with VO
… found additional language ‘french’ with VO
632 strings read from strings/french_code.lang
1654 strings read from strings/french_guis.lang
5616 strings read from strings/french_lips.lang
6085 strings read from strings/french_maps.lang
Couldn’t open journal files
execing default.cfg
“” isn’t a valid key
“ALT” isn’t a valid key
“CTRL” isn’t a valid key
couldn’t exec editor.cfg
couldn’t exec Quake4Config.cfg
execing autoexec.cfg
-------- Initializing Sound System ----------
sound system initialized.

--------------- R_InitOpenGL ----------------
Initializing OpenGL subsystem
…registered window class
…registered fake window class
…initializing QGL
…calling LoadLibrary( ‘opengl32’ ): succeeded
Couldn’t find proc address for: wglGetExtensionsStringARB
Couldn’t find proc address for: wglSwapIntervalEXT
Couldn’t find proc address for: wglGetPixelFormatAttribivARB
Couldn’t find proc address for: wglGetPixelFormatAttribfvARB
Couldn’t find proc address for: wglChoosePixelFormatARB
Couldn’t find proc address for: wglCreatePbufferARB
Couldn’t find proc address for: wglGetPbufferDCARB
Couldn’t find proc address for: wglReleasePbufferDCARB
Couldn’t find proc address for: wglDestroyPbufferARB
Couldn’t find proc address for: wglQueryPbufferARB
Couldn’t find proc address for: wglBindTexImageARB
Couldn’t find proc address for: wglReleaseTexImageARB
Couldn’t find proc address for: wglSetPbufferAttribARB
…calling CDS: ok
…created window @ 0,0 (640x480)
Initializing OpenGL driver
…getting DC: succeeded
…PIXELFORMAT 8 selected
…creating GL context: failed
Shutting down OpenGL subsystem
…wglMakeCurrent( NULL, NULL ): failed
…releasing DC: success
…resetting display
…shutting down QGL
…unloading OpenGL DLL
Initializing OpenGL subsystem
…initializing QGL
…calling LoadLibrary( ‘opengl32’ ): succeeded
Couldn’t find proc address for: wglGetExtensionsStringARB
Couldn’t find proc address for: wglSwapIntervalEXT
Couldn’t find proc address for: wglGetPixelFormatAttribivARB
Couldn’t find proc address for: wglGetPixelFormatAttribfvARB
Couldn’t find proc address for: wglChoosePixelFormatARB
Couldn’t find proc address for: wglCreatePbufferARB
Couldn’t find proc address for: wglGetPbufferDCARB
Couldn’t find proc address for: wglReleasePbufferDCARB
Couldn’t find proc address for: wglDestroyPbufferARB
Couldn’t find proc address for: wglQueryPbufferARB
Couldn’t find proc address for: wglBindTexImageARB
Couldn’t find proc address for: wglReleaseTexImageARB
Couldn’t find proc address for: wglSetPbufferAttribARB
…calling CDS: ok
…created window @ 0,0 (640x480)
Initializing OpenGL driver
…getting DC: succeeded
…PIXELFORMAT 8 selected
…creating GL context: failed
Shutting down OpenGL subsystem
…wglMakeCurrent( NULL, NULL ): failed"

Voilà donc aidez-moi svp! J’ai le même problème avec Wolfenstein: ET! Merci d’avance…

Tu as quoi comme carte graphique ? Pilote ? Tu as changé de carte graphique récemment ?

Mon ordi date de septembre dernier, carte graphique d’origine. Tous les TM passent, ainsi que les Sims 2, Fire Departement, SRS, The Movies…
Apparemment, ma carte graphique est une “VIA/S3G UniChrome Pro IGP”

Si c’est pas ça dis le moi :wink:
Et merci de te pencher sur mon pb :jap:

J’ai trouvé ça:
http://www.infos-du-net.com/forum/70515-6-…g-unichrome-igp

A mon avis,ta carte graphique ne gère pas l’Opengl. :neutre: C’est louche.

Merci pour le lien :jap: . J’installe la mise à jour et je te tiens au courant.

Bon ça tiens à peine plus longtemps au lancement mais tjrs retour au bureau cette fois-ci avec ce rapport:

"Winsock Initialized
Found interface: {722CF6B1-05F6-41ED-8461-F5D7C8DD3B50} 802.11g USB 2.0 adapter - Miniport d’ordonnancement de paquets - 192.168.1.159/255.255.255.0
Found interface: {5F294C77-42A2-489F-A73F-2C921D5019DB} Realtek RTL8139/810x Family Fast Ethernet NIC - Miniport d’ordonnancement de paquets - 0.0.0.0 NULL netmask - skipped
Sys_InitNetworking: adding loopback interface
engine using MMX & SSE & SSE2 for SIMD processing
enabled Flush-To-Zero mode
enabled Denormals-Are-Zero mode
--------- Initializing File System ----------
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/game000.pk4 with checksum 0x9321cee4
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak001.pk4 with checksum 0xf2cbc998
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak002.pk4 with checksum 0x7f8d80d1
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak003.pk4 with checksum 0x1b57b207
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak004.pk4 with checksum 0x385aa578
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak005.pk4 with checksum 0x60d50a1d
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak006.pk4 with checksum 0x9099ed11
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak007.pk4 with checksum 0xaf301fff
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak008.pk4 with checksum 0x4ac6f6d9
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak009.pk4 with checksum 0x36030c7d
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak010.pk4 with checksum 0x4b80fbda
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak011.pk4 with checksum 0x8acf4cfa
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/pak012.pk4 with checksum 0xbe4120b0
Loaded pk4 C:/Program Files/id Software/Quake 4/q4base/zpak_french.pk4 with checksum 0xbec7cb4
Current search path:
C:/Program Files/id Software/Quake 4/q4base
C:/Program Files/id Software/Quake 4/q4base/zpak_french.pk4 (3462 files)
C:/Program Files/id Software/Quake 4/q4base/pak012.pk4 (1081 files)
C:/Program Files/id Software/Quake 4/q4base/pak011.pk4 (5620 files)
C:/Program Files/id Software/Quake 4/q4base/pak010.pk4 (5539 files)
C:/Program Files/id Software/Quake 4/q4base/pak009.pk4 (1284 files)
C:/Program Files/id Software/Quake 4/q4base/pak008.pk4 (1289 files)
C:/Program Files/id Software/Quake 4/q4base/pak007.pk4 (1330 files)
C:/Program Files/id Software/Quake 4/q4base/pak006.pk4 (1343 files)
C:/Program Files/id Software/Quake 4/q4base/pak005.pk4 (1395 files)
C:/Program Files/id Software/Quake 4/q4base/pak004.pk4 (2249 files)
C:/Program Files/id Software/Quake 4/q4base/pak003.pk4 (1281 files)
C:/Program Files/id Software/Quake 4/q4base/pak002.pk4 (313 files)
C:/Program Files/id Software/Quake 4/q4base/pak001.pk4 (5837 files)
C:/Program Files/id Software/Quake 4/q4base/game000.pk4 (2 files)
game DLL: 0x0 in pak: 0x0
Addon pk4s:
file system initialized.

------------ Initializing Decls -------------
Loading guides… 59 loaded
544ms to load 1071k of material
117ms to load 43k of skin
266ms to load 716k of sound
6ms to load 1k of materialType
516ms to load 2078k of lipSync
113ms to load 105k of playback
2118ms to load 1665k of effect

-------- Initializing renderSystem ----------
using ARB renderSystem
renderSystem initialized.

Found default language English with VO
… found additional language ‘french’ with VO
632 strings read from strings/french_code.lang
1654 strings read from strings/french_guis.lang
5616 strings read from strings/french_lips.lang
6085 strings read from strings/french_maps.lang
Couldn’t open journal files
execing default.cfg
“” isn’t a valid key
“ALT” isn’t a valid key
“CTRL” isn’t a valid key
couldn’t exec editor.cfg
execing Quake4Config.cfg
execing autoexec.cfg
-------- Initializing Sound System ----------
sound system initialized.

--------------- R_InitOpenGL ----------------
Initializing OpenGL subsystem
…registered window class
…registered fake window class
…initializing QGL
…calling LoadLibrary( ‘opengl32’ ): succeeded
Couldn’t find proc address for: wglGetExtensionsStringARB
Couldn’t find proc address for: wglSwapIntervalEXT
Couldn’t find proc address for: wglGetPixelFormatAttribivARB
Couldn’t find proc address for: wglGetPixelFormatAttribfvARB
Couldn’t find proc address for: wglChoosePixelFormatARB
Couldn’t find proc address for: wglCreatePbufferARB
Couldn’t find proc address for: wglGetPbufferDCARB
Couldn’t find proc address for: wglReleasePbufferDCARB
Couldn’t find proc address for: wglDestroyPbufferARB
Couldn’t find proc address for: wglQueryPbufferARB
Couldn’t find proc address for: wglBindTexImageARB
Couldn’t find proc address for: wglReleaseTexImageARB
Couldn’t find proc address for: wglSetPbufferAttribARB
…calling CDS: ok
…created window @ 0,0 (640x480)
Initializing OpenGL driver
…getting DC: succeeded
…PIXELFORMAT 8 selected
…creating GL context: succeeded
…making context current: succeeded
Couldn’t find proc address for: wglGetExtensionsStringARB
Couldn’t find proc address for: wglSwapIntervalEXT
Couldn’t find proc address for: wglGetPixelFormatAttribivARB
Couldn’t find proc address for: wglGetPixelFormatAttribfvARB
Couldn’t find proc address for: wglChoosePixelFormatARB
Couldn’t find proc address for: wglCreatePbufferARB
Couldn’t find proc address for: wglGetPbufferDCARB
Couldn’t find proc address for: wglReleasePbufferDCARB
Couldn’t find proc address for: wglDestroyPbufferARB
Couldn’t find proc address for: wglQueryPbufferARB
Couldn’t find proc address for: wglBindTexImageARB
Couldn’t find proc address for: wglReleaseTexImageARB
Couldn’t find proc address for: wglSetPbufferAttribARB

------------ Input Initialization -----------
Initializing DirectInput…
mouse: DirectInput initialized.
keyboard: DirectInput initialized.

…initializing QAL
…calling LoadLibrary( ‘OpenAL32.dll’ ): failed
sound: STEREO
…using GL_ARB_multitexture
…using GL_ARB_texture_env_combine
X…GL_ARB_texture_cube_map not found
…using GL_ARB_texture_env_dot3
…using GL_ARB_texture_env_add
X…GL_ARB_texture_non_power_of_two not found
X…GL_NV_blend_square not found
…using GL_ARB_texture_compression
…using GL_EXT_texture_compression_s3tc
X…GL_EXT_texture_filter_anisotropic not found
…using GL_EXT_texture_lod
…using GL_1.4_texture_lod_bias
X…GL_EXT_shared_texture_palette not found
…using GL_EXT_draw_range_elements
…using GL_EXT_blend_minmax
X…GL_NV_float_buffer not found
X…GL_EXT_texture3D not found
…using GL_EXT_stencil_wrap
X…GL_NV_register_combiners not found
X…NV_vertex_program not found
X…GL_EXT_stencil_two_side not found
X…GL_ATI_separate_stencil not found
X…GL_ATI_fragment_shader not found
X…GL_ATI_text_fragment_shader not found
X…GL_ARB_vertex_buffer_object not found
X…GL_ARB_vertex_program not found
X…GL_ARB_fragment_program not found
X…GL_ARB_shader_objects not found


ERROR: L’association carte graphique/pilote actuelle ne prend pas en charge les fonctionnalités requises.


Error during initialization
Shutting down OpenGL subsystem"

Continuez à m’aider svp :jap:

1-Télécharge Everest de Lavalys ou Sandrasisoft
Tu connaitras le pedigré de ta carte et ,normalement,le logiciel te donnera un lien vers les pilotes.

Personnelement,je ne peux rien faire de plus.Comme je l’ai dit plus haut,ta carte graphique semble très capricieuse avec OpenGl mais fonctionne avec Direct X.Donc,il y a pas 36000 solutions.Soit tu trouves un pilote potable,soit tu changes de carte graphique soit tu laisses tomber les jeux Opengl genre Doom,Quake…

C’est une carte graphique intégrée à la carte mère, vu le rapport elle ne supporte pas l’openGl, mais de toute manière même si elle le supportait elle ne serait certainement pas assez puissante :confused:

C’est plutôt une carte dédiée à l’usage bureautique et familial, pas aux jeux de dernière génération. Cela dit même une carte bas de gamme est très bien pour l’usage que j’imagine que tu en fais et pour un prix très raisonnable (on en trouve à moins de 100€, moins cher que deux jeux :))