Forum Clubic

Problème Ndiswrapper sur Mandrake LE 2005

Hello tous, comme je l’avais énoncé dans le sujet: Mandrake LE 2005 dans les bacs, je viens d’installer sur mon portable HP ZD7045EA, une mandrake LE 2005, j’ai un BROADCOM BCM94306 comme chip wireless 54G, je suis donc obligé de passer par ndiswrapper pour installer un driver windows, normalement mandrake le fait automatiquement à partir du centre de configuration mandrake (il demande si on veux installer ndiswrapper car la carte détectée n’est pas supportée et il demande ensuite le chemin du driver…) bref, une fois tout ceci fait, au redémarrage, il semble que mandrake lance une interface Wlan0, mais elle le témoin sur le portable ne s’allume pas, je fais un modprobe ndiswrapper, et la (module not found) et lorsque je fait un iwconfig, il ne trouve pas non plus l’interface wlan0 j’ai rajouté ndiswrapper dans /etc/modules et /etc/modprobe.preload j’ai également mis alias wlan0 ndiswrapper dans /etc/modprobe.conf mais j’ai toujours ‘module not found’ et pas de wlan0 lors d’un iwconfig… comment dirais-je… HELP !!

essaye de refaire la procedure a la main
place toi dans le repertoire ou est le .inf des driver windows et fait
$ndiswrapper tonfichier.inf
$modprobe ndiswrapper
$dhcpcd wan0

sinon tu peux essayer avec le driver suggeré sur le site de ndiswrapper qui n’est pas forcement le driver de ta carte.

Bon ca yet c’est bon, voila comment j’ai fait:
j’ai viré les RPM inclu dans Mandrake,
J’ai supprimé la connection wlan0 que Mandrake avait créé à l’aide du centre de configuration
Installation de Ndiswrapper avec les sources,
Ajout de alias wlan0 ndiswrapper dans modprobe.conf
ajout de ndiswrapper dans modprobe.preload
ajout de ndiswrapper dans modules.conf [EDIT] modules et pas modules.conf !! [/EDIT]
redémarrage
configuration de la carte BCM94306 wlan0 à l’aide du centre de controle mandrake -> matériel -> configuration du matériel

Voilà ca marche sans aucun soucis maintenant !!! il ne reste plus pour moi qu’a configurer les boutons de volume, média … ca j’ai déja trouvé un tuto sous debian et slack sur linux on laptop, je vais m’en inspirer :wink: merci de votre aide :wink:

J’ai tout réinstallé propre nickel sans windows, j’ai réitéré la procédure ci-dessus -> ca marche a nouveau sans soucis -> /me! APPROVED :stuck_out_tongue:
@+

donc en fait le pb c le centre de conf de mandrake.
ça ne va pas me réconcilier avec la configuration par interface graphique.

Apparement le problème viens du fait que les paquetages livrés avec mandrake ne s’installent pas comme il faut, en installant avec les sources puis en configurant manuellement avec l’interface de mandrake… la ca marche ! je ne saurais expliquer pourquoi, mais en tout cas meme en intallant et en configurant le tout avec une console c’est vraiment pas compliqué (meme moi j’y arrive ! alors :p)
L’interface de mandrake (mandriva oups) est quand meme un bon outil, pour l’instant je n’ai remarqué que ce disfonctionnement au niveau du réseau sanss fil.