Forum Clubic

Problème installation joomla 1.6 ubuntu

Bonjour, j’ai un souci pour installer Joomla, enfaîte se qui se passe quand je me connecte, il me télécharge la page index.php au lieu de me demander la langue
et autre pour terminer l’installation. J’ai tester avec Firefox et Chromium même résultat. Merci d’avance pour vos réponses.
Edité le 27/03/2011 à 22:21

Hum, tu as installé PHP sur ton ubuntu ?

oui j’ai installer un lamp comme d’écrie sur le site de Ubuntu

En ce cas, il doit te manquer la partie qui dis à Apache de laisser mod_php gérer les *.php.

J’ai bien ubuntu mais pas encore installé Apache (je le compile, suis plus bourrin ;)) mais tu dois en gros trouver ça (ça fonctionnait sous Windows, mais y a pas de raisons que ça déconne sous ubuntu) :

Pour le chargement :

LoadModule php5_module "C:/Program Files (x86)/PHP/php5apache2_2.dll"

Pour la configuration :

PHPIniDir "E:/www/conf/php5.3"
AddHandler application/x-httpd-php .php

Vérifie dans /etc/apache2/ que tu ai un fichier php5.load & php5.conf dans mods-available, et que tu ai bien un lien symbolique vers ces deux fichiers dans mods-enabled.

Faire un ls (ls -lisAh --color=auto pour être plus précis) du dossier devrait te retourner ça :

664924 0 lrwxrwxrwx 1 root root 28 2011-03-27 19:43 alias.conf -> ../mods-available/alias.conf
664925 0 lrwxrwxrwx 1 root root 28 2011-03-27 19:43 alias.load -> ../mods-available/alias.load
671276 0 lrwxrwxrwx 1 root root 33 2011-03-27 19:43 auth_basic.load -> ../mods-available/auth_basic.load
671282 0 lrwxrwxrwx 1 root root 33 2011-03-27 19:43 authn_file.load -> ../mods-available/authn_file.load
671279 0 lrwxrwxrwx 1 root root 36 2011-03-27 19:43 authz_default.load -> ../mods-available/authz_default.load
671281 0 lrwxrwxrwx 1 root root 38 2011-03-27 19:43 authz_groupfile.load -> ../mods-available/authz_groupfile.load
671283 0 lrwxrwxrwx 1 root root 33 2011-03-27 19:43 authz_host.load -> ../mods-available/authz_host.load
671280 0 lrwxrwxrwx 1 root root 33 2011-03-27 19:43 authz_user.load -> ../mods-available/authz_user.load
664926 0 lrwxrwxrwx 1 root root 32 2011-03-27 19:43 autoindex.conf -> ../mods-available/autoindex.conf
664927 0 lrwxrwxrwx 1 root root 32 2011-03-27 19:43 autoindex.load -> ../mods-available/autoindex.load
671349 0 lrwxrwxrwx 1 root root 26 2011-03-27 20:33 cgi.load -> ../mods-available/cgi.load
671277 0 lrwxrwxrwx 1 root root 30 2011-03-27 19:43 deflate.conf -> ../mods-available/deflate.conf
671278 0 lrwxrwxrwx 1 root root 30 2011-03-27 19:43 deflate.load -> ../mods-available/deflate.load
664928 0 lrwxrwxrwx 1 root root 26 2011-03-27 19:43 dir.conf -> ../mods-available/dir.conf
664929 0 lrwxrwxrwx 1 root root 26 2011-03-27 19:43 dir.load -> ../mods-available/dir.load
664930 0 lrwxrwxrwx 1 root root 26 2011-03-27 19:43 env.load -> ../mods-available/env.load
664931 0 lrwxrwxrwx 1 root root 27 2011-03-27 19:43 mime.conf -> ../mods-available/mime.conf
664932 0 lrwxrwxrwx 1 root root 27 2011-03-27 19:43 mime.load -> ../mods-available/mime.load
664933 0 lrwxrwxrwx 1 root root 34 2011-03-27 19:43 negotiation.conf -> ../mods-available/negotiation.conf
664934 0 lrwxrwxrwx 1 root root 34 2011-03-27 19:43 negotiation.load -> ../mods-available/negotiation.load
671284 0 lrwxrwxrwx 1 root root 33 2011-03-27 19:43 reqtimeout.conf -> ../mods-available/reqtimeout.conf
671285 0 lrwxrwxrwx 1 root root 33 2011-03-27 19:43 reqtimeout.load -> ../mods-available/reqtimeout.load
664935 0 lrwxrwxrwx 1 root root 31 2011-03-27 19:43 setenvif.conf -> ../mods-available/setenvif.conf
671272 0 lrwxrwxrwx 1 root root 31 2011-03-27 19:43 setenvif.load -> ../mods-available/setenvif.load
671274 0 lrwxrwxrwx 1 root root 29 2011-03-27 19:43 status.conf -> ../mods-available/status.conf
671275 0 lrwxrwxrwx 1 root root 29 2011-03-27 19:43 status.load -> ../mods-available/status.load
671276 0 lrwxrwxrwx 1 root root 29 2011-03-27 19:43 php5.conf -> ../mods-available/php5.conf
671277 0 lrwxrwxrwx 1 root root 29 2011-03-27 19:43 php5.load -> ../mods-available/php5.load

Et pour créer les liens symboliques, depuis ce même dossier :

sudo ln -s ../mods-available/php5.conf php5.conf
sudo ln -s ../mods-available/php5.load php5.load

Ensuite je pourrais pas dire plus :slight_smile:

lol oui un peut plus bourin mais je comprend pas sous debian sa avait fonctionner très bien je vois pas se qui m****