Forum Clubic

Probleme installation d'un script depuis github

bonjour a tous,aujourd’hui j’ai essayé d’installer ce petit script :
github.com…
seulement,j’ai eu des problemes pour tout faire fonctionner,et quand je me rends sur le site nouvellement cree,j’ai juste le message me disant que le serveur tourne.
j’ai tenté cette installation sur un raspberry pi 2 model B.
quelqu’un de chevronné pourrait-il se pencher sur ce script pour m’expliquer ce qui se passe ?(je n’ai quasiment aucune connaissance dans ce domaine).
Merci d’avance

:hello:

C’est à dire ?

Il faudrait nous en dire plus :

Des messages d’erreurs, si oui, lesquels ?

Tu as suivi le readme ? Tu utilises quelle distrib ? Raspbian ?
Tu utilises Apache comme serveur web ou un autre ?

j’ai effectivement suivi le README,et j’ai rencontré plusieurs problèmes.tout d’abord,au moment de faire “sudo service apache2 restart” j?ai eu le même problème que HeedfulCrayon,lequel a poste sur github son problème.j’ai regardé plus bas sur la page et j’ai vu la solution au problème,qui était d?éditer le fichier “ssl.conf” et de remplacer SSLMutex par Mutex.
ça a fonctionné et j’ai continué a lire le README.un peu plus loin,la commande
sudo sed -i.bak “s/ServerSignature On/ServerSignature Off/g” /etc/apache2/conf.d/security
m’a posé problème,et pour cause, car /con.f/security n’existait pas ! J’ai donc eu droit a un joli “no such file or directory”
J’ai pensé qu’avec la dernière version d’apache2,ce fichier security avait été changé de place et/ou renommé,mais ce sont des spéculations.
la commande suivante posait aussi problème,pour la même raison : elle tentait d?accéder a /conf.d/security
ensuite,la commande rm -f /var/www/index.html
fonctionnait,mais restait sans effet puisque le “index.html” en question se trouvait dans /var/www/html/index.html
et donc,après avoir fait tout ça,quand j?accède au site (par l’ip locale pour l’instant),je me retrouve devant ceci :[Photo supprimée]
ce qui est un peu normal…
j’ai donc cherché dans les fichiers du dépôt,lequel comportait le code HTML,et il se trouve que c’est le index.php,qui contient du code PHP ET du HTML,et quand je le met dans le répertoire HTML,forcément rien ne change puisque c’est un fichier .php
j’utilise raspbian,et apache (comme indiqué dans le README)
Edité le 24/01/2016 à 09:13

bonsoir ,
t’as essayé de creer manuelement le fichier security avec la commande touch ?