Forum Clubic

Problème exécution d'applications en mode utilisateur

Bonjour tout le monde,

J’ai une petite question à vous poser : Certaines applications ne fonctionnent pas parfaitement en mode utilisateur.
Par exemple avec l’application Ganttproject, un simple utilisateur ne peut pas avoir accès aux options.

Il existe la solution d’exécuter l’application en mode administrateur, mais je ne vois pas l’intérêt de divulguer le mot de passe administrateur à chaque utilisateur de la boîte… J’ai aussi éssayé de mettre l’application en mode compatibilité XP (SP3), mais ça n’a rien changé.

Auriez-vous une astuce pour moi ?

Merci d’avance.:slight_smile:

Cdt

L’application essaye d’écrire dans un dossier protégé (typiquement Program Files) et / ou dans une section protégée du registre.

Un utilisateur lambda n’a pas le droit d’écrire dans ces zones spécifiques. C’est un défaut de programmation (ou une programmation inadaptée au système en question).

Normalement, il faudrait que les options soient écrites dans le HKCU du registre (dont l’utilisateur a le pouvoir), et non dans une autre ruche, ni dans un .ini directement dans le dossier du programme, mais un dans un dossier appartenant au user (le fameux application data).

Salut kuunlan,

Merci pour ta réponse.
Je comprend mieux le problème. Tu penses qu’une réinstallation suffirait à résoudre le problème ?

cdt

Le problème, c’est que c’est le logiciel lui-même qui est mal écrit et qui ne respecte pas les règles de fonctionnement de Windows NT… Je ne suis pas sûr qu’une simple réinstallation y puisse quelque chose. :neutre:

Y a-t-il eu une version mise à jour de ton logiciel et qui ne se trouverait pas le “besoin” d’aller trafiquer dans des dossiers/clef de Registre où il n’a pas à aller ?

C’est difficile à dire. Ca peut résoudre le problème (cas du .ini blabla) si le programme est installé dans un autre dossier que program files (“c:\mon programme” par exemple).
Dans le cas d’un accès au registre, ça risque d’être moins simple, et surtout, nettement plus casse gueule.

Si tu es en entreprise avec Active Directory et qu’il n’y a pas d’impératif rigoureux de sécurité, tu peux passer le compte de l’utilisateur en question en administrateur local de la machine. Ca lui donnera les droits voulu, sans toucher les accès coté AD.

Mais bon, c’est un workaround = /

Slt,

Je pense que je vais faire comme ça (modifier les droits utilisateurs) parce que je n’ai pas réussi à régler le problème !