Forum Clubic

Probleme étrange avec le Incoming d'eMule!

Bonjour a tous!

Je possede deux ordinateur mis en reseau local en passant par une Livebox Sagem.Je n’ai jamais eu de probleme pour partager mes

fichiers entre ces deux ordinateurs(chaque ordinateur tourne sous XP Home).Mon probleme survient lorsque je veut acceder au fichiers

nouveaux de mon dossier “incoming” d’eMule.Il m’est impossible par exemple de pouvoir lire un fichier video sur mon resaeu local;un

message d’erreur me dit que le fichier est inaccessible.Je precise que ces fichiers que j’essaie d’ouvrir sont sur le PC 1.

Le PC 1 est relié a la Livebox par ethernet.Le PC 2 est en connexion Wi-Fi sur la Livebox.Les adresses IP sont gérées automatiquement .

Je precise aussi que seuls les fichiers nouvellement arrivés dans le dossier incoming sont touchés par ce probleme.Des fichiers plus

anciens sont partages sans messages d’erreurs.Vraiment bizarre;serait-ce un bug d’eMule connu ou un bug de Windows?J’avais vu il y a

peu une autre personne ayant le meme probleme sur un forum mais je ne le retrouve pas.Peut-etre pourriez-vous m’aider?Merci

Essaye de desactiver le partage du dossier incimoing , puis reactive le . Normalement tu devrai pouvoir lire les nouveaux fichiers arrivés.

Merci pour ta reponse,c’est la premiere fois que je post.D’habitude,j’m’arrange toujours en cherchant dans les forums precedents.

Sinon,oui,j’ai deja essayé et c’est vrai que ca marche mais c’estv quand meme bizarre de devoir faire ca a chaque fois,c’est pas

normal et loin d’etre pratique.Et aussi,pourquoi c’est juste avec le dossier incoming d’emule.J’ai d’autres dossiers partages et j’ai

jamais de probleme.

J’avais pensé aussi a des services Windows a reactiver mais je ne vois pas lesquels.Si tu as d’autres pistes,je suis preneur.

J’ai essayé aussi de retrouvé le message du gars qui avait eu le meme probleme pour avoir des news mais je retrouve pas le

message;Bref,ca m’ennerve.

Eh ben non,le pire c’est que ca marche meme pas.J’avais dit oui parce-que c’est ce que je pensais avoir fait la derniere fois mais maintenant j’ai des doutes.
Là,j’ai essayé aussi de renommer le dossier et de recreer un nouveau partage sur le reseau mais rien ne se passe.Plus j’avance et plus ca me lourde.
Je dois pas etre le seul a partager le dossier incoming sur un reseau local.Si quelqu’un pouvait me dire ce que ca donne chez lui pour savoir si le probleme et specifique a ma config.;peut-etre toi Dragon_Boy?

Voici 2 liens qui devraient vous interesser :

www.commentcamarche.net…
www.hanselman.com…

C’est le même problème que cet autre topic:
www.clubic.com…

Merci de votre reponse(Caiman2).

En fait,mon probleme n’est pas celui-ci.En ce qui me concerne,mon dossier incoming est present sur mon PC ainsi qu’en partage reseau sur un second ordinateur,les fichiers qui sont a l’interieur sont eux aussi visibles et accessible via l’ordinateur sur lequel ils ont ete téléchargés,visible uniquement sur l’ordinateur 2 du reseau.

Le probleme c’est que tous les nouveaux fichiers de ce dossiers incoming ne peuvent pas etre ouvert sur le partage reseau du second ordinateur.Je precise que cela ne se produit qu’avec le dossier incoming.

En attendant de trouver une solution,je fait des copier/coller des nouveaux dossiers du Incoming vers un autre dossiers que je partage aussi sur mon reseau et ca marche;mais bon,c’est du bricolage.J’espere que vous avez mieux compris mon probleme?

Pour resumé,je ne comprend pas pourquoi les nouveaux dossiers que je telecharge apparaisse sur mon reseau local mais ne peuvent pas etre ouvert sur le reseau;alors que sur le PC les ayants telechargés c’est possible.Pourquoi ce probleme ne s’applique t’il qu’au dossier incoming,
Edité le 10/07/2007 à 22:48

Voir les droits utilisateurs sur ce dossier incoming et le flagger pour que les dossiers enfants héritent des mêmes droits
Edité le 11/07/2007 à 11:05

Comment effectue t’on cette manipulation?Je vais chercher sur Google en attendant votre reponse.Merci

Je precise que j’ai ojouté l’onglet securité a XP Home pour pouvoir gerer les droits d’acces plus precisement (cet onglet est

normalement propre a XP Pro)mais je ne l’ai jamais utilisé.Peut-etre est-ce par cet onglet que je vais pouvoir regler l’option dont vous

me parlez?
Edité le 11/07/2007 à 16:24

Par defaut tout dossier enfant hérite du dossier parent , sauf si on modifie ou supprime des utilisateurs dans ce dossier enfant. Dans ce cas windows previent qu’il va copier les droits du dossier parent vers le dossier enfant.
On reconnait les droit hérités parce qu’ils apparaissent en grisés.

Il faudrait comparer les droits des dossiers qui sont accessibles de ceux qui ne le sont pas.

Exact,on se rapproche.En regardant dans l’onglet securité du dossier Incoming,les dossiers nouvellement telecharges n’ont pas ou plutot ont un item manquant:dans le cadre intitulé “Nom d’utilisateur ou de groupe”,l’item “Tout le Monde” est manquant.Par ailleurs,les nouveaux fichiers arrivés n’ont pas de droit apparaissant en grisé,ils sont tous en vert,a la difference des anciens dossiers (j’appel ancien dossier les dossiers qui etaient deja dans le dossier Incoming lorsque j’ai effectué le partage de celui-ci sur le reseau) qui eux ont tous leurs droits en grisé.

Comment faire pour que cet item figure sur chaque nouveau dossier sans avoir a le rajouter manuellement pour chaque dossier.Quelle action doit etre appliquee au dossier parent?C’est là qu’est la solution mais je n’arrive pas a faire que les droits du dossier parent(le incoming)s’appliquent aux dossiers enfants.

Une autre chose etrange que j’ai oublié de vous dire et que les dossiers que je rajoute moi meme dans le dossier Incoming et donc sans avoir ete telecharges sont,eux,lisibles sur le reseau au meme titre que ceux ce mes autres dossiers mis sur le reseau(l’item “tout le monde” apparait là aussi dans leurs proprietes).

Pourquoi ces dossiers traites par eMule ne disposent pas d’emblé des memes droits que les autres?Mystere.
Edité le 11/07/2007 à 20:42

Vous donnez vous même la raison.
C’est l’executable d’emule qui crée ces dossiers et donc en plus de créer ces dossiers il en modifie les droits.
Peut-être y at-il des parametres à régler au niveau d’Emule .
Si ce n’est pas le cas il faudrait savoir quel est le nom de cet executable et le rechercher avec le gestionnaire des taches (ou un autre plus puissant comme “process monitor”) pour savoir sous quel utilisateur il tourne (system, services, proprietaire,administrateur …).
Ensuite supprimer à cet utlisateur le droit de modifier les autorisations sur le dossier et sous dossiers “incoming”.
Cette manoeuvre est peut-être génante avec les utilisateurs spéciaux cités ci-dessus.

En revanche si cet executable est lancé en tant que service pour pouvez à ce moment la lui définir d’être éxecuté sous l’utilisateur de votre choix. (le créer en local et lui affecter tous les droits sauf modification des “autorisations”).

Mais enfin tout cela me parait un peu “vicelard” peut-être qu’une mise à jour d’Emule ou l’installation d’un autre P2P comme shareaza me parait moins scabreux. :pt1cable:
Edité le 12/07/2007 à 10:04

Je crois que ca depasse mon niveau de competence,vous m’avez donné toutes les reponses dont j’avais besoin.J’vais peut-etre essayer d’apprivoiser un peu mieux l’onglet securité pour la gestion des dossiers et on verra.J’ai quand meme essayé pas pal de manipulations hier pour que les droits des dossiers enfants soient les memes que ceux des parents mais rien n’y fait.Ou alors le probleme provient d’emule lui-meme et je ne peut rien faire?

Si je trouve une solution,je la postera ici d’ici peu.Je reste cependant preneur de conseils,Merci pour le coup de main et vos conseils aussi precis.

Bon,je crois que c’est bon.Ce matin j’ai essayé pour voir de retourner a la version 0.47 de eMule pour voir si ca resolvait le probleme et effectivement ca a resolu le probleme.Je ne suis cependant pas sur que l’erreur provienne de la version 0.48 a puisque j’avais effectué la mise a jour avec la technique qui permet de conserver ses credits.Peut-etre ai-je mal effectué cette manip.Ce qui est sur c’est que la version 0.47 c ne presente pas de probleme a ce niveau.Comme d’habitude,la solution etait toute bete,et dans l’histoire je crois que le bete c’est moi.Encore merci a ceux qui ont pris la peine de m’aider.
Edité le 12/07/2007 à 14:51

salut,
Moi j’ai un problème avec mes fichiers terminés. J’ai installé Emule Plus , télechargé mes fichiers tout a bien marché et puis au bout de 3 , 4 jours je ne trouve plus les nouveaux fichiers téléchargés. Ils sont pourtant inscrits dans partage , Emule me dit qu’ils sont dans mon fichier Incoming alors que non… Et même après des recherches sur mon disque dur je ne trouve pas les fichiers , ils me disent que l’emplacement a disparu … Une idée pour régler ça ? Merci

Salut Pochy et les autres,:hello:
As tu résolu ton probleme?Tu es sous XP ou plutot Vista je pense vu le probleme(je crois que c’est un probleme connu avec emule dans Vista)?Voici un lien tres bien expliqué sur la gestion des dossiers sous Vista pour ceux que cela interresse www.infos-du-net.com…

Sinon,J’ai résolu min probleme de facon plus claire.:DEn fait,comme Caïman2 m’avait expliqué,eMule modifiait les droits des dossiers qu’il générait.En fait,la solution que j’avais essayé etait la bonne (a savoir modifier les droits du dossier Incoming pour la règle "Tout le Monde"apparaisse dans l’onglet sécurité)mais je ne m’etait pas attaqué au bon dossier.Le probleme c’est que comme le dossier Incoming appartient a eMule et bien eMule.exe continuait a en modifier les droits.Je n’etait donc pas remonté suffisamment haut dans dans la hierarchie en ne m’occupant que du dossier Incoming.

La solution a donc été de modifier les droits dans l’onglet sécurité du dossier contenant eMule.exe et d’y ajouter "Pour toutle monde"dans les droits d’utisateur de l’onglet.Et là,“miracle”,comme le disait Caïman2 ,les droits ont changés et ont été hérités par l’ensemble des dossiers “enfants” et donc ,pour mon dossier Incoming,les droits de l’item "Pour tout le monde"apparaissaient en grisé.Merci encore a Caïman2.:super:
Edité le 16/12/2007 à 00:10