Forum Clubic

Problème d'objets créés non gérés?

Bonjour,

Je vais aller droit au but :
J’ai fait un flash (version 8.0 pro), un “loader” pour mon portfolio que vous pouvez voir ici.
Le problème, est que, des petites bulles restent parfois en suspend, comme si l’objet se crée mais n’est plus géré par flash…:nexath
bug connu?

Merci…

Bon, je viens de corriger le problème avec un petit bout de code (un patch :lol:)
mais je laisse le clip bugué (car le code est correct) au cas où quelqu’un à une explication :neutre:

Une explication sans avoir le code, ça risque d’être difficile :slight_smile:

Je vais laisser le patch…
Si ça marche avec une bulle, il n’y a pas de raison que ça marche pas avec toutes.
Apparemment c’est flash qui n’est pas assez puissant pour gérer autant de particules, il doit perdre les pédales.

Et puis, la preuve, en local, il y en a deux ou trois max, et sur le net, presque une dizaine, bizarre non???

Pas forcement. Sur ton animation, les bulles remontent jusqu’au niveau de l’eau, qui lui-même remonte. Il y a une interaction entre deux objets se déplaçant indépendamment, on peut donc tout à fait penser à un problème de synchronisation qui ne se produit que dans des conditions précises. Une caractéristique des problèmes de synchronisations étant qu’ils dépendent du temps et de la vitesse d’exécution, et sont donc aléatoires.
Edité le 06/08/2009 à 19:34

Rien à voir, à part les logs spécialisés mutli-proc qui executent en parallèle, flash n’est pas dans ce cas.
Le code ici est traité séquentiellement, animations incluses, au même instant t, rien ne s’exécute simultanément, tout est à la “queue leuleu”, ici ce n’est pas de l’éxécution en parallèle, donc pas de désynchro.
De plus j’ai trouvé le bug et il s’agit bien d’un bug flash :
J’ai viré le test de l’eau et l’eau elle même, juste les bulles montent, arrivées à une hauteur y, elles passent à une animation (éclate) et le clip est détruit, le problème est que le “gotoAndPlay(n° image)” n’est pas pris en compte dans certains cas.
tout simplement…flash perds les pédales.
Edité le 07/08/2009 à 17:18