Forum Clubic

Probleme Direct3D ou Drivers ATI

Bonjour,

J’ai récemment eu un nouveau PC ( 1024 MO de RAM, Radeon 9800 PRO, Processeur AMD 2.2ghz 3000+, DD 80go Maxtor ) gratuitement et non-formaté. Mais il y avait 3 images ghosts dessus, dont une qui était celle juste après l’installation du SP1. Je l’ai donc installé et mon PC s’est retrouvé avec le SP1.

J’ai fais depuis toutes les MAJs via Windows Update, et j’ai tenté d’installer des jeux : Warcraft III et Counter-Strike.

J’ai testé Warcraft III et ça marchait, mais j’ai eu plusieurs souçis avec le SP1, nottament pour windows Live messenger et d’autres trucs. J’ai pris donc la deuxieme image: celle avec le SP2. Ca a marché, no souci.

Seulement, maintenant, j’ai installé Warcraft III et Counter-Strike, et Warcraft 3 me marque un message d’erreur au lancement

Mais Counter-Strike marche sans problème ! Suivant le message d’erreur, j’ai tout d’abord désinstallé mes drivers ( Des CATALYST, car j’ai une 9800 PRO ), puis réinstallé une version plus récente. Ca n’a pas marché. J’ai essayé la version 6.x, pas marché non plus ( je prends soin de désinstalles mes drivers avant d’en installer de nouveaux ), et je suis sûr que l’installation marche bien car dans le DXDIAG le driver de ma cg est bien celui que je veux.

Là, quelqu’un m’a dit que Counter Strike était en openGL, donc je me suis dis que ça venait sûrement de DirectX[/url]. J’ai donc installé [url=http://www.clubic.com/telecharger-fiche10906-directx.html]DirectX 9.c sans souçi ( Warcraft III me dit bien que j’ai une version supérieure à la version 8 ), mais le " Direct3D " ne marche pas. En effet, dans le DXDIAG, lorsque je fais le test de Direct3D, ni la version 7, ni la 8 ni la 9 ne marchent :

Résultats des tests Direct3D 7 : Échec à l’étape 8 (Création d’un périphérique 3D): HRESULT = 0x80004005 (Échec général)
Résultats des tests Direct3D 8 : Échec à l’étape 8 (Création d’un périphérique 3D): HRESULT = 0x8876086c (Code d’erreur)
Résultats des tests Direct3D 9 : Échec à l’étape 8 (Création d’un périphérique 3D): HRESULT = 0x8876086c (Code d’erreur)

Mais les test de Direct Draw se passent sans souçi .

Voici mon dxdiag :

http://img155.imageshack.us/img155/4624/dxdiagyp6.jpg

Je sais que les drivers Omega ne sont pas WHQL, mais je pense pas que ça vienne de là. Direct3D ne marchait pas non plus avec les Catalyst 7.1.

Je sais que ma carte graphique est compatible Direct3D, j’ai déjà réussi à lancé Warcraft III dessus ! Mais revenir au SP1 pour ça…

Voici donc ma question : Comment activer Direct3D et / ou trouver une solution pour lancer Warcraft III autrement ! ( opengl? )

Merci d’avance à ceux qui peuvent m’aider !

C’est bon ça marche! J’ai ghosté mon disque dur avec une version plus ancienne, apparement seuls les Catalyst 6.1 marchent ( ou antérieurs je suppose, jusqu’au 5.1 du moins :slight_smile: )

Hello,

Tu peux aller jusqu’aux 7.7 sans problème :wink:

Ah ? Tu en es sûr ? Parce que j’ai téléchargé les 7.1 ( ou 7.10 en fait je sais pas ) et ils ne marchaient pas… :expressionless:

Au pire, est-ce qu’une restauration du systeme simple permettra d’annuler la màj des drivers ? :slight_smile:

Merci en tout cas :wink: