Forum Clubic

Problème détection disque dur SATA et USB

J’ai un problème un peu particulier et je ne sais plus comment le résoudre.

Voila, j’ai un disque dur de 2 To, 1 To et de 500 Go ainsi qu’un de 300 Go.

Je veux pouvoir utiliser le 2To en USB, le 1To SATA, retirer le 500go et garder le 300Go comme disque principale.

Lorsque je branche le 1To en SATA, windows détecte le disque mais me demande de le partitionner/formatter.
Pourtant, je sais pertinemment que ce disque est déjà formatté et qu’il y a des données dessus.
Lorsque je le branche en USB, tout est ok.

pour le 2To c’est l’inverse, il fonctionne bien en SATA, mais en USB, j’ai le message de le partionner/formatter.
Il y a également des données sur ce disque.

Je n’y comprends plus rien.

Voici ma config:
2To - WDC WD20 EARS-60MVWB0
1To - WDC WD110 EARS-22Y5B1
300Go - 2D3000HLFS-01G5U4

Carte maîtresse: Rampage II Extreme
Mémoire: 6 Go OCZ DDR3
Carte vidéo: 2x BFG GTX 280 OC2
Windows 7 64bits
Dernière mises à jours installé.

Voici ce que j’ai fais jusqu’à maintenant:

  • Testé d’autre câble SATA
  • Inverser câble SATA
  • Changé câble SATA du contrôleur USB
  • Update du contrôleur Micron JMB36X

J’hésite à mettre le BIOS à jours puisqu’il n’y a pas d’update qui concerne les disques SATA.

Merci de m’aider!

J’ai fais un autre test, j’ai mis mon 2To qui fonctionne en SATA sur mon portatif en USB et même chose, Windows 7 me dit qu’il n’est pas formatté.
J’en déduis donc que le problème ne provient pas de mon ordinateur.

Se pourrait-il que lorsque j’ai formatté le 2To en SATA, il ne soit plus visible en USB et l’inverse pour le 1To qui a été formatté en USB ne fonctionne plus en SATA?
FMaltais a édité ce message il y a 4 minutes

Autre test, j’ai mis mon 2To en SATA et l’ai reformatté, ça a pris un temps énorme. Une fois terminé, je l’ai mis en USB et Windows me donne le même message, le disque n’est pas formatté. Je l’ai donc formatté et une fois terminé, l’ai mis en SATA. Maintenant, c’est en SATA que Windows me dis qu’il n’est pas formatté. Ça sens le problème avec ce disque et je crois que j,aurai le même symptôme avec le 1To.

Si tu as le même problème avec deux disques durs, peut être que le problème vient de ton boitier ?

Personnellement, j’ai eu le problème avec un disque dur externe Western Digital My Book Pro. Dès la connexion, windows me demandait si je voulais le formatter, j’ai démonté le disque, je l’ai formaté en interne et depuis plus de problème.

Résultat, aujourd’hui, j’utilise la connectique ESATA et mon ordi pense que mon HDD externe est interne et depuis plus de problème.