Forum Clubic

Problème démarrage X - Je me retrouve en mode console

Bonjour à tous,

J’ai installé la mandriva 2005 sur une nouvelle machine. Le démarrage se déroule tout à fait normalement. Le problème, c’est que je me retrouve en mode console et que le système ne me propose à un aucun moment de lancer KDE. J’ai comparé le lilo.conf de la machine actuelle avec celui de la machine précédente - qui lançait KDE sans poser de question - et leur contenus sont rigoureusement identiques:

default="linux"
boot=/dev/hda
map=/boot/map
keytable=/boot/fr-latin1.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz
label="linux"
root=/dev/hda1
initrd=/boot/initrd.img
append="acpi=ht resume=/dev/hda5 splash=silent"
vga=788
read-only
image=/boot/vmlinuz
label="linux-nonfb"
root=/dev/hda1
initrd=/boot/initrd.img
append="acpi=ht resume=/dev/hda5"
read-only
image=/boot/vmlinuz
label="failsafe"
root=/dev/hda1
initrd=/boot/initrd.img
append="failsafe acpi=ht resume=/dev/hda5 devfs=nomount"
read-only

Je me pose donc deux questions:

1 - Comment lancer KDE en mode console ?

2 - Pourquoi ce changement de comportement alors qu’il s’agit de la même distribution ?

A titre indicatif, la configuration de la deuxième machine est la suivante:

Carte mère Intel Rock Late ( D865Perl )
CPU Intel Celeron D335 ( 2,8 Ghz )
Carte ATI Radeon 7000
Disque dur 120 Go Ultra-DMA ( 8 Mo )

J’ai déjà eu un problème semblable, et, si j’ai bien compris ton problème, je pense pouvoir t’aider !
Tout d’abord, pour lancer X en mode console, tu fais soit


startx

De préférence, pas en root, soit


init 5

Maintenant, faire cela ne résoud pas ton problème…
J’ai eu ce problème lorsque j’ai installé le driver NVidia, rien à voir avec lilo.conf…
Je vois que tu as ATI, documente toi, j’ai eu à changer le fichier /etc/modprobe.preload et ajouter une ligne nvdia… Cherche plutôt de ce côté parce qu’à priori, ton fichier lilo.conf semble normal…
Bonne chance !
PS : pour configurer le démarrage avec mandriva en mode console, tape (en root) :


drakconf

Je te remercie.

KDE semble bien installé:

kde-config -v

Qt: 3.3.4
KDE: 3.3.2
kde-config: 1.0

Par contre, si je lance "startx kde", ça commence à coincer:

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.10-3mdksmp i686 [ELF]
Current Operating System: Linux localhost 2.6.11-6mdk #1 Tue Mar 22 16:04:32 CET
2005 i686
Build Date: 06 April 2005
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Jul 31 14:41:30 2005
(==) Using config file: "/etc/X11/xorg.conf"
Using vt 7

(EE) No devices detected.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.X.Org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional informati
on.

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.

Je ne comprends pas ce qui le contrarie. Si quelqu’un peut me traduire …

Poste ton /etc/X11/xorg.conf (mais pas ici, donne juste le lien vers un ftp)
A tout les coup, tu t’es vautré sur le driver de ta carte ati
Dans la section device, tu as bien Driver “ati” ?
Sinon, essaye de reconfigurer le serveur X. Je ne suis plus du tout sûr, mais il me semble que ca doit être drakx ou drak quelquechose :smiley: