Forum Clubic

Probleme debian: des interfaces reseau se créent toutes seules

salut a tous.

j’ai un petit probléme avec mon serveur debian recement installé.

le bug est que a chaque demarage du serveur il crée une nouvelle interface reseau virtuelle, portant a chaque fois un numero different (eth1, eth2, eth3, …, eth10 …) alors que j’ai absolument rien fait pour cela …

voulant assigner une ip fixe a mon serveur c’est trés embetant… de plus l’adresse mac change a chaque fois donc méme pas possible de faire une reservation DHCP…
et mon intrerface physique eth0 est méme pas listée par ifconfig -a. par contre dans webmin je la vois dans le truc pour gerer le reseau, et elle me parais bien configurée…

donc voila, comment faire pour que mon serveur arrete de creer des interfaces toutes pourries ? j’aimerais pouvoir utiliser eth0 normalement …

merci

mouarf ! c’est la 1ere fois que j’entends parler d’un truc pareil… :MDR
Ca pourrait venir de HAL mais comme j’ai jamais rencontre un probleme similaire, je vois vraiment pas ce qui pourrait etre fait…
As tu essaye de reinstalle ta distrib ? t’as quoi comme carte reseau ? As tu verifie si il y avait un bug connu de ce genre ?
As tu touche aux fichiers de conf du reseau ?
As tu essaye une autre distrib ?

aujourd’hui j’en suis a eth11, et toujours pas de solution …
j’ai essayé de reinstaller la distrib (debian4).
tout ce que j’ai touché a la conf reseau c’est changer les ip.
j’ai un peu chercher sur le net pour voir si le probléme etais connu, mais je ne sait pas trop quels mots googliser pour avoir des resultats pertinents…
je n’ai pas essayer d’autre distribs linux, mais j’ai essayé FreeNAS (un bsd) et la carte reseau n’etais pas reconnue automatiquement … donc ayant pas trop envie de me prendre la tete chui repassé sous debian.
je sait pas exactement ce que c’est comme carte, c’est integré a la carte mére.
quelle commande pour avoir des infos sur ma carte reseau?
merci pour ton aide.

lspci… ou sinon, ouvrir la becane et chercher le nom de la puce

Le problème est du au fait que l’adresse MAC de la carte change sans arrêt. Debian considère que ce n’est plus la même qu’avant et crée une nouvelle interface.

Je sais pas exactement comment ça marche, mais ça se passe là dedans : /etc/udev/rules.d/75-persistent-net-generator.rules

Je pense que tu devrais essayer de créer une règle dans un /etc/udev/rules.d/01-perso.rules et lui dire que la carte qui utilise tel driver doit avoir tel nom. Par exemple, pour ma carte Wifi, j’ai mis un truc comme ça pour qu’elle soit pas nommée eth1 :

SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:13:02:22:13:d0", NAME="wifi0"

Mais avec le prob de l’adresse MAC qui n’arrête pas de changer, va falloir trouver une autre astuce…

ok je teste ça ce soir.
merci

:heink:

une adresse mac est pas attribuee par le systeme pourtant non ?
Elle est changeable mais c’est pas dynamique… me trompe je ?

re.
thoriquement l’adresse mac attribuée a ta carte physique, et elle est pas changeable. On peux juste la dissimuler en utilisant des techniques d’escroc. Par contre en creant des interfaces virtuelles a partir de la carte physique, vu que chaque interface a besoin d’une adresse mac, bin ça crée des adresses mac virtuelles…

Sinon, j’ai pas reussi a resoudre le probléme, j’ai mis une nouvelle carte reseau PCI et j’ai desactivé l’intégrée a partir du bios, et la ça marche tt seul. c cool. mais n’empéche que je n’ai absolument rien compris au probléme…

merci quand méme pour votre aide

Bonjour,
J’ai un AMD 64 avec une debian sarge

même problème.
Internet fonctionne bien, mais à chaque boot l’interface eth s’incrément d’une unité, l’adresse ip change ainsi que l’adresse mac (donnée par ifconfig)
autrement j’ai une freebox en mode routeur avec dhcp

je n’arrive pas à comprendre.
cordialement

Quel est le modèle de la carte/chipset ethernet ?

La MAC change toute seule ??? C’est quoi ce bug???
Poste mous le résultat de lspci et surtout de lsmod
Si udev et/ou le noyau merdouillent et “redécouvrent” la carte de temps en temps, il devrait retrouver la même MAC à chaque fois !
S’il trouve une mac différente à chaque fois ,c’est que le driver est totalement buggé.
Ou alors, la carte à un pb matériel (mas ça j’y crois pas trop car je ne l’ai jamais vu (argument nul s’il en est :)))

Il faudrait demander sur un chan debian car je ne sais pas où rapporter le bug (sur quel paquet??)


**google** [www.nabble.com...](http://www.nabble.com/Eth-d-keeps-incrementing-everytime-the-system-boots.-td13854233.html)

The solution to this is to add the line

SUBSYSTEM==“net”, DRIVERS==“forcedeth”, NAME=“eth0”

to /etc/udev/udev.rules

mais je n’ai pas tout lu car là il est 01h23 du mat :wink:

forcedeth = Nvidia… la voila la cause du probleme…

Heu on fait pire :wink:
Bon…je ne sais toujours pas si c’était seulement une règle udev qui manquait ou si le driver qui merdouille au point de croire que la MAC change…