Forum Clubic

Probleme de Virtual Host avec Apache2 - (serveur Nunuxe MDK10.1)

Hello, j’espere que vous allez pouvoir m’aider à resoudre un petit soucis.

J’ai beau chercher je patauge :riva:

J’essai tant bien que mal de mettre en place des virtual host basés sur le nom sur mon serveur apache.

Le principe c’est d’avoir un domaine www.domaine.com qui tombe sur le repertoire /serveur/www1 , et en plus un sous-domaine machin.domaine.com qui doit aboutir sur /serveur/www2

Pour faire cela je me base sur les doc:

http://httpd.apache.org/docs/1.3/vhosts/name-based.html

http://httpd.apache.org/docs/2.1/fr/vhosts…s.html#purename

Donc je configure mon *.conf comme indiqué:

Mais j’ai beau faire, soit les 2 tombent sur /serveur/www1 soit ils tombent sur /serveur/www2, bref… jamais chacun le sien :riva:

Voici mon fichier conf:


### Main Configuration Section
### You really shouldn't change these settings unless you're a guru
###
ServerRoot /etc/httpd/2.0
ServerName www.whykywa.com
#LockFile /etc/httpd/httpd.lock
PidFile /var/run/httpd.pid
ErrorLog logs/error_log
LogLevel warn
DocumentRoot /serveur/www


### Dynamic Shared Object (DSO) Support
### 
### You should always leave those three, as they are needed for 
### normal use.
### mod_access (Order, Allow, etc..)
### mod_log_config (Transferlog, etc..)
### mod_mime (AddType, etc...)

LoadModule access_module	modules/mod_access.so
LoadModule auth_module  modules/mod_auth.so
LoadModule auth_anon_module	modules/mod_auth_anon.so
##LoadModule auth_dbm_module	modules/mod_auth_dbm.so
LoadModule auth_digest_module	modules/mod_auth_digest.so
##LoadModule charset_lite_module	modules/mod_charset_lite.so
##LoadModule case_filter_module	modules/mod_case_filter.so
##LoadModule case_filter_in_module	modules/mod_case_filter_in.so
##LoadModule ext_filter_module	modules/mod_ext_filter.so
LoadModule include_module	modules/mod_include.so
LoadModule log_config_module	modules/mod_log_config.so
##LoadModule log_forensic_module /usr/lib/apache2/mod_log_forensic.so
LoadModule logio_module  modules/mod_logio.so
LoadModule env_module  modules/mod_env.so
##LoadModule mime_magic_module	modules/mod_mime_magic.so
##LoadModule cern_meta_module	modules/mod_cern_meta.so
LoadModule expires_module	modules/mod_expires.so
LoadModule headers_module	modules/mod_headers.so
LoadModule usertrack_module	modules/mod_usertrack.so
##LoadModule unique_id_module	modules/mod_unique_id.so
LoadModule setenvif_module	modules/mod_setenvif.so
LoadModule mime_module  modules/mod_mime.so
LoadModule status_module	modules/mod_status.so
LoadModule autoindex_module	modules/mod_autoindex.so
LoadModule asis_module  modules/mod_asis.so
LoadModule info_module  modules/mod_info.so
LoadModule cgi_module  modules/mod_cgi.so
##LoadModule cgid_module  modules/mod_cgid.so
LoadModule vhost_alias_module	modules/mod_vhost_alias.so
LoadModule negotiation_module	modules/mod_negotiation.so
LoadModule dir_module  modules/mod_dir.so
LoadModule imap_module  modules/mod_imap.so
LoadModule actions_module	modules/mod_actions.so
##LoadModule speling_module	modules/mod_speling.so
LoadModule userdir_module	modules/mod_userdir.so
LoadModule alias_module  modules/mod_alias.so
LoadModule rewrite_module	modules/mod_rewrite.so

###
### Global Configuration
###
# We now support multiple apache configurations on the same server. In 
# common.conf, we put all directives that are common to all implementations
# (httpd, httpd-perl, etc.)
# For Apache2 we load all conf files in conf.d
Include /etc/httpd/conf.d/*.conf
Include conf/commonhttpd.conf


###
### IP Address/Port and Proxied configuration section
###
# The APACHEPROXIED setting can be set in /etc/rc.d/init.d/httpd if you
# are using a proxy or accelerator, like the Apache-SGI or khttpd, so that
# the fast web server serves static content while Apache handles the 
# cgi or php files

#BindAddress *
<IfDefine APACHEPROXIED>
    Listen 8080
</IfDefine>
<IfDefine !APACHEPROXIED>
    Listen 80
</IfDefine>

# Likewise, we can set apache as the server by default and send perl
# requests via ProxyPass to apache-mod_perl. It increases performance
# since the perl interpreter is only used for perl and the standard apache
# does all the html and image files, with a smaller footprint.
#
# If you install apache and apache-mod_perl, this is the default config.
# If you don't want two web servers to use perl, uninstall apache, and
# apache-mod_perl will not be proxied.

<IfDefine PERLPROXIED>
<IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteRule ^proxy:.*  -  [F]
    RewriteRule ^(.*\/perl\/.*)$  http://%{HTTP_HOST}:8200$1 [P]
    RewriteRule ^(.*\/cgi-perl\/.*)$  http://%{HTTP_HOST}:8200$1 [P]
</IfModule>
</IfDefine>

###
### Log configuration Section
###

<IfModule mod_log_config.c>
#Single logfile with access, agent and referer information
#This is the default, if vlogs are not defined for the main server
CustomLog logs/access_log combined env=!VLOG
#If VLOG is defined in conf/vhosts/Vhost.conf, we use this entry
CustomLog "|/usr/sbin/advxsplitlogfile" vhost env=VLOG
</IfModule>

###
### Virtual Hosts 
###
# We include different templates for Virtual Hosting. Have a look in the 
# vhosts directory and modify to suit your needs.
#Include conf/vhosts/Vhosts.conf
#Include conf/vhosts/DynamicVhosts.conf
#Include conf/vhosts/VirtualHomePages.conf


###
### Performance settings Section
###
#
# Timeout: The number of seconds before receives and sends time out.
#
Timeout 300

#
# KeepAlive: Whether or not to allow persistent connections (more than
# one request per connection). Set to "Off" to deactivate.
#
KeepAlive On

#
# MaxKeepAliveRequests: The maximum number of requests to allow
# during a persistent connection. Set to 0 to allow an unlimited amount.
# We recommend you leave this number high, for maximum performance.
#
MaxKeepAliveRequests 100

#
# KeepAliveTimeout: Number of seconds to wait for the next request from the
# same client on the same connection.
#
KeepAliveTimeout 15


# prefork MPM [THIS IS THE DEFAULT]
# StartServers: number of server processes to start
# MinSpareServers: minimum number of server processes which are kept spare
# MaxSpareServers: maximum number of server processes which are kept spare
# MaxClients: maximum number of server processes allowed to start
# MaxRequestsPerChild: maximum number of requests a server process serves
<IfModule prefork.c>
StartServers         5
MinSpareServers      5
MaxSpareServers     10
MaxClients         150
MaxRequestsPerChild  0
</IfModule>

# worker MPM
# StartServers: initial number of server processes to start
# MaxClients: maximum number of simultaneous client connections
# MinSpareThreads: minimum number of worker threads which are kept spare
# MaxSpareThreads: maximum number of worker threads which are kept spare
# ThreadsPerChild: constant number of worker threads in each server process
# MaxRequestsPerChild: maximum number of requests a server process serves
<IfModule worker.c>
StartServers         2
MaxClients         150
MinSpareThreads     25
MaxSpareThreads     75
ThreadsPerChild     25
MaxRequestsPerChild  0
</IfModule>

# perchild MPM
# NumServers: constant number of server processes
# StartThreads: initial number of worker threads in each server process
# MinSpareThreads: minimum number of worker threads which are kept spare
# MaxSpareThreads: maximum number of worker threads which are kept spare
# MaxThreadsPerChild: maximum number of worker threads in each server process
# MaxRequestsPerChild: maximum number of connections per server process
<IfModule perchild.c>
NumServers           5
StartThreads         5
MinSpareThreads      5
MaxSpareThreads     10
MaxThreadsPerChild  20
MaxRequestsPerChild  0
</IfModule>

###
### webapps configuration section
###

# Web applications should be activated _after_ apache has been
# configured properly.
Include /etc/httpd/webapps.d/*.conf



NameVirtualHost xx.xx.xx.xx

<VirtualHost *>
ServerName www.domaine.com
DocumentRoot /serveur/www1
</VirtualHost>

<VirtualHost *>
ServerName machin.domaine.com
DocumentRoot /serveur/www2
</VirtualHost>

Si quelqu’un peut m’expliquer ce que j’ai loupé je suis preneur :slight_smile:

Merci @ vous.

tu as loupé plusieurs choses :slight_smile:

déjà, tes virtual host serons mieux dans un sous dossier du document root

exemple:
documentroot => /serveur/www
vhost1 => /serveur/www/vhost1
vhost2 => /serveur/www/vhost2

ensuite, il faut que tu nomme tes virtual host

par exemple:

<VirtualHost vhost1.com>
ServerName www.domaine.com
DocumentRoot /serveur/www/vhost1
</VirtualHost>

déjà, ca devrais aller mieux

bon ben je vais essayer en les mettant dans le meme dossier de base, je n’ai pas pensé que ça pouvais poser probleme.

J’avais deja essayé en nommant les virtualhost … sans succes… bizarre.

j’ai oublie de precies qu’au debut j’ai simplement tenté de faire la configuration via webmin… voyant que ça ne marchait pas j’ai mis lesmains dans le camboui :ane:

pour info voila un vhost que j’avais mis en place pour ssl

hormis les commandes relatives a ssl que tu peut/doit enlever, le reste est bon pour un vhost classique


$ cat /etc/apache2/sites-enabled/001-default-ssl
<VirtualHost localhost:443>
        ServerAdmin webmaster@localhost
        SSLEngine on
        DocumentRoot /var/www/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>
        ErrorLog /var/log/apache2/error-ssl.log
        LogLevel info
        CustomLog /var/log/apache2/access-ssl.log combined
        ServerSignature On
</VirtualHost>

menfin tu utilise quelle version d’apache ? la 2 ?

c’est comme le Port-salut c’est marque dessus (cf titre du topic :slight_smile: )

ha oui tiens …

mais zalors comment ca se fait que tes vhost sont spécifiés direct dans le fichier de conf ?

ta pas le fichier /etc/apache2/sites-enabled/ avec normalement le fichier defaults dedans ?

si oui ba il faut travailler la dedans :slight_smile: créer un fichier par vhost similaire au fichier default mais avec les modifs spécifiques a ton vhost

je n’ai pas de /etc/apache2/sites-enabled/

par contre j’ai tout dans etc/httpd/2.0/conf/

là j’ai bien un reprtoire Vhosts qui contient un vhosts.conf et un virtualhomepage.conf.

ces fichiers peuvent etre appelé depuis le conf d’apache2 via les lignes:


###
### Virtual Hosts 
###
# We include different templates for Virtual Hosting. Have a look in the 
# vhosts directory and modify to suit your needs.
Include conf/vhosts/Vhosts.conf
Include conf/vhosts/DynamicVhosts.conf
Include conf/vhosts/VirtualHomePages.conf

Lorsque j’ai fait mes premiers test via webmin c’est le fichier vhosts.conf qui etait modifié. Mais celui-ci ne contient ni plus ni moins que ce que j’ai mis en fin de mon fichier conf principal à savoir:


################# Vhosts.conf
#This is where we store the VirtualHosts configuration. 
#
#Since Apache 1.3.19, we modified the setup to include some nice tricks:
#
#- We added the User and Group directives so VirtualHosts now work with
#  suexec directive. If set, Apache will run all cgi scripts under that
#  user and group (provided the uid and gid are > 100 for security). The
#  directories and cgi files *must* belong to that user/group for the
#  feature to work
#- We added the Setenv VLOG directive. This works in conjunction with
#  the CustomLog in common.conf. When Setenv VLOG is set, apache will
#  create a /var/log/httpd/VLOG-YYYY-MM-<ServerName>.log instead of logging
#  to access_log. Use this instead of defining a special logfile for
#  each vhost, otherwise you eat up file descriptors.
#- You can also specify a path for the VLOG for each Vhost, for example,
#  to place the logs in each user's directory. However, if you want to
#  use the file for accounting, place it in a directory owned by root,
#  otherwise the user will be able to erase it.
#- I suggest only including the ErrorLog *only* if the vhost will use
#  cgi scripts. Again, it saves file descriptors! 
#- We added the Rewrite directives so vhosts will work with the 
#  PERLPROXIED configuration


################# IP-based Virtual Hosts 
#<VirtualHost 192.168.2.100>
#User jmdault
#Group jmdault
#DocumentRoot /home/jmdault/public_html
#ServerName test2.com
#Setenv VLOG /home/jmdault/logs
#ErrorLogs /home/jmdault/test2-error_log
#RewriteEngine On
#RewriteOptions inherit
#</VirtualHost>

################# Named VirtualHosts
#NameVirtualHost 111.222.33.44
#<VirtualHost 111.222.33.44>
#ServerName www.domain.tld
#ServerPath /domain
#DocumentRoot /web/domain
#</VirtualHost>


NameVirtualHost xx.xx.xx.xx

<VirtualHost *:80>
ServerName machin.domaine.com
DocumentRoot /serveur/www2
</VirtualHost>

bref, lorsque j’utilisais ce fichier conf le probleme etait le meme alors j’ai inclu les Vhosts dans le conf d’apache pour n’avoir qu’un fichier à modifier le temps de faire les essai :neutre: