Forum Clubic

Probleme de son et de generic host process for win 32 services

C’est sur un portable en XP home qui n’avait pas fonctionné de puis le mois de février.
Au bout d’un certain temps, message d’erreur ‘generic host process for win 32 services’ et après plus de son.
Il y a toujours du son au démarrage et à l’arret de l’ordi.
Une précision, il a créé un fichier de log dans demarrage genre bloc notes qui s’appelle ‘Desktop notes…etc…’ ou il nomme une certaine dll.
Quelqu’un a t-il une idée?
PS: J’ai fait une restauration du systeme à debut février mais tjrs le meme probleme.
Le portable n’a pas été sur internet depuis debut fevrier.

Personne a une idée, je vois pas quoi faire! SVP!!!

salut,

j’ai une tite idée, mais il faudrait que tu confirmes qu’il y a cette ligne dans le fichier desktop:

“[.ShellClassInfo] LocalizedResourceName=@%SystemRoot%\System32\Shell32.dll,-21787”

oui c’est exactement ca!!!

De quoi ca vient???

OK
heureusement que tu as parlé du fichier desktop sinon on aurait cherché un bout de temps.

Il y a une fiche sur le site Microsoft US mais pas sur le site FR ; Microsoft ne dit pas d’où ça vient.

La fiche est là:

http://support.microsoft.com/default.aspx?scid=kb;en-us;330132
“Notepad Starts With “[.ShellClassInfo] LocalizedResourceName=@%SystemRoot%\System32\Shell32.dll,-21787” When You Start Your Computer”

en voici la traduction :

Il y a deux méthodes, au choix.

1ere méthode: supprimer le fichier Desktop.ini incriminé

Ouvrir l’explorateur
Outils - options des dossiers - affichage
cocher 'afficher le contenu des dossiers systeme
décocher ‘masquer les extensions des fichiers dont le type est connu’

Dans chacun de ces 3 répertoires:

\Documents and Settings\All Users\Start Menu\Programs\Startup
\Documents and Settings\All Users\Start Menu\Programs
\Documents and Settings\All Users\Start Menu

rechercher un fichier desktop.ini et l’ouvrir.
si on trouve ces lignes dans le fichier :

[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21787

alors, le supprimer.

2ème méthode: Utiliser l’utilitaire msconfig pour empêcher le démarrage du fichier

faire: démarrer / executer , taper: msconfig , puis OK
cliquer sur l’onglet ‘Démarrage’
décocher les entrées nommées “desktop” listées comme devant démarrer dans:

(disque):\Documents and Settings\All Users\Start Menu\Programs\Startup
(disque):\Documents and Settings\All Users\Start Menu\Programs
(disque):\Documents and Settings\All Users\Start Menu
Quitter l’utilitaire.
et Redémarrer le PC .

voilà

merci pour tes conseils mike, je vais essayer ca.
c’est une erreur de windows ou bien ca peut venir d’un virus?

non, pas d’un virus.
plutôt un ‘petit’ bug de Windows , mais la cause réelle n’est pas mentionnée

voilou

Bonjour,
J’ai la même fenêtre qui s’affiche, presque à chaque fois que j’allume mon ordi,mais je n’ai pas de problème de son.
Pas de problème par la suite (ou alors je n’ai rien vu), sauf mon “paint shop pro” qui ne veut plus démarrer.
“Paint Shop Pro 7 a rencontré un problème et doit fermer. Nous vous prions de nous excuser pour le désagrément encouru.”, me dit-il. Est-ce lié?
J’ai cherché le fichier “desktop” avec chacune des 2 démarches proposées plus haut, et je n’ai aps trouvé de “desktop”.
Dans l’onglet “démarrage”, rien de particulier.
Qui a résolu ce problème?

Pardon… j’ai trouvé le “desktop”… il était caché

J’ai supprimé le fichier qui correspondait exactement. Puis redémarrage. Pas de fenêtre ouverte à l’allumage de mon ordi. Victoire? J’espère…
Par contre, ça n’a pas résolu le problème de paint shop pro…

salut,

C’est vraiment très curieux ces problemes de desktop.ini intempestifs.
Pour PSP 7 , personnellement, je le désinstallerais et le réinstallerais proprement ( via ajout/suppression de programmes)

Je vais essayer. Merci de m’avoir répondu.