Forum Clubic

Problème de reconnaisance de disque

Bonjour à tous,
Sur le disque interne de mon pc fixe, je n’ai que le système, Windows 7.
Tous mes fichiers perso sont sur un dique externe, paritionné en 3.
Pour simplifier la discussion, disons que j’ai 3 disques externes.
Sur le bureau, j’ai des raccourcis qui pointent sur des fichiers qui sont sur ces 3 disques. L’icone de certains raccourcis est également sur ces disques externes.
Depuis des années, je tourne comme cela sans le moindre problème, les 3 disques étant branchés en permanence.

Depuis quelque jours, au démarrage, j’ai pour chacun de ces 3 disques, la fenêtre “Exécution automatique” qui s’ouvre et qui pose les questions habituelles comme pour un disque externe qu’on branche après le démarrage d’un PC.
Ce qui fait que les icones sur le bureau qui sont pris sur ces disques, ne sont pas trouvés…

Je ne sais pas ce qui se passe, et je n’aime pas ne pas savoir…
Je compte sur vous pour m’expliquer…

As-tu vérifié dans “exécution automatique” du panneau de configuration si le paramètre avait changé ?

Autrement dit, que dans la catégorie “périphériques” (sous réserve que ton hdd externe y soit indiqué) ce soit réglé sur “ne rien faire” au lieu de “ouvrir device stage” :wink:

Dans “execution automatique” mes disques ne sont pas décrits.
Mais j’ai en haut une ligne :
“Utiliser l’execution automatique pour tous les medias et tous les périphériques”.
J’ai décoché ce champ.
Et je retrouve mes icones… :oui:
Je n’ai plus le démarrage automatique pour le lecteur de dvd, mais ce n’est pas grave.
Je reste un peu sur ma faim, car, avant, j’avais les icones ET le démarrage auto des DVD. Mais bon les DVD c’est occasionnel, pour moi…
Merci pour l’astuce.


Ah oui, encore une petite chose : En bas de la fenêtre "Execution automatique", j'ai une ligne : Périphériques : suivi de : "Les périphériques connectés à votre ordinateur sont affichés ici."

Mais… y’a rien d’afficher… :neutre:

Ha ok ^^ perso j’ai mon lecteur .mp3 Sony qui est affiché là, et justement je ne voulais pas qu’il s’ouvre au branchement donc j’avais coché “ne rien faire” :wink:

Mais tu peux normalement choisir un comportement séparé pour chaque cas de figure et/ou type de médias, chez moi presque tout est réglé sur “ne rien faire”, mais “logiciels et jeux” par exemple est réglé sur “installer ou exécuter un programme depuis son support” (j’ai encore des jeux sur dvd) :neutre:

Je pense que pour que ces options soient opérationnelles, il faut cocher : “Utiliser l’execution automatique pour tous les medias et tous les périphériques”.

Chose bizarre, je démarre l’ordi le matin. Il n’a pas tourné depuis la veille au soir. Il est “froid”.
Je n’ai pas mes icones.

Après avoir travaillé 3/4 d’heure, je l’arrête normalement. Je coupe l’alimentation électrique. Même arrêt que la veille au soir. Je redémarre. Et là, mes icones sont bonnes.

Les mystères de l’informatique sont décidément insondables…:@

Aujourd’hui je surveille le démarrage… Premier affichage du bureau… les icones sont correctement affichées.
Puis quelques secondes … minutes… il finit le démarrage et les icones ne sont plus bonnes.

Mon disque externe serait-il en train de me lâcher… ??

J’ai contourné le problème en mettant le fichier d’icones sur le disque C.

Je suis tomber sur la solution, un peu par hasard.
Il suffit d’agrandir la taille du fichier Iconcache.db
Je l’ai passé à 4096
Dans HKEY_LOCAL_MACHINE > Software > Microsoft > Windows > CurrentVersion > Explorer
j’ai créé la valeur chaîne Max Cached Icons à 4096

Je pense qu’on aurait eu le même résultat en supprimant Iconcache.db
Il sera recréé automatiquement en supprimant les icones qui ne servent plus à rien.
Si un jour, il était à nouveau plein, c’est ce que je ferais.

Ceci dit, j’ai changé de disque externe sur lequel sont ces icones. J’espère que ce n’est pas dû à cela…