Forum Clubic

Probleme de port lors de creation d'un serveur ftp

bonjour,
je veux créer un serveur ftp à usage personnel.
en local tout marche

par contre cela se gate par acces distant :

1ere idée, j’ai voulu mettre un port autre que le 21
l’ouverture du parefeu nickel, nat oki avec redemarrage et prise en compte du port ouvert

lancement du ftp:
la connection et l’identification des comptes oki
le seul problème c’est qu’il n’ont pas accès à l’arborescence des fichiers partagés
j’ai réglé tout pour que ce soit bon (du moins à mon avis)
j’ai tester moult serveurs proposés sur clubic, aucun ne fonctionnait, d’où la conclusion que le problème ne venait pas de là

ne voyant que ça ne marchait pas non plus chez moi (un ami a eu le même problème et s’est donc rabattu sur le 21 qui lui marche), je tente le 21

et là oh grand desespoir le port 21 n’est pas accessible, aussi bien sous linux que windows
impossible de le faire fonctionner même en ayant libéré le port 21 en tcp et udp, même un client p2p pleure

j’ai un modem ST510v4 mode routeur
j’ai eu beau tout reset et refait ma config, rien ne veut passer pour ce port là seulement;

que dois-je faire? pourquoi on nous donne la possibilité de changer le port du ftp et que ça ne veut pas fonctionner pleinement?
si le 21 est impossible à utiliser et que seul ce dernier est utilisable ça sert à quoi?

merci de m’aider

Pour que cela fonctionne, il faut une ip fixe sur le serveur FTP, ouvrir ton port sur tes firewall…
Pour tester de chez toi, tu tapes ton ftp://(ton ip sur le net)

Si tu veux un autre port que le 21, tu refais la meme manip
Pour tester ftp://(ton ip sur le net):(ton port)

Le sigle ftp est par normalisation sur le port 21

c’est déja fait

Donc si c’est fait, ca fonctionne

Si ca marche pas, passe l’ip du pc serveur ftp en DMZ…
Si la ca fonctionne, tu n’as pas ouvert ton port 21…

Regarde bien la config de ton routeur, au pire donne moi sa reference…

je vais me répéter car tu sembles ne pas comprendre mon problème :

reference :
modem ST510v4 mode routeur (speed touch)

le problème c’est que le port 21, il ne veut pas en entendre parler (mes logiciels genre amule me mettent un warning indiquant que ce port est indisponible, ce qui revient à dire qu’il n’y a même pas une histoire de pare-feu, les ports non ouverts autres ne me provoque pas ce genre de message)
je precise que les pare feu windows et linux n’y sont absolument pour rien!

j’ai l’impression que ce modèle de routeur n’est pas en odeur de sainteté avec ce port 21

Amule est Emule version APPLE ou tu as fait une erreur de frappe ???
Tu veux du ftp ou configurer la mule car le problème franchement différent et les routeurs cisco de ton FAI font la différence très facilement… Cela s’appelle du filtrage ip !!!

J’ai eu un speedtouch pendant de nombreuses années chez FT et mon serveur FTP a fonctionné pendant de longues années !!!!

Au risque de me repeter, en DMZ aucun filtrage de port n’est effectué, le port 21 sera forcement ouvert mais si tu cherches à y faire passer autre chose que du FTP, linux, windows et Mac Os ne te le permettront pas…

amule est un client p2p utilisable sous linux mais ce n’est pas pas le vrai probleme
le problème c’est que le port 21 merdouille quand je le mets pour les différents serveur ftp que j’ai testé : filezilla, guildftp…

concernant ta fameuse dmz :
je me suis mis sous windows en mode modem solo (connection par le soft du FAI)
mes ports sont libres sauf le 21 qui ne veut toujours pas permettre ne serait-ce que l’identification des accès, ce que les autres ports permettent (le listage ne marche pas avec les autres par contre)

Le parametre DMZ est sur ton modem/routeur (DeMilitaryZone)… Et je ne sais pas commet te l’ecrire mais une fois activé, il n’y a plus de filtrage matériel… Donc si ca passe pas, ca ne vient pas du modem…

Moralité: Si tu as mal au coude, soigne le genoux et auras toujours mal au coude :ane:

d’où cela peut-il venir si ça ne vient pas du modem?
pourquoi ne peut-on pas utiliser un autre port pour le ftp alors que les soft proposent d’autre ports? (le listage est impossible mais l’authentification est bonne sur les autres ports)

alors que le port 21, ouvert dans les memes conditions que ces autres ports ne permet même pas l’authentification et la connection?

le dmz?? quand tu mets en mode modem le speedTouch, wan = lan, donc pas de ports fermés, la vraie passoire

donc si le mode modem (ou equivalent du dmz) ne marche pas du tout pour ce port 21 que faut-il faire?

(je répète que pour les autres, l’autentification sur le serveur se fait avec le pare feu windows, qui lui autorise les serveurs, mais le listage des fichiers présents est impossible par le net alors qu’en local tout marche nickel)

En ce qui concerne le port 21, je ne peux pas trop t’aider. Par contre, quand tu utilises un autre port et que tu n’as pas la listage, cela peut venir de la connection en mode passive qui est impossible car tu n’as pas ouvert une plage de port publique >50 000.

Si l’erreur vient de ca, dans le listing de ta connexion au serveur FTP, il doit bloquer sur une commande qui s’appelle “PASV” normalement. Bref, si c’est le cas, dis le et je t’expliquerait comment faire plus en details. Pour tester ton ftp, utilises ca, cest pas mal du tout!

voila ce que le client ftp distant dit (port 23513) :
Commande : LIST
Réponse : 150 Opening ASCII mode data connection for /bin/ls (123 bytes).
Réponse : 425 Can’t build data connection.
Erreur : N’a pas pu récupérer la liste du répertoire
Commande : TYPE A
Réponse : 200 Type set to A.

avec le lien de test :

mode pasv :

  • About to connect() to 86.xxxxxxport 23513
  • Trying 86.xxxxxxx… connected
  • Connected to 86.xxxxxxxx (86.xxxxxxx) port 23513
    < 220-GuildFTPd FTP Server © 1997-2002
    < 220-Version 0.999.14
    < 220 Please enter your name:

> USER dede
< 331 User name okay, Need password.

> PASS *****
< 230 User logged in.

> PWD
< 257 "/" is current directory.

  • Entry path is ‘/’

> CLNT Testing from http://www.g6ftpserver.com/ftptest from IP 86.xxxxxx
< 500 ‘CLNT’: command not understood.

  • QUOT command failed with 500

  • Connection #0 to host 86.xxxxxxxx left intact

  • Closing connection #0

mode epsv :

  • About to connect() to 86.xxxxxxxx port 23513
  • Trying 86.xxxxxxxx… connected
  • Connected to 86.220.230.127 (86.xxxxxxxx port 23513
    < 220-GuildFTPd FTP Server © 1997-2002
    < 220-Version 0.999.14
    < 220 Please enter your name:

> USER dede
< 331 User name okay, Need password.

> PASS *****
< 230 User logged in.

> PWD
< 257 "/" is current directory.

  • Entry path is ‘/’

> CLNT Testing from http://www.g6ftpserver.com/ftptest from IP 86.xxxxxxxx
< 500 ‘CLNT’: command not understood.

  • QUOT command failed with 500

  • Connection #0 to host 86.xxxxxxxx left intact

  • Closing connection #0

concernant le port 21 en mode modem :

  • About to connect() to 86.xxxxxxx port 21
  • Trying 86.xxxxxxx… connected
  • Connected to 86.xxxxxxx (86.xxxxxxx) port 21
  • FTP response reading failed
  • Closing connection #0

j’ai tester avec des serveurs ftp plus simples tel typsoft, c’ets la même chose

j’espère que ça peut t’aider à comprendre

j’ai téléchargé le logiciel proposé sur le site du test

je l’ai installé et j’obtient ceci lors du test :

  • About to connect() to 86xxxxxxxx port 23513
  • Trying 86.xxxxxxxxx… connected
  • Connected to 86.xxxxxxxx (86.xxxxxxxx) port 23513
    < 220 Gene6 FTP Server v3.8.0 (Build 34) ready…

> USER dede
< 331 Password required for pingur.

> PASS *****
< 230 User dede logged in.

> PWD
< 257 "/" is current directory.

  • Entry path is ‘/’

> CLNT Testing from http://www.g6ftpserver.com/ftptest from IP 86.xxxxxxxxxx
< 200 Noted.

> FEAT
< 211-Extensions supported:
< AUTH TLS
< CCC
< CLNT
< CPSV
< EPRT
< EPSV
< MDTM
< MFCT
< MFMT
< MLST type*;size*;create;modify*;
< MODE Z
< PASV
< PBSZ
< PROT
< REST STREAM
< SIZE
< SSCN
< TVFS
< UTF8
< XCRC "filename" SP EP
< XMD5 "filename" SP EP
< XSHA1 "filename" SP EP
< 211 End.

> PASV

  • Connect data stream passively
    < 227 Entering Passive Mode (10,0,0,1,231,11)

  • Trying 10.0.0.1… Timed out

  • couldn’t connect to host

  • Connection #0 to host 86.xxxxxxxxxx left intact

  • Closing connection #0

donc si j’ai bien configuré, je tombe sur l’erreur dont tu m’a parlé

bon le seul hic c’est que ce serveur n’est pas gratuit (du moins un shareware) :neutre:

La solution du DMZ est une solution de diagnositique pour eliminer le filtre du modem.

Pour tester tes ports utilise
https://www.grc.com/x/ne.dll?bh0bkyd2
C’est gratuit…Tu as le détail aussi des utilisations normalisés des ports et de règles de refus de routage…

Le routage du port 21 par définition ne peut s’effectuer (en général) que sur des ip fixe.
Pour un essai, remplace tom modem par un en usb sans fonction avancé (voir un RTC mais bonjour la lenteur)–> si ca marche pas, le refus est sur ton pc et pas ailleur…

Pour solutionner ton problème, il faut proceder par elimination pour trouver le fautif (par exemple un norton mal desinstallé) et proceder par essai successif.

Bon, mon collegue s’efforce de regler le probleme du port 21 pour toi, moi je vais m’efforcer de regler le probleme du mode passif! lol

Donc le probleme vient bien du mode passif qui ne marche pas sur ton serveur ftp. En gros, lors de la connecxion à ton serveur FTP, les deux entités établissent une connexion bis pour le transfert des données via le mode passif (je ne suis pas certain de l’exactitude de cette explication mais la connexion bis est établie, c’est certain).

Cette connexion se fait en général sur les ports publics > 50 000 donc il faut que tu ouvres une plage de ports dans tes firewalls (par exemple 50 000 à 50 500). Etant donné que c’est des ports publics, le risque d’intrusions est faible.

Une fois cette plage de ports ouverts, il faut que tu ailles dans la configuration de ton serveur FTP et que tu lui spécifies la plage de ports exacte que tu as choisie pour le mode passif. Je ne sais pas precisement si cette option existe dans tous les serveurs, je sais que sur FileZilla Server, elle y est.

Essai déjà ca et on verra par la suite les éventuels nouveau probleme.

je ne sais pas ce qui se passe sur mon pc actuellement:

je susi en mode modem pur et que vois-je :

le ftp sur mon port autre que le 21 marche (alors que hier soir dans les mêmes conditions ça ne voulait pas)
le 21 merdouille toujours, sans doute une histoire d’ip fixe comme le dit fnac.

pour l’instant j’essai de comprendre pourquoi ça marche maintenant et pas avant
bon j’ai trifouillé dans windows mais j’ai tout remis omme c’était avant (ah si j’ai installé la version 6 du protocol tcp/ip), installer la version installer de typsoft ftp
le reste n’a pas changé

par contre le test echoue toujours sur CLNT alors que ça fonctionne (peut être une commande inconnue des deux soft que je teste : typsoft ftp derver et guildftpd??)

je vais testé ensuite en mode routeur avec l’ouverture des ports.
si cette fois ça ne marche pas, on saura d’où ça vient
je me concentre sur les ports autres que le 21 pour le moment car c’est les plus proche du fonctionnement optimal

IP v6 est livré avec Windows XP, il suffit de l’installer mais je ne vois pas en quoi ce la va t’aider…

bon ba en mode routeur ça fait le même problème que hier

le hic avec ce routeur c’est que je ne peut pas ouvrir une plage de ports, du moins ce n’est pas aussi visible à utiliser que les vrais routeurs

ouverture de port un par un pas de problème , par contre la plage i don’t know

:frowning:

Pour ton probleme de commande CLNT, j’ai eu le meme probleme que toi en configurant mon serveur sous TypeSoft. Le probleme vient tout simplement du fait que ce logiciel n’est pas assez complet (je crois) et qu’il ne doit gérer que les serveurs dans des configurations réseaux assez restreintes. Si tu as un serveur NAT par exemple dans ton reseau, il ne doit pas supporter cette configuration. Je t’invite donc à ne pas utiliser ce soft.

Pour le problème de la plage de ports, ouvre seulement une dizaine de ports un par un, je pense que ca devrait etre suffisant et dis moi ce que tu obtients.

test avec guildftpd :

j’ai ouverts les ports 50000 à 50010
j’ai mi en option cette gamme là

les tests sur le site se sont révélés identiques mais c’est normal vu que la commande clnt ne marche pas également pour ce serveur là

mon collègue testeur (sympa de m’aider) a tou d’abord essayer de se connecter sous linux sur mon serveur
aucun problème, il a vu tous mes fichiers et telechargement ok

il va sous windows : problème, listage impossible encore
il force le mode passif, ça marche impec

de mon côté, avec filezilla je me connecte sur l’adresse de mon ftp (ie et filezilla) : ça bug
dans la fenetre de connection on voit que je tente de me connecter mais deconnection immediate (il n’arrive pas a demander le compte)

je ne sais pas si cela est normal

je vais faire quelques tests supplémentaires pour voir si mon client ne me joue pas des tours mais pour l’instant ta solution semble marcher, en bidouillant certe mais ça semble marcher. merci :love:

Ok donc ton probleme principal, c’est le passage en mode passif qui ne se fait pas bien. Essai de bidouiller dans les options du mode passif de ton serveur ftp et ca pourra éventuellement marcher.