Forum Clubic

Problème de lecture de fichier mp4

Malgré le chargement des codecs klite 4.1.7 ou fdd show ou du lecteur vlc (tout cela petite à petit et en supprimant les éléments précédemment installés) impossible d’avoir son et image, j’obtients juste le son… Une idée ?


Petite précision supplémentaire en mettant à jour les drivers de ma 7800 GT c'est encore pire : autant avant je pouvais voir un aperçu ou avoir quelques secondes de vidéos autant maintenant je n'ai plus rien du tout ... Ils sont tous C--S chez Nvidia ? :@

Utilise l’utilitaire GSpot qui est installé avec KLite pour voir quel est le codec video.
Chez moi, VLC lit très bien les vidéos mp4 encodées en avc1 (H.264/MPEG-4 AVC).

Media Player Classic fonctionne aussi mais j’ai la version HC (Home Cinema) et ça dépend quels filtres on utilise (internes à MPC ou pas). Avec VLC qui n’utilise pas les codecs de Windows, il ne devrait pas y avoir de problèmes de configuration.

Après vérification sur GSpot je suis bien en avc1 H.264/MPEG-4 AVC mais la lecture sur VLC ne fonctionne pas (son mais pas image) -> je crois de plus en plus que cela vient des pilotes nvidia)

Dans VLC, regarde si la sortie est en GDI.

Bien que ton problème n’ait rien à voir, tu peux quand même jeter un œil la dessus:
http://www.clubic.com/forum/hardware-general/ecran-noir-intermittent-blocage-et-reboot-id535784-page1.html

Je remet la partie qui peut t’intéresser et que j’ai posté sur l’autre sujet.
Les players passent souvent par une couche de DirectX pour afficher les vidéos mais on peut changer ce paramètre : dans VLC, coche la case avancé et va dans Video puis Output Modules et change la valeur.
Essaie aussi avec Media Player Classic, on peut facilement changer le mode (Options/Playback/Output/DirectShow Video)

Les modes qui n’utilisent pas DirectX pour lires les vidéos sont:
-pour MediaPlayerClasssic:Overlay Mixer.
-pour VLC: Windows GDI et OpenGL.

Merci pour vos réponses,

Après la passage de VLC en GDI (test aussi sur Media Player Classic) je récupère l’image mais c’est horriblement saccadé (ma config : Geforce 7800 GT + AMD 3500 + OC à 2.48 Ghz + 1 Go RAM sous XP) -> une autre bonne idée ?
Edité le 30/08/2008 à 20:31

Le mode Windows GDI est probablement celui qui consomme le plus de ressources processeur, mais je ne sais si c’est normal que ça saccade avec ta config (sur la mienne, ça utilise environ 20% du CPU pour une video en 640x480 encodée en H.264/MPEG-4 AVC).

Est-ce que tu as la dernière version pour tout?
-driver nVidia 175.19
-DirectX 9.0C ( essaie de mettre à jour avec la dernière version DirectX 9.0C juin 208).
-VLC 0.8.6i

Est-ce que la carte vidéo fonctionne bien dans les jeux ?
Fait un test avec dxdiag (démarrer/exécuter: dxdiag) : 3eme onglet : vérifie si tout est normal (accélération DirectDraw activée, pas d’erreurs signalée) et teste DirectDraw.

Tu peux essayer de changer quelques options dans VLC
-Video : cocher ou décocher “Overlay”

  • Video / Output module (mode avancé): forcer “DirectX video” ou “DirectX 3D video”

OK je vais essayer tout cela mais sinon j’ai bien la dernière version pour nvidia et VLC (j’ai un doute pour direct X)

DirectX 9.0C de Mars 2008 sur clubic: http://www.clubic.com/telecharger-fiche10906-directx.html

Chez Microsoft 9.0C Août 2008: http://www.microsoft.com/downloads/details.aspx?familyid=2da43d38-db71-4c1b-bc6a-9b6652cd92a3&displaylang=fr