Forum Clubic

Probleme de droit de lecture sur disque SATA - Tout apparait en "Lecture seule"...!

Bonjour,

j’ai le probleme suivant dont je ne trouve aucune solution en cherchant sur le net :

ma partition systeme (C:\) et une deuxieme partition (D:\) sur laquelle je stocke mon serveur web et tout ce qui tourne autour (car c’est un Raptor donc 10000tr/min acheté expres pour cela) est en lecture seule (bien que je n’en ai pas tellement l’impression puisque j’ecris tres bien dessus, mais il est vrai que des probleme bizarre sur mon pc me font penser qu’il y a quand meme un probleme), je veux dire que tous les repertoires de ces 2 partitions affichent dans leurs propriétés la case “Lecture seule” deja cochée, et si j’enleve la coche et que je dis d’appliquer au dossier et tous ses sous dossier, au prochain affichage des propriétés, elle est de nouveau cochée !

Ces 2 partitions se trouve sur le meme disque physique, a savoir un disque Serial ATA - Western Digital Raptor 74 Go lui meme connecté sur le port serial ATA de ma carte mere ABIT A8N equipé du Nforce4.

Mon disque dur apparait dans l’outil pour retirer les peripheriques en toute securité dans la barre des taches (je ne sais pas si c’est normal avant je n’avais pas de disque SATA, mais il est ecrit dans des forums que cela est du au fait que les peripheriques SATA sont HOT-PLUG et peuvent donc etre desactivés par ce biais pour etre debrancher).

Je pense que le probleme viens peut etre de la car, une partition est en FAT32 et l’autre en NTFS, et les 2 ont le probleme.

Quelqu’un aurait il une idée pour resoudre cela ? J’en pert la boule :pt1cable:

Etant developpeur PHP j’ai tres souvent des problemes de droit au niveau des repertoires et fichiers qui sont sur mon serveur (qui sous linux peuvent etre resolus par CHMOD ou autre mais sous windows, par en decochant la case lecture seule…) et la par exemple je souhaites installer Gallerie pour tester et cela me demande de modifier les droits du repertoire d’installation mais cela m’est encore une fois impossible… (pourtant les logs apache, les fichiers temporaires system etc… etc… s’ecrivent bien pourtant)

Merci d’avance de toute aide qui pourra m’eviter l’asile lol.

personne n’a une idée :frowning: ?

La case est cochée avec une belle coche sur fond ou blanc ou avec une coche sur fond gris ou avec un carré bleu ?

Pour changer les droits sous Windows, c’est clic droit => propriété => sécurité

C’est indiqué avec un carré vert dans le carré “lecture seule”

Peut importe sur quel dossier, et peut importe la partition C: ou D: c’est tout le disque qui est comme ca… Et comme je le dis dans mon descriptif du probleme, j’ai beau decocher la case “lecture seule”, cela fait bien la procedure, me demande bien si je veux appliquer au sous dossier etc… mais apres avoir fini, je reclique “bouton droit” ==> “propriétés” et la de nouveau j’ai ce carré vers dans la case “lecture seule”.

Ce probleme n’est que sur mon disque connecté en Serial ATA, j’ai 2 autres disque dur en IDE (PATA) et je n’ai jamais vu ce probleme sur aucun des 2, ni meme d’ailleur jamais… :frowning:

Voila une capture des proprietes d’un dossier (tous les dossiers et fichiers sont pareils) :

Up :’(

C’est normal :neutre:

Mais c’est quoi ton probleme ? :riva:
J’ai lu un descriptif (complet) de ta config et tes remarques sans savoir ce que tu voulais exactement.

  1. Le sata en bas dans ta barre de tache c’est normal.
    Si tu veux plus le voir s’est simple, demande a ton bios de l’emuler comme un D.D ATA. Il doit pourvoir le faire si c’est une carte recente.

  2. Les repertoires en lecture seule ? bin, c’est normal, on ecrit dans un fichier pas sur un repertoire.

  3. Si tu veux que n’importe quoi/qui puisse ecrire dans un repertoire tu fais “Outils” —> Option des dossiers —> affichage —> décoche “partage simple”
    Puis tu vas dans propriétés de ton dossier et l’onglet securité.
    Tu fais “ajouter”, tout le monde, et tu coches dans “autoriser” tout les droits.
    Tu vas ensuite dans “parametres avances” puis tu coches “Remplacer les entrées d’autorisation de tous les objets enfants …” et OK.
    Evite de partager ce dossier car, maitenant tout le monde a tous les droits.

LOL bon et bien vous avez repondu a ma question en fait, ayant l’habitude de regarder les droits sous linux et pas trop sous windows, je ne savais pas qu’un repertoire pouvais etre affiché avec un carré dans lecture seule… (ce qui n’etait pas logique dans ma tete… Je pensais que si il existait une case a cocher dans la fenetre du repertoire c’etait que l’on pouvait penser que l’on peu mettre le repertoire en lecture seule et faire que tout ce qu’il contiendra plus tard sera en lecture seule, ou alors un peu comme la case du dessous pour rendre un dossier caché).

Je me suis completement embrouiller à chercher un probleme la ou il n’y en avait pas (a cause de mon serveur web qui me mettait tout le temps des probleme de droit que je n’arrive pas a resoudre quelquefois…) j’ai compris cette logique desormait, il faut juste penser que cette case ne sert que pour modifier les propriétés de lecture seule de tout ce qu’il contient plus facilement (un peu comme pour faire un chmod -R).

Merci à vous et encore désolé de vous avoir déranger pour un probleme qui n’en etait pas un :sweet:.