Forum Clubic

Probleme de conversion XLS à CSV

Bonjour,

j’ai un petit soucis avec la conversion de fichier Excel en CSV. En fait, je créé des fichiers Excel pour effectuer des upload dans un logiciel de comptable, jusque là tout va bien, rien de bien sorcier. Les choses se compliquent à la dernière étape…

En effet pour uploader mon fichier dans le logiciel je dois le convertir de XLS à CSV, vous me direz “ça aussi pas sorcier jeune padawan”. Mais le soucis que je rencontre c’est apres la conversion…j’enregistre tout simplement mon fichier excel en fichier CSV(Dos) et quand je le réouvre pour vérifier que les colonnes sont respecter tout va bien. Malheureusement (eh oui) quand j’ouvre ce même fichier sur le pc de n’importe qui en fait les colonnes ne sont pas respecter et tout est dans une seule.

Et de ce fait marche pas mon upload, et à moi les milliers de lignes d’ecritures comptable à saisir manuellement dans le logiciel…et j’ai mal aux yeux :slight_smile:

On m’a déjà dit qu’il faut aller dans les options d’Excel mais riend e plus précis.

Merci de votre aide

Bonjour,

Avez-vous essayer d’ouvrir le fichier .CSV ainsi créé avec WordPad ?
A essayer ?

Amitiés & @+

La première chose à faire est d’ouvrir le fichier CSV avec un éditeur de texte (notepad suffit, mais un éditeur sachant afficher le texte et l’hexadécimal, genre pspad est préférable) pour repérer quel est le séparateur utilisé.

Ensuite, il faut vérifier sur le PC d’accueil que le séparateur par défaut est bien le même. Le problème se produit souvent entre les fichiers séparateur ‘virgule’ et les fichiers séparateurs ‘point virgule’.

Si le problème est là, la seule solution que je connaisse est la suivante :
renommer le fichier en txt
A l’ouverture, le PC affichera l’assistant, et il sera possible de choisir le bon séparateur.

Attention, c’est ce choix qui deviendra alors l’option par défaut du CSV, d’où problèmes possibles avec les autres fichiers qui fonctionnaient bien sur ce PC

Bonjour à tous,

j’ai essayé diverses solutions et …ça change rien. Alors voilà mon séparateur est ; celui de mes collègues est ; donc normalement tout le monde devrait voir la même chose quand il ouvre un un fichier CSV fait par ma machine. et ce n’est pas le cas, moi il a le format voulu cad tout est bien formatter en colonne et non par des séparateurs (j’ouvre avec excel). Mais sur les machines des autres et aussi quand le fichier est uploadé dans le logiciel comptable tout se trouve dans une colonne et les données sont séparées par des ; et ça c po bon di tout

Je sais la meilleur solution c’est de changé de pc, voir de logiciel comptable (ou encore moi :-))) mais je peux pas

Merci beaucoup j’ai solutionné le probleme, il s’agissait d’un soucis de configuration de mon pc (il était en français alors que je travail sur des bases US)