Forum Clubic

Problême de compilation GNU GCC mingw32, Vista - cc1plus introuvable

Bonjour, je teste actuellement la RC1 (rc 5600) de Windows Vista 64 bit, et pour mes études, j’ai besoin d’utiliser un IDE pour la programmation C/C++. J’utilise donc Code Block, seulement, une erreur apparait à la compilation (quelque soit le code source), une erreur de lien apparament, qui apparait aussi sous DevC++.

Or cet excecutable existe bien et est à sa place habituel, je ne sais donc pas d’où vient le problême, je me retrouve obligé d’utiliser Visual C++ Express Edition que je n’apprecie pas beaucoup.
Auriez vous une idée, car je un peu du mal avec la configuration des compilateurs.

(ps: j’ai fait des recherches, mais aucun resultat tangible).

Merci de votre aide.

Essaye de mettre ton fichier dans un dossier sans espace?

Qu’entends tu par mon fichier?
Mon fichier source? Le repertoire d’installation?

A mon avis il voulait dire: placer tes sources dans un chemin sans espace.

Donc tu places ta source dans un dossier à la racine et pas dans un "Program Files" ou "Document and settings" qui contiennent des espaces.

En ayant installé CodeBlock directement à la racine C: (et le source avec), le problême reste d’actualitée. :confused:

Tu n’es pas le seul à avoir ce problème ==> ici

Je ne sais pas si google pourrait te donner un début de réponse… (tu cherches juste cc1plus dans google et tu trouves le même problème).

Ce problème semble être lié avec Vista (selon les forums), j’ai eu le même problème avec MinGW et je poste ici la solution à mon problème.

A la compilation j’avais :
gcc.exe: installation problem, cannot exec cc1': No such file or directory g++.exe: installation problem, cannot execcc1plus’: No such file or directory

Il a suffit que je rajoute dans le path windows le repertoire suivant :
C:\MinGW\libexec\gcc\mingw32\3.4.5

En conclusion vous devez juste rajouter le répertoire contenant cc1.exe ou cc1plus.exe dans la variable PATH.
Simple mais il fallait y penser… J’espère que celà résoudra le problème pour vous!