Forum Clubic

Problème d'accès au disque dur

Bonsoir,

Autre mes soucis de carte réseau, quand je veux ouvrir mes disques durs, il me dit qu’il est impossible de monter ce volume :confused:

Il y a généralement deux causes possibles:

  • tu n’es pas administrateur et n’a donc pas le droit de faire ça …

  • le système de fichier que tu essayes de monter n’est pas connu : soit, il n’est vraiment pas connu, soit le pilote n’est pas chargé ( si c’est du ntfs, essaye un modprobe ntfs d’abord )

je vais essayer ton “modprobe” mais ça se fait dans le terminal?
Je suis connecté à mon compte utilisateur car il ne veut pas me connecter avec le mode administrateur. Mais je suis censé avoir tous les droits.
Je vais essayé le modprobe puis de me connecter en mode admin si j’y arrive lol

Ce sont des dd classiques, dont 2 ntfs avec des fichiers dedans, mon dd ext pareil et 1 dd neuf qu’il faut formater :frowning:


Alors, apparemment, je n'ai pas de session "administrateur", je les ai toutes essayé: admin, Admin, administrateur... donc ce doit mas session Ensuite, j'ai lancé le modprobe ntfs mais ça n'a rien fait du tout dans le terminal ni sur les disques durs :(

Il y a un compte administrateur qui sous Unix est l’utilisateur “root” .
Généralement, l’ouverture d’une session graphique sous root est interdit.

Si tu es sous gnome, dans le menu applications, accessoires, tu devrais avoir “terminal administrateur”
qui va te demander le mot de passe de root ( que tu as défini à l’installation )

Tu peux faire un modprobe ntfs

Ensuite, pour voir comment s’appellent tes disques:
fdisk -l

Le premier s’appelle sda , puis sdb , … selon leur ordre sur les controleurs .
Les 4 premieres partitions sont numérotées de 1 à 4 ( sda1, sda2, sda3, sda4 )

Les 16 lecteurs logiques possibles sont numérotés à partir de 5 ( sda5, sda6 , … )

Pour monter une partition:

  • créer un dossier: ex mkdir /mnt/mon_disque
  • monter la partition de ton choix mount -t ntfs /dev/sd /mnt/mon_disque

Habituellement, sous gnome, dans raccourcis, il y a toutes les partitions détectées, il suffit de cliquer dessus pour les monter.

Merci pour ton aide mais quand je tape ta 2 ème ligne de commande, “bash: a: Aucun fichier ou répertoire de ce type” :-S

il faut que tu remplace par quelque chose de pertinent sur ton systeme
ex:
mount -t ntfs /dev/sda1 /mnt/mon_disque
-> montage de la premiere partition primaire du premier disque

Ca ne marche pas :(. Voici ce que ça me dit:

serveur:/home/benoit# fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000a5350

Device Boot Start End Blocks Id System
/dev/sda1 1 58336 468581376 83 Linux
/dev/sda2 58336 60802 19802112+ 5 Extended
/dev/sda5 58336 60802 19802112 82 Linux swap / Solaris

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xdee4dee4

Device Boot Start End Blocks Id System
/dev/sdb1 1 60801 488384001 7 HPFS/NTFS

Disk /dev/sdc: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x2c8a2c89

Device Boot Start End Blocks Id System
/dev/sdc1 * 1 38913 312568641 7 HPFS/NTFS

Disk /dev/sdd: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x4b80f225

Device Boot Start End Blocks Id System
/dev/sdd1 1 60801 488384001 7 HPFS/NTFS

Disk /dev/hdc: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000ae923

Device Boot Start End Blocks Id System
/dev/hdc1 * 1 851 6835626 83 Linux
/dev/hdc2 852 14593 110382615 5 Extended
/dev/hdc5 852 1419 4562428+ 82 Linux swap / Solaris
/dev/hdc6 1420 14593 105820123+ 83 Linux
serveur:/home/benoit# mount - ntfs /dev/sda /mnt/FreeAgent
Usage: mount -V : print version
mount -h : print this help
mount : list mounted filesystems
mount -l : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere’.
Details found in /etc/fstab may be omitted.
mount -a [-t|-O] … : mount all stuff from /etc/fstab
mount device : mount device at the known place
mount directory : mount known device here
mount -t type dev dir : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
mount --bind olddir newdir
or move a subtree:
mount --move olddir newdir
One can change the type of mount containing the directory dir:
mount --make-shared dir
mount --make-slave dir
mount --make-private dir
mount --make-unbindable dir
One can change the type of all the mounts in a mount subtree
containing the directory dir:
mount --make-rshared dir
mount --make-rslave dir
mount --make-rprivate dir
mount --make-runbindable dir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using -L label or by uuid, using -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say man 8 mount .

mount - ntfs /dev/sda /mnt/FreeAgent

Bon déjà, il manque le t du type de partition mount -t
Ensuite, /dev/sda ne peut etre monté, c’est un disque entier et non une partition.

Tu peux monter
/dev/sdb1 : apparemment 500Go
/dev/sdc1: apparemment 320Go
/dev/sdd1: apparemment 500Go

J’ai essayé "mount -t ntfs /dev/sda1 et voilà ce que ça donne:

debian:/home/benoit# mount -t ntfs /dev/sda1
Usage: mount -V : print version
mount -h : print this help
mount : list mounted filesystems
mount -l : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere’.
Details found in /etc/fstab may be omitted.
mount -a [-t|-O] … : mount all stuff from /etc/fstab
mount device : mount device at the known place
mount directory : mount known device here
mount -t type dev dir : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
mount --bind olddir newdir
or move a subtree:
mount --move olddir newdir
One can change the type of mount containing the directory dir:
mount --make-shared dir
mount --make-slave dir
mount --make-private dir
mount --make-unbindable dir
One can change the type of all the mounts in a mount subtree
containing the directory dir:
mount --make-rshared dir
mount --make-rslave dir
mount --make-rprivate dir
mount --make-runbindable dir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using -L label or by uuid, using -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say man 8 mount .


Désolé de mon absence, mais j'ai dû m'absenter cette semaine...:(

Il te manque un bout de ta commande.

commande: mount
premier argument, le type de système de fichier s’il n’est pas détecté : -t ntfs
ensuite, ce que l’on veut monter , ex /dev/sda1 dans ton cas: /dev/sda1
finalement, l’emplacement ou le monter ( dossier qui existe ) ex /mnt/sda1

donc:

modprobe ntfs

mkdir /mnt/sda1

mount -t ntfs /dev/sda1 /mnt/sda1

Tu peux accéder à tes données à partir du dossier /mnt/sda1

J’ai réessayé mais toujours pas accès aux disques :-S